О движке

Общая информация по движку

Navigation: Общая информация >

Общая информация по движку

 Return to chapter overview

DataLife Engine v.11.1 - это многопользовательский новостной движок, обладающий большими функциональными возможностями. Движок предназначен, в первую очередь, для создания новостных блогов и сайтов с большим информационным контекстом. Однако он имеет большое количество настроек, которые позволяют использовать его практически для любых целей. Движок может быть интегрирован практически в любой существующий дизайн и не имеет никаких ограничений по созданию шаблонов для него. Еще одной ключевой особенностью DataLife Engine - является низкая нагрузка на системные ресурсы. Даже при очень большой аудитории сайта нагрузка на сервер будет минимальной и вы не будете испытывать каких-либо проблем с отображением информации. Движок оптимизирован под поисковые системы, что приведет на ваш сайт дополнительных клиентов. Использование продвинутой технологии AJAX позволит вам сэкономить вам ваш трафик и трафик посетителей, а также снижает нагрузку на сервер.


Общие Возможности

Navigation: Общая информация >

Общие Возможности

 Return to chapter overview

DataLife Engine обладает следующими возможностями:

Общие возможности:

?Использует для хранения данных MySQL

?Минимальная нагрузка на базу данных

?Использование продвинутой технологии AJAX

?Вывод новостей, статей, да и вообще всего что угодно

?Поддержка ЧПУ (человеко-понятный URL) позволяет использовать тему статьи или любой другой текст в URL браузера, благодаря этому индексация сайта в поисковых системах будет более качественной (необходим modrewrite)

?Возможность отключения ЧПУ

?Общая статистика сайта

?Поддержка дополнительных полей (возможность использовать не только краткую и полную новость на сайте, но и имеется возможность для создания любого количества дополнительных полей различных видов для ввода информации)

?Возможность написания статей, содержащих несколько страниц

?Флуд контроль

?Автоматический фильтр слов в комментариях

?Поддержка категорий

?Возможность установки любого количества вложенных категорий

?Каждой категории можно назначить отдельный шаблон

?Автоматическое обрезание длинных слов в комментариях

?Рейтинг новостей

?Календарь

?Поиск по статьям включая дополнительные поля (подсветка найденного текста)

?Обзор непрочитанных новостей с момента последнего посещения сайта

?Возможность просмотра сколько раз была прочитана новость

?Возможность добавления статей в раздел "Избранное"

?Отсылка писем пользователям через форму на сайте

?Вывод страницы используя сжатие gzip

?Поддержка персональных сообщений между пользователями

?Поддержка нескольких языков

?Вывод популярных статей в отдельном блоке

?Возможность создания статистический страниц непосредственно через админпанель

?Возможность выбора между упрощенной регистрацией и расширенной, при выборе расширенной регистрации пользователь будет зарегистрирован только после активации аккаунта. Активация высылается по почте.

?Возможность загрузки и прикрепления файлов к новостям

?Встроенные средства защиты от несанкционированного скачивания файлов (antileech)

?RSS Импорт новостей

?RSS Информеры

?Мультиязычная поддержка новостей на сайте

?Поддержка Облака Тегов

?Автоматическая поддержка смартфонов

Возможности для посетителей сайта:

?Регистрация на сайте

?Добавление комментариев

?Изменение и удаление пользователями своих собственных комментариев

?Возможность добавления новостей со стороны посетителей

?Модерирование новостей

?Статистика по конкретному пользователю (включая рейтинг и профиль)

?Вывод различной информации для зарегистрированных посетителей и нет

?Возможность загрузки фотографии в профиле пользователя

?Возможность восстановления забытого пароля

?Возможность редактирования новости непосредственно на сайте

?Смена скинов на сайте по своему усмотрению

?Ведение закладок для новостей, и быстрый доступ к ним.

?Массовая загрузка картинок на сервер

?Просмотр и добавление видео на сайт

?Персонализация вывода рекламы для определенных групп

?Возможность загрузки большого количества картинок и файлов в один клик

?Система жалоб "в один клик", на ошибки, новости, комментарии, персональные сообщения

Возможности админцентра:

?Добавление, редактирование и удаление новостей

?Полностью настраиваемая админпанель для различных групп пользователей

?Возможность использования двух редакторов (BBCODES или WYSIWYG)

?Антивирус проверяющий состояние файлов на предмет возможного взлома

?Редактирование пользователей

?Имеется возможность использовать смайлы и HTML код

?Неограниченное создание групп пользователей с тонкой настройкой различных прав доступа

?Возможность выставления бана для посетителей

?Средства для создания и редактирования шаблонов непосредственно в админцентре

?Возможность корректировки времени

?Возможность изменения даты публикации

?Автоматическая публикация статьи при наступлении установленного времени

?Возможность отключения календаря и архивов (для экономии ресурсов)

?Возможность фиксации новостей (будут всегда наверху, независимо от даты)

?Отключение регистрации посетителей

?Автоматическая временная приостановка регистрации при достижении максимального количества зарегистрированных пользователей

?Автоматическое уменьшение загруженных картинок с сохранением пропорций до указанных размеров

?Автоматическое удаление пользователей которые не посещали сайт заданное время

?Наложение водяных знаков на картинки

?Возможность загрузки картинок для каждой конкретной новости (при удалении новости, картинки тоже будут удаляться)

?Удобный менеджер загруженных картинок

?Оптимизацию, ремонт, создание резервной копии и восстановление базы данных можно осуществлять непосредственно из скрипта

?Поиск пользователей по IP адресам

?Удобное управление рекламными материалами.

?Быстрый поиск и замена в базе данных

?Публикация "правил" на сайте

?Создание карты сайта для Google

?Создание фильтров для автоподстановки слов и значений

И много других полезных функций...


Список изменений

Navigation: Общая информация >

Список изменений

 Return to chapter overview

Список изменений относительно версии 11.0:

qДобавлена возможность загружать на сервер изображения к публикуемым на сайте комментариям. Данная возможность включается и настраивается в настройках групп. Для каждой группы пользователей вы можете разрешить или запретить загрузку изображений к комментариям. Также для каждой группы вы можете задать различные отдельные параметры для загружаемых изображений, например, максимальное количество загружаемых изображений к комментариям, их размеры и вес и т.д. При загрузке изображений к комментарям пользователю доступна упрощенная форма загрузки комментариев, и изображения загружаются согласно заданным в настройках групп параметрам. Пользователю при этом доступно управление своими загруженными изображениями. Он может их удалить или заменить, если ему разрешено редактировать свои комментарии.

qДобавлена поддержка движка InnoDB для базы данных MySQL. При установке скрипта вы можете выбрать, какой тип хранения использовать. Для выбора доступно использование либо InnoDB либо MyISAM. При выборе движка мы рекомендуем руководствоваться следующими критериями. Если ваш сайт будет редко обновляться новым контентом (регистрация большого количества пользователей, активное добавление новых комментариев и т.д.) т.е. сайт "справочник", то рекомендуется использовать MyISAM тип, он быстрее при выборке из базы данных. Если на сайте планируется активное обсуждение чего-либо большим количеством пользователей, то рекомендуется использовать InnoDB тип. Для большинства сайтов оптимальным выбором будет именно InnoDB, т.к. в будущем он более легко масштабируется. Выбор движка базы данных доступен только если на вашем сервере установлена версия MySQL не ниже чем 5.6.4. Если версия MySQL сервера ниже, то доступно использование только MyISAM.

qДобавлена возможность создания и использования плейлистов при воспроизведении видео на сайте. Для этого видеофайлы просто перечисляется в теге video через запятую. Например: [video=http://site.ru/video1.mp4,http://site.ru/video2.mp4,http://site.ru/video3.mp4]

qДобавлена возможность создания описания, для видео которое будет видно при показе в плеере, для этого в теге вставки видео используется следующий формат: [videо=путь к видео файлу|путь к постеру для видео|описание видео], тоже самое можно задать для всех файлов если используется плейлист файлов, добавленный через запятую. Пример отображения вы можете увидеть на скриншоте выше.

qДобавлена возможность использовать в теге [videо=...], также ссылки на видео в сервисе Youtube. Тем самым вы можете организовывать смешанные плейлисты включающие в себя ваше видео и видео на сервисе Youtube.

qДобавлена возможность создания и использования плейлистов при воспроизведении аудио на сайте. Для этого аудиофайлы просто перечисляется в теге audio через запятую. Например: [audio=http://site.ru/audio1.mp3,http://site.ru/audio2.mp3,http://site.ru/audio3.mp3]

qДобавлена возможность создания описания, для аудио которое будет видно при воспроизведении музыки в плеере, для этого в теге вставки аудио используется следующий формат: [audiо=путь к аудио файлу|описание аудио]. Пример отображения вы можете увидеть на скриншоте выше.

qДля аудио проигрывателя добавлена возможность добавления ссылок для воспроизведения потокового аудио. Тем самым вы можете задавать и выводить плейлисты для прослушивания на своем сайте радиостанций.

qВ настройки проигрывателей, в админпанели, добавлена возможность выбора темы для плеера. Для выбора доступна либо темная, либо светлая тема для плеера, что делает отображение плеера на вашем сайте более органичным.

qУлучшена процедура вставки видео и аудио материалов в редакторах. При добавлении видео, вы можете сразу создавать плейлисты, а также вы можете сразу задать в окне ввода не только ссылку на видео и аудио, но и ссылки к постерам для них, и описание для видео и аудио файлов.

qВ состав DataLife Engine добавлен новый WYSIWYG редактор. Название нового редактора FroalaEditor. Данный редактор обладает легким и понятным интерфейсом (на наш взгляд лучшим интерфейсом) для создания и редактирования контента, HTML код генерируемый им является одним из самых чистых и не имеет практически ничего лишнего, имеет относительно небольшой вес обладает быстрым рендерингом редактора на странице.

qДобавлен новый тип для дополнительных полей публикаций: "Загружаемая галерея изображений". При создании данного типа поля вы можете задать параметры для загружаемых изображений, а также максимальное количество изображений, которое может быть загружено для данной галереи. При добавлении публикации в админпанели или на сайте изображение можно будет загружать в один клик. При выводе данного поля на сайте, изображения будут группироваться в галерею картинок, которые также можно перелистывать между собой при просмотре, в случае если для картинок были созданы уменьшенные копии.

qДля дополнительных полей, имеющих тип "Загружаемое изображение" и "Загружаемый файл", добавлен автоматический запрет на повторную загрузку изображений и файлов, до тех пор, пока предыдущее загруженное изображение или файл не будут удалены. Тем самым снижается вероятность прикрепления к новости, не использующихся файлов и изображений.

qДля дополнительных полей, имеющих тип "Загружаемое изображение" добавлены новые теги: [xfvalue_thumb_url_X] и [xfvalue_image_url_X], которые выводят только URL для уменьшенной копии загруженного изображения и URL для полного изображения соответственно, где "X" это имя дополнительного поля. Данные теги будут полезны для вебмастеров, которые хотят персонального оформления загруженных публикаций на сайте, например, совместно с другими дополнительными полями.

qДля дополнительный полей, имеющих тип "Переключатель Да или Нет", добавлена возможность назначения состояния «Включено» или «Выключено» по умолчанию, которое будет использоваться при добавлении новой публикации.

qДобавлена возможность онлайн просмотра документов, загружаемых на сайт через скрипт DataLife Engine. Для этого в шаблон вывода загруженных файлов (attachment.tpl) были добавлены следующие теги: {online-view-link} который выводит ссылку URL на просмотр документа онлайн в браузере, а также теги [allow-online] текст [/allow-online], которые выводят заключенный в них текст, если загруженный документ имеет поддерживаемый для просмотра формат. Для онлайн просмотра поддерживаются следующие типы документов: Adobe PDF, Microsoft Word, Microsoft Excel. Просмотр документов происходит непосредственно в браузере посетителя, при помощи сервиса Google Docs Viewer, поэтому посетителям не нужно иметь установленные программы от Microsoft или Adobe.

qВ связи с тем, что разработчики WYSIWYG редактора LiveEditor решили прекратить какие-либо работы по данному редактору, и он уже не получал несколько лет каких-либо обновлений, было принято решение убрать данный редактор из состава DataLife Engine. Сайты, которые ранее использовали данный редактор, будут автоматически переключены на использование редактора FroalaEditor.

qДобавлена возможность задать описание изображений (атрибут alt) при массовой вставке изображений в новость. Для этого вам нужно выбрать нужные изображения, и кликнув по любому из них, задать описание. После чего нажать на кнопку "Вставить выбранное". Заданное описание будет также добавлено для всех картинок при вставке.

qДобавлен автоматический сброс кэша Zend OPCache при изменении настроек сайта. Тем самым, при включенном данном кешировании в настройках сервера, вам не нужно самостоятельно сбрасывать кэш, или ждать пока изменения вступят в силу.

qПри просмотре списка категорий в админпанели, в разделе редактирования категорий, изменен вид отображения списка категорий. Теперь все подкатегории показываются в свернутом виде, и могут быть открыты непосредственно при необходимости для конкретной родительской категории. А также добавлены кнопки, благодаря которым можно быстро в один клик развернуть или свернуть все категории в списке. Добавление новой категории осуществляется в всплывающем окне. Тем самым упрощается работа с большим количеством категорий и подкатегорий в админпанели.

qДобавлена возможность отписать всех пользователей, подписанных на комментарии, для каждой новости отдельно. В случае если у новости есть подписанные пользователи, то при редактировании данной новости в панели управления, во вкладке "Дополнительно", вы можете увидеть количество подписчиков и отписать их от комментариев к данной конкретной публикации. Данное нововведение будет полезно, например, если новость закрывается от дальнейшего комментирования.

qДобавлена возможность подписываться на комментарии к новости, при публикации комментария, даже когда комментарий уходит на модерацию.

qВ профиле пользователя на сайте, добавлена возможность отписаться от подписанных комментариев к публикациям, с указанием количества публикаций, на которые подписан пользователь. Для этого в шаблоне userinfo.tpl добавлено использование нового тега {unsubscribe}, который выводит чекбокс на отписку от комментариев, и количество подписанных публикаций.

qВ профиле пользователя на сайте, добавлена возможность автоматически подписаться на получение уведомлений о новых комментариях, которые добавляются к новостям, автором которых он является. Тем самым пользователю не нужно подписываться отдельно на каждую свою новость, достаточно отменить соответствующий чекбокс в настройках своего профиля. Для вывода чекбокса, в шаблоне userinfo.tpl добавлено использование нового тега {news-subscribe}.

qВ профиле пользователя на сайте, добавлена возможность автоматически подписаться на получение уведомлений о новых комментариях, которые являются ответами на его собственные комментарии. Для этого достаточно отменить соответствующий чекбокс в настройках своего профиля. Для вывода чекбокса, в шаблоне userinfo.tpl добавлено использование нового тега {comments-reply-subscribe}.

qДобавлена поддержка расширения PHP Memcached. Скрипт DLE автоматически определяет какое именно расширение PHP установлено, Memcache или Memcached на сервере, и в зависимости от этого использует то или иное PHP расширение, в случае если в настройках скрипта включено Memcache кеширование. Тем самым больше нет необходимости ставить на сервер именно расширение PHP Memcache.

qВ админпанели, в разделе редактирования публикаций, в список массовых действий над публикациями, добавлена возможность добавления категорий к публикациям. В отличии от существующего пункт "Изменить категории", пункт "Добавить категорию", позволяет массово назначить публикациям новые выбранные категории, без изменения старых, ранее добавленных категорий.

qДля шаблонного тега тега [news=1,2,3] Текст [/news] добавлена возможность указать диапазон новостей с использованием символа тире. Например, вы можете указать [news=1,2,50-60] Текст [/news]. Аналогично диапазон можно задать и для противоположного тега [not-news=1,2,50-60] Текст [/not-news]. Тем самым облегчается создание нужного вам оформления, и не нет необходимости прописывать все ID нужный публикаций через запятую.

qДля шаблонного тега тега [page-count=1,2,3] Текст [/page-count] добавлена возможность указать диапазон нужных страниц с использованием символа тире. Например, вы можете указать [page-count=1,2,50-60] Текст [/page-count]. Аналогично диапазон можно задать и для противоположного тега [not-page-count=1,2,50-60] Текст [/not-page-count]. Тем самым облегчается создание нужного вам оформления, и не нет необходимости прописывать все номера нужных вам страниц через запятую.

qДобавлена возможность отписываться пользователям сайта от рассылок писем, которые отправляются с раздела "Рассылка сообщений" админпанели. Для этого при рассылке писем, вы можете задать либо в шаблоне, либо непосредственно в тексте сообщения тег {%unsubscribe%}, который выводит в отправляемом письме URL на отписку от получения рассылки для пользователя. При переходе по данной ссылке, для профиля пользователя, устанавливается статус "Не получать писем с сайта". При этом, пользователю достаточно просто пройти по ссылке, ему не нужно авторизовываться или производить какие-либо другие действия на сайте. Тем самым он может легко отписаться от писем с сайта, если он давно потерял интерес к сайту. Несмотря на то что рассылка писем позволяет все равно отправить сообщение пользователю, даже если он изъявил желание не получать писем. Мы настоятельно рекомендуем вебмастерам, во избежание попадания сервера в спам фильтры, всегда при рассылке сообщений учитывать статус, который пользователь установил в своем профиле.

qДобавлено автоматическое добавление для всех внешних ссылок, которые публикуются в новостях и комментариях, атрибута rel, содержащего в себе параметры "external noopener noreferrer". Данный атрибут позволяет снизить вероятность возможной атаки на сайт с использованием механизмов социальной инженерии.

qВ настройки скрипта, добавлена возможность указания количества дней, в течение которых кешировать полную новость после ее публикации. Создание и обновление кэша, эта тоже ресурсоемкая операция. По истечении времени, публикация также теряет свою популярность, и если она не часто читается, то создавать и контролировать кэш постоянно для нее нецелесообразно. Если на вашем сайте публикуется мало новостей, то вы можете увеличить количество дней в течении которых кешировать, если много, то уменьшить. В любом случае мы не рекомендуем устанавливать время кеширования менее 30 дней. Небольшое количество дней используйте только если есть проблемы с свободным местом на жестком диске сервера, либо если публикуете очень большое количество новостей в месяц. А вот тем, у кого немного новостей на сайте, мы рекомендуем увеличить это значение.

qВ админпанели, в разделе редактирования пользователей, добавлена возможность быстрого переноса всех публикаций от одного пользователя, другому. Для этого нужно нажать на количество публикаций пользователя, выбрать перенос публикаций другому пользователю, и указать логин пользователя, на который нужно перенести публикации. Данное нововведение будет полезно, если перед удалением пользователя из базы данных, нужно перенести все его публикации другому пользователю.

qВ админпанели, в разделе редактирования пользователей, добавлена возможность быстрого пересчета количества публикаций у пользователя. Для этого нужно нажать на количество публикаций пользователя и выбрать в меню пересчет публикаций. Данная опция будет полезна, если производилось массовые манипуляции с публикациями, или добавления в базу данных минуя скрипт.

qВ админпанели, в разделе редактирования пользователей, добавлена возможность быстрого пересчета количества комментариев у пользователя. Для этого нужно нажать на количество комментариев пользователя и выбрать в меню пересчет комментариев. Данная опция будет полезна, если производилось массовые манипуляции с комментариями, или добавления в базу данных минуя скрипт.

qУлучшено быстродействие работы вывода новостей при использовании сортировок по рейтингу и просмотрам. Также улучшено быстродействие вывода комментариев, использующих сортировку по рейтингу.

qУлучшена система учета количества комментариев пользователя в статистике его профиля. При массовом удалении новостей происходит также автоматический пересчет и комментариев пользователей. Тем самым отпадает необходимость периодического пересчета статистики.

qПроведена оптимизация отображения админпанели DataLife Engine на мобильных устройствах в портретной ориентации. Тем самым панель управления стала более удобной при ее использовании на смартфонах.

qБиблиотека Jquery была обновлена до линейки 2.xx

qОбновлен редактор TinyMCE до актуальной версии.

qИсправлена проблема, при которой было невозможно использовать точку в доп. полях, имеющих тип перекрестных ссылок.

qИсправлена проблема, при которой формировалась невалидная верстка HTML комментариев при использовании древовидных комментариев.

qИсправлена проблема, при которой для тега {category-url} выводился URL на категорию с использованием ЧПУ, независимо от настроек ЧПУ в админпанели скрипта.

qИсправлена проблема, при которой происходило дублирование индексов дополнительных полей, имеющий опцию перекрестных ссылок, в случае если новость публикуется в несколько категорий.

qИсправлена проблема, при которой некорректно работали теги [available=main] текст [/available] и [not-available=main] текст [/not-available] для главной страницы, в случае если в настройках скрипта была включен показ статической страницы на главной в качестве основной.

qИсправлена проблема, при которой если в разделе редактирования публикаций производилась очистка новости от комментариев, то происходил всегда возврат на первую страницу раздела редактирования новостей, независимо от выставленных фильтров поиска и показа публикаций для редактирования.

qИсправлена проблема, при которой невозможно было ввести правильный ответ на систему "Вопрос-Ответ", в случае если пользователь отвечает на комментарий, а не добавляет новый.

Список изменений относительно версии 10.6:

qВ состав дистрибутива включены три абсолютно новых шаблона. Данные шаблоны созданы с использованием HTML5 стандартов. Являются полностью адаптивными, как под декстопные браузеры, так и под планшеты и смартфоны. Также в верстке шаблонов активно использована векторная графика, что обеспечивает их качественное отображение на HiDPI (Retina) дисплеях.

qДобавлен новый тип дополнительных полей для публикаций: "Загружаемое изображение". При данном типе поля, пользователю предлагается загрузить картинку для данной новости, которая будет выводится потом при показе новостей на сайте. Для данного типа поля вы можете задать такие параметры как ограничения на вес и размер картинки, нужно ли создавать для нее уменьшенную копию, размеры уменьшенной копии, накладывать ли на нее водяной знак. Тем самым с использованием данного типа поля облегчается процесс написания новостей, например, вы можете создать различные типы картинок (постеры, скриншоты и т.д.) и оформить их вывод в шаблоне, а при добавлении новостей останется лишь их только загрузить в один клик.

qДобавлен новый тип дополнительных полей для публикаций: "Загружаемый файл". При данном типе поля, пользователю предлагается загрузить файл для данной новости, который потом будет скачиваться как вложение. В настройках данного поля вы можете задать расширения файлов, которые допустимы для данного поля при загрузке, а также максимальный вес, загружаемого файла. Тем самым с использованием данного типа поля облегчается процесс написания новостей, например, вы можете создать различные типы файлов, в том числе и картинки непосредственно для скачивания (обои в разных разрешениях) и оформить их вывод в шаблоне, а при добавлении новостей останется лишь их только загрузить в один клик.

qДобавлен новый тип дополнительных полей для публикаций: "Переключатель 'Да' или 'Нет'". При написании новостей данный тип поля выводится в виде переключателя 'Да' или 'Нет' (Включено или Выключено). В качестве значения данное поле выводит 'Да' или 'Нет' в зависимости от того что было установлено при написании новости. Однако основное назначение данного поля — это управление тегами [xfgiven_X] текст [/xfgiven_X] и [xfnotgiven_X] текст [/xfnotgiven_X]. В случае если переключатель был включен, то теги [xfgiven_X] текст [/xfgiven_X] выведут соответствующих текст, а теги [xfnotgiven_X] текст [/xfnotgiven_X] уберут его, и наоборот. Тем самым при помощи данных дополнительных полей вы можете легко управлять выводимой информацией на сайте в шаблонах, применительно к каждой конкретной новости. Например, включать или отключать вывод каких-либо вкладок с описанием на странице, либо организовать вывод галерей со скриншотами или постерами и т.д.

qДля дополнительных полей новостей, имеющих тип поля "Список", добавлена возможность создавать отдельные значения, которые отображаются в списке при добавлении публикации, и те, которые отображаются на сайте после выбора пользователем в качестве значений. Для этого при добавлении поля, нужно использовать разделитель '|' в списке значений, например: Yes|Да. При написании новости, пользователю для выбора будет указан пункт Да, а на сайте будет выведено значение поля как Yes.

qДля дополнительных полей профиля пользователей, имеющих тип поля "Список", также добавлена возможность создавать отдельные значения, которые отображаются в списке при редактировании профиля, и те которые отображаются на сайте после выбора пользователем в качестве значений. Для этого при добавлении поля, нужно также использовать разделитель '|' в списке значений, например Yes|Да. При редактировании профиля, пользователю для выбора будет указан пункт Да, а на сайте будет выведено значение поля как Yes.

qСущественно переработан и улучшен режим работы "Использовать как перекрестные гиперссылки" для дополнительных полей новости. В случае если поле имеет данную опцию, то поиск новостей по значению поля производится на основе полного совпадения данного значения у других новостей, а также совпадения именно данного конкретного поля. Например, если раньше вы создавали поле "Год выпуска", и задавали значение 2015, и при этом у вас было другое поле, в котором была, например, загружена картинка, в пути которой также было 2015, то старая система выводила обе новости, т.к. поиск осуществлялся исключительно по вхождению искомого слова. Что приводило к тому что показывались не совсем ожидаемые новости. Теперь же будут показаны только те новости, у которых именно поле "Год выпуска" будет иметь значение 2015. Никакие другие поля и их значения учитываться больше не будут, что позволяет более расширенно использовать дополнительные поля, для организации перекрестного связывания между собой. Например, по году выпуска, актерам, режиссерам и т.д. Новый тип поиска автоматически применяется только для новых добавляемых новостей. Если вы хотите, чтобы и старые существующие новости участвовали в данном поиске, то вам нужно будет в админпанели, в разделе "Перестроение публикаций", запустить перестроение новостей, и тем самым будет создан индекс значений полей и для старых существующих новостей.

qДля основного шаблона (main.tpl) добавлена возможность вывода в нем дополнительных полей новостей при просмотре полной новости на сайте. Для этого в данном шаблоне вы можете использовать те же теги, что и для вывода дополнительных полей в шаблонах краткой и полной новости. Это теги: [xfgiven_X] текст [/xfgiven_X], [xfnotgiven_X] текст [/xfnotgiven_X] и [xfvalue_X]

qДля шаблонов, поддерживающих вывод дополнительных полей новостей, добавлена поддержка новых тегов [ifxfvalue tagname="tagvalue"] Текст [/ifxfvalue], которые выводят текст заключенный в них, если значение дополнительного поля совпадает с указанным. А также добавлена возможность использования тегов [ifxfvalue tagname!="tagvalue"] Текст [/ifxfvalue], которые выведут текст, если значение поля не совпадает с указанным. Где tagmane это имя дополнительного поля, а tagvalue это его значение. Например, [ifxfvalue test="m"] Мужской пол [/ifxfvalue], данный тег выведет текст "Мужской пол", если значению поля test будет установлено "m" при написании публикации. Это открывает большие возможности по созданию различных оформлений шаблонов в зависимости от значений полей, установленных при написании этих публикаций. Например, создав поле с типом "список", можно в зависимости от выбранного пункта, применить различное оформление.

qУлучшено отображение дополнительных полей при быстром редактировании публикаций на сайте, для этого добавлены дополнительные вспомогательные классы CSS для формы редактирования, которые можно использовать для оформления полей при быстром редактировании.

qПри использовании авторизации на сайте с помощью социальных сетей, добавлена возможность для пользователей задать свой персональный логин для сайта, который будет в дальнейшем использоваться. Запрос логина осуществляется только в момент первой авторизации на сайте при помощи социальной сети и будет использоваться в дальнейшем автоматически. Данное нововведение будет полезно для посетителей вашего сайта, которые не хотят использовать данные, полученные автоматически из социальной сети, например, когда в качестве логина используется имя и фамилия пользователя.

qДобавлена поддержка смайлов для HiDPI (Retina) мониторов. Для этого при используется две копии смайлов, в обычном разрешении, и в высококачественном. В случае если монитор имеет обычную пиксельную плотность, то на нем выводится обычный смайлик, если монитор имеет HiDPI (Retina) плотность, то выводится его высококачественная копия. Определение и использование смайлов происходит в автоматическом режиме. Для этого вам нужно разместить в папке со смайлами две копии смайлика, например, с именем smile.gif для обычного смайла и smile@2x.gif для HiDPI (Retina) смайла. В случае если копия смайла в высоком разрешении отсутствует, то будет использоваться во всех случаях вывод обычного смайла.

qВ состав дистрибутива включено 60 новых смайлов. Все они имеет поддержку HiDPI (Retina) дисплеев.

qДобавлена автоматическая поддержка смайлов в формате .png. Поддержка осуществляется также в автоматическом режиме. Для этого нужно просто скопировать файлы в папку со смайлами с расширением .png и указать имя смайлика в настройках скрипта.

qДобавлен новый глобальный тег: {customcomments id="1,2,5-8" category="2,3,5-8" author="x" days="x" template="custom" available="global" from="0" limit="10" order="date" sort="desc" cache="yes"}

qДля шаблонов вывода комментариев (comments.tpl) добавлена поддержка нового тега {comment limit="X"}, который выводит текст комментария без HTML форматирования, при этом сам текст комментария сокращается до указанного "x" количества символов. При этом сокращение текста происходит до последнего логического слова, а не обрывает текст на середине слова. Данный тег будет полезен при использовании пользовательского вывода комментариев, с использованием тега {customcomments ...}, когда нужно вывести не весь комментарий целиком, а только его анонс.

qДля шаблонов вывода комментариев (comments.tpl) добавлена поддержка нового тега {news-link}, который выводит URL новости, которой принадлежит данный комментарий. Данный тег будет полезен при использовании пользовательского вывода комментариев и при показе последних комментариев.

qДля шаблонов вывода комментариев (comments.tpl) добавлена поддержка нового тега {news-title}, который выводит HTML безопасный заголовок новости, которой принадлежит данный комментарий. Данный тег будет полезен при использовании пользовательского вывода комментариев и при показе последних комментариев.

qВ настройки групп добавлена возможность указания того, какие категории запрещены данной группе пользователей для просмотра. Данная новая настройка является дополнением к существующей, где вы перечисляете разрешенные для просмотра категории. Если ранее, для того чтобы запретить, например, всего одну категорию из большого списка категорий, вам нужно было выбирать все доступные категории, за исключением всего одной запрещенной категории, то теперь вы можете просто выбрать одну запрещенную категорию и списка, и все. Предыдущая настройка в админпанели также была сохранена, поэтому вы сами можете выбрать как вам удобнее, вы можете выбрать как список доступных категорий, так и просто указать список недоступных.

qДобавлена возможность продвижения пользователей из одной группы в другую, по прошествии определенного количества дней с момента регистрации на сайте. Для этого в настройках групп добавлена соответствующая настройка, где вы можете указать, через сколько дней и в какую группу перевести пользователя после его регистрации. Тем самым открываются новые возможности по предоставлению пользователям каких-либо прав или привилегий на сайте.

qДобавлена возможность продвижения пользователей из одной группы в другую, при наборе им определенного количества новостей на сайте. Для этого в настройках групп добавлена соответствующая настройка, где вы можете указать, сколько новостей необходимо иметь и в какую группу переместить пользователя при наборе им данного количества публикаций. Публикации, находящиеся на модерации, при этом не учитываются. Тем самым вы можете предоставлять пользователям, которые заслужили определенное доверие какие-либо дополнительные права и преференции.

qДобавлена возможность продвижения пользователей из одной группы в другую при наборе им определенного количества комментариев на сайте. Для этого в настройках групп добавлена соответствующая настройка, где вы можете указать, сколько комментариев необходимо иметь и в какую группу переместить пользователя им данного количества комментариев. Комментарии, находящиеся на модерации, при этом не учитываются. Тем самым вы можете предоставлять пользователям, которые заслужили определенное доверие какие-либо дополнительные права и преференции.

qДобавлена возможность продвижения пользователей из одной группы в другую при наборе им определенного рейтинга их публикаций на сайте. Для этого в настройках групп добавлена соответствующая настройка, где вы можете указать, какой суммарный рейтинг им необходимо набрать, и в какую группу переместить пользователя при получении ими данного рейтинга.

qДля шаблонов вывода комментариев и персональных сообщений (comments.tpl и pm.tpl) добавлена поддержка форматированного вывода количества комментариев и публикаций пользователя. Например, при выводе количества комментариев 252501 будет выведено 252 501. Что облегчает восприятие больших цифр.

qДля шаблонов вывода профиля пользователя (userinfo.tpl и profile_popup.tpl) добавлена поддержка форматированного вывода числового рейтинга. Например, при выводе общего рейтинга пользователя +252501, будет выведено +252 501. Что облегчает восприятие больших цифр.

qДобавлена поддержка нового глобального шаблонного тега: {* Закомментированный код *}. Данный тег предназначен для комментирования кода, все что заключено между "{*" и "*}" будет удалено из шаблона. И будет отсутствовать при выводе на сайте. Данные теги будут полезны разработчикам шаблонов, для отладки той или иной функциональности, когда нужно временно закомментировать ту или иную функциональность. Данный тег является глобальным и может использоваться во всех шаблонах.

qДобавлен автоматический сброс индекса похожих новостей при изменении количества выводимых похожих новостей в настройках скрипта. Тем самым больше нет необходимости после изменения данной настройки заходить в перестроение публикаций и там делать перестроение кеша похожих новостей.

qВ настройки скрипта добавлена возможность указания нужно ли выводить в профиле пользователя его публикации, ожидающие модерации, или нет. В случае включения данной настройки, то пользователь может увидеть в своем профиле новости, которые ожидают модерации, и отредактировать их. Если данная настройка отключена, то в его профиле данные новости отображатся не будут, и также не будет отображатся сообщение о том, что у него нет публикаций, ожидающих модерации.

qВнесены изменения в работу обратной связи на сайте, в случае если пишет незарегистрированный пользователь на сайте. В случае если пользователь не зарегистрирован, то не проводится проверка совпадения введенного им логина с теми, что уже зарегистрированы на сайте. Вместо этого к его введенному имени добавляется префикс "Незарегистрированный пользователь". Тем самым администрация или получатель письма с сайта будет легко видеть, что письмо ему отправил именно незарегистрированный посетитель сайта. А для самого посетителя сайта не будет неудобной обязанности придумывать другое имя, если то имя что он написал, занято зарегистрированным пользователем.

qВнесены изменения в работу добавления комментариев на сайте, в случае если комментарий пишет незарегистрированный посетитель сайта. Если введенное им имя совпадает с зарегистрированным логином, то к его имени добавляется префикс "Гость". Например, посетитель написал имя "Татьяна", и на сайте уже есть зарегистрированный логин "Татьяна", то комментарий будет добавлен от имени "Гость Татьяна". Тем самым имеется визуальное отличие, что этот пользователь не является зарегистрированным на сайте, а также посетитель сайта избавляется от неудобной обязанности придумывать себе другое имя. Если же такого нет имени среди зарегистрированных, то префикс добавляться не будет.

qДобавлена поддержка уведомлений о новых комментариях, для комментариев, которые отправляются на модерацию. Ранее уведомления отправлялись только если комментарий публиковался сразу на сайте минуя модерацию администрацией сайта. Теперь уведомления также будут отправлятся после того как администрация сайта проверила комментарий и опубликовала его на сайте.

qВ раздел управления облаком тегов в админпанели добавлена возможность поиска ключевых слов по заданному слову. Что существенно облегчает поиск и редактирование нужного слова, при большом объеме заданных слов.

qВ раздел управления перекрестными ссылками в админпанели добавлена возможность поиска по ключевым словам и ссылкам. Что существенно облегчает поиск и редактирование нужного слова, при большом объеме заданных слов.

qДля модуля "Перекрестные ссылки" добавлена возможность установки новой опции: "Открывать ссылку в новом окне". Тем самым вы можете устанавливать где вам открывать нужную вам ссылку в этом же окне браузера, или в новом окне браузера.

qДля массовых действий в модуле "Перекрестные ссылки" также была добавлена возможность назначать ссылкам каким образом открывать данные ссылки, в новом окне браузера или в текущем окне браузера.

qВ админпанели, в разделе управления пользователями, добавлена новая опция "Точное совпадение логина", при поиске пользователей по логину. В случае если данная опция отмечена, то поиск будет проходит по точному совпадению логина с указанным в поиске. Тем самым облегчается поиск нужного пользователя, имеющего короткий логин, в случае если на сайте зарегистрировано большое количество пользователей.

qВоспроизведение флеш видео файлов в формате .flv приведено к единому плееру. Теперь для воспроизведения данного видео используется тот же плеер что и для воспроизведения HTML5 видео. Тем самым всё видео на сайте, имеет единый визуальный вид.

qДля более лучшего и качественного продвижения публикаций в поисковых системах, при просмотре полных новостей, добавлено автоматическое использование ключевых слов из облака тегов, в специально сформированном метатеге для поисковых систем.

qУлучшена обработка текста, опубликованного в тегах code в парсере новостей. Было исключено какое-либо пересечение публикуемого кода с тегами и фильтрами DLE, что позволяет публиковать в нем исходных код, без какого-либо вмешательства в текст со стороны DLE.

qДобавлена поддержка копирования аватаров при авторизации на сайте с использованием социальной сети "Одноклассники".

qОбновлен до актуальной версии визуальный редактор TinyMCE. Помимо исправления ранее обнаруженных ошибок, в данном редакторе было добавлено много других изменений. Внешний вид редактора изменен на более классический для вебсайтов (все функции представлены в виде кнопок, без меню), в нем была улучшена вставка ББ тегов для видео и Youtube и других. В редакторе улучшена вставка и обработка примеров исходных кодов (тега [cоde] [/cоde]), добавлена подсветка этого кода непосредственно в редакторе, а также добавлено удобное окно для вставки примеров кодов. В редакторе добавлена подсветка синтаксиса HTML кода, при редактировании исходного кода HTML.

qВнесены изменения в механизмы формирования карты сайта. В случае если для незарегистрированных пользователей запрещены какие-либо категории для просмотра, то из карты также исключаются эти категории и публикации из этих категорий.

qВнесены изменения в код вывода ключевых слов для облака тегов, благодаря которым появилось больше возможностей по различному оформлению данных тегов на сайте.

qДобавлена поддержка кодировки utf8mb4 для MySQL сервера версии 5.7.x

qИсправлена проблема, при которой некорректно работали теги [dеclination=x] Текст [/dеclination] в случае использования их совместно с числами для которых применен форматированный вывод.

qИсправлена проблема, при которой некорректно выводились новости с использованием тега {custom ...} c параметрами author и catalog, в случае если использовалось несколько тегов на странице одновременно с этими параметрами, с включенном кешировании при этом.

qИсправлена проблема с цитированием комментариев, которые содержат в себе HTML теги, при использовании стандартного редактора для комментариев. Теперь при цитировании в поле редактора, также вставляются эти HTML теги, а не их HTML сущности.

qИсправлена проблема с получением писем в кодировке UTF-8 на некоторые типы почтовых сервисов.

qИсправлена проблема, при которой некорректно переименовывалось имя авторов для загруженных к новостям файлов, в случае переименования логина пользователя в панели управления пользователями.

qИсправлена проблема, при которой не очищался кеш новости, если она находилась на модерации и редактировалась автором этой новости на сайте.

qИсправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 10.5:

qДобавлена поддержка четырех байтовой кодировки базы данных для сайтов, использующих кодировку UTF-8. При установке скрипта в кодировке UTF-8 вы можете включить поддержку четырех байтов для данной кодировки в БД. Это необходимо если вы, например, захотите использовать не буквенные символы в базе данных. Например, смайлики Emoji, музыкальные символы и т.д.

qДля шаблона main.tpl добавлен новый тег {jsfiles}, данный тег выводит подключение всех JS скриптов, которые использует DLE в указанном месте шаблона. При помощи данного тега вы можете, например, перенести все JS скрипты в самый низ страницы, для ускорения загрузки и рендеринга ваших страниц. Данный тег является необязательным, и в случае его отсутствия в шаблоне, все скрипты будут подключены, как и ранее к тегу {headers}. Внимание, если вы переносите подключение скриптов, то должны иметь ввиду, что тег {AJAX} также должен находится ниже тега {jsfiles}, а также вы должны предусмотреть работу всех своих сторонних скриптов в шаблоне, если они используют, например, библиотеку Jquery, чтобы они не запускались раньше, чем выполнится подключение всех скриптов. Мы настоятельно не рекомендуем новичкам пользоваться данным тегом, он предназначен для опытных вебмастеров, которые имеют опыт в работе с JS скриптами.

qДля рейтинга новостей и комментариев добавлен вывод информации в виде в всплывающего окна, в случае если его голос не может быть учтен, с описанием причины по которым его голос не может быть принят. Например, он выставляет эту же оценку повторно, или голосует за собственную новость или комментарий.

qДля рейтинга новостей и комментариев добавлен запрет на выставление оценки собственной новости или собственному комментарию.

qДля рейтинга новостей и комментариев добавлена возможность изменения для посетителей сайта своего голоса или оценки. Например, если вы если пользователь поставил одну оценку или голос за новость или комментарий, то передумав он может изменить свою оценку. При этом старая его оценка будет отменена и добавлена новая.

qВ настройки скрипта добавлена возможность указывать максимальное количество страниц найденных результатов поиска по сайту. Тем самым вы можете как ограничить показ найденных результатов, в целях снижения нагрузки на сервер, так и показывать все найденные результаты.

qДобавлен форматированный вывод количества просмотров новости, количества комментариев у новости, количества новостей и комментариев у пользователя в профиле. Например, при выводе количества просмотров у новости вместо 252501 будет выведено 252 501. Что облегчает восприятие больших цифр.

qДля тегов [aviable=x] Текст [/aviable] и [not-aviable=x] Текст [/not-aviable] добавлены теги синонимы [available=x] Текст [/available] и [not-available=x] Текст [/not-available] соответственно. Данные теги являются полностью идентичными синонимами и несут одну функциональную нагрузку, просто написание available является правильным и созвучным для англоязычных пользователей скрипта.

qДобавлена поддержка вложенности друг в друга для тегов [available=x] Текст [/available] и [not-available=x] Текст [/not-available]. Например, вы можете использовать в шаблоне конструкцию: [available=main|cat] Текст 1 [available=cat] Текст 2 [/available] [/available]. Которая выведет "Текст 1" при просмотре главной странице и категорий, а "Текст 2" только при просмотре категорий. Тем самым упрощается логика верстки шаблона, а также добавляются новые возможности при верстке шаблона.

qДобавлена поддержка вложенности друг в друга для тегов [group=x] Текст [/group] и [not-group=x] Текст [/not-group]. Например, вы можете использовать в шаблоне следующую конструкцию: [group=1,2,3,4] Текст 1 [group=1] Текст 2 [/group] [/group]. Которая выведет "Текст 1" для всех зарегистрированных пользователей, а "Текст 2" только для администраторов.

qДля BBCODES редактора для сайта, добавлена поддержка вставки заголовков текста. Заголовки вставляются с использованием специальной новой кнопки в редакторе и могут использоваться заголовки от <H1> до <H6>.

qУлучшены алгоритмы работы модуля "Перекрестные ссылки". Теперь модуль корректно распознает разные слова, имеющие одинаковые вхождения. Например, если были заданы слова "Терминатор" и "Терминатор Генезис" с разными ссылками, то будет проведена корректная замена каждого отдельного ключевого слова, независимо друг от друга и независимо от того, когда она были добавлены в скрипте.

qВ настройки видеопроигрывателей в админпанели добавлена возможность включать или отключать предварительную загрузку метаданных видео. Если данная настройка включена, то плеер подгружает предварительно для видео данные о видео, а именно его продолжительность и первый стоп кадр видео для превью в плеере. В случае отключения данной настройки эти данные не загружаются, тем самым вы можете экономить трафик сервера и пользователей, если они не будут просматривать данное видео.

qДобавлен новый более удобный формат вывода публикаций в закладках. Сортируется вывод теперь не по параметрам общих настроек в скрипте, а по принципу: "последний добавленный показывается первым", т.е. новости которые были добавлены в закладки позднее показываются в списке раньше, тем самым при наличии большого количества закладок на сайте, пользователю будет удобнее видеть, какие новости он в последний раз добавлял.

qДля тегов [category=x] текст [/category], [not-category=x] текст [/not-category], [catlist=x] текст [/catlist], [not-catlist=x] текст [/not-catlist] добавлена возможность перечислять список категорий с использованием дефиса, например, вы можете указать [category=3-7,15] текст [/category], и данные теги выведут текст на страницах категорий, имеющих ID с 3 по 7, и 15.

qДля шаблонов вывода комментариев (comments.tpl) добавлены новые теги [rootcomments] текст [/rootcomments], которые выводят текст, заключенных в них, в случае если комментарий является основным родительским к новости, а не является ответом на какой-либо другой комментарий. А также добавлены теги [childrencomments] текст [/childrencomments] которые выводят текст, заключенных в них, в случае если комментарий является ответом на другой комментарий. Тем самым вы можете гибко визуально настраивать внешний вид дерева комментариев, например, заключить родительские комментарии в отдельный блок, или для ответов на комментарии сократить количество визуального оформления и информации.

qДля пользовательского вывода новостей при помощи тега {custom ...}, для параметра author, добавлена возможность перечислять нескольких авторов. Например, вы можете указать {custom author="test,admin"}, и тогда будет выведены новости авторов с логином "admin" и логином "test".

qДля пользовательского вывода новостей при помощи тега {custom ...} добавлено использование нового параметра authorexclude="X", при котором выводятся публикации всех авторов, кроме указанного, где X это имя логина автора. Логины авторов в данном параметре также можно перечислять через запятую. Например, при использовании {custom authorexclude="admin,test"} будут выведены новости всех авторов, кроме авторов с логином "admin" и логином "test".

qДля пользовательского вывода новостей при помощи тега {custom ...} добавлено использование нового параметра catalog="X", при котором выводятся все публикации содержащие указанный в параметре символьный код, где X это назначенный новостям символьный код. Допускается также перечисление символьных кодов в параметре через запятую. Например, при использовании {custom catalog="а,б"} будут выведены новости, которые содержат символьные коды "а" или "б".

qДля пользовательского вывода новостей при помощи тега {custom ...} добавлено использование нового параметра catalogexclude="X", при котором выводятся все публикации, которые не содержат указанный в параметре символьный код, где X это назначенный новостям символьный код. Допускается также перечисление символьных кодов в параметре через запятую. Например, при использовании {custom catalogexclude="а,б"} будут выведены новости, которые не содержат символьные коды "а" и "б".

qДля пользовательского вывода новостей при помощи тега {custom ...} добавлено использование нового параметра xfields="X", при котором выводятся все публикации, содержащие указанное в параметре значение дополнительных полей новостей, где X это значение дополнительного поля. Допускается также перечисление значений в параметре через запятую. Например, при использовании {custom xfields="значение 1,значение 2"} будут выведены новости, в которых есть дополнительные поля содержащие "значение 1" или "значение 2".

qДля пользовательского вывода новостей при помощи тега {custom ...} добавлено использование нового параметра xfieldsexclude="X", при котором выводятся все публикации, не содержащие указанное в параметре значение дополнительных полей новостей, где X это значение дополнительного поля. Допускается также перечисление значений в параметре через запятую. Например, при использовании {custom xfieldsexclude="значение 1,значение 2"} будут выведены новости, в которых нет дополнительных полей содержащих "значение 1" и "значение 2".

qДля шаблонов вывода профиля пользователей (userinfo.tpl и profile_popup.tpl) добавлена поддержка новых тегов [profile-user-group=X] Текст [/profile-user-group], которые выводят текст заключенных в них, если группа пользователя, профиль которого просматривается, принадлежит указанной группе X. Где X это номер группы. Допускается также перечисление нужных групп через запятую. Например, вы можете указать [profile-user-group=1,2] Текст [/profile-user-group] и в данном случае будет выведен текст, если просматривается профиль администратора или главного редактора. Тем самым вы можете для разных групп пользователей, делать различное оформление их профиля.

qДля шаблонов вывода профиля пользователей (userinfo.tpl и profile_popup.tpl) добавлена поддержка новых тегов [not-profile-user-group=X] Текст [/not-profile-user-group], которые выводят текст заключенных в них, если группа пользователя, профиль которого просматривается, не принадлежит указанной группе X. Где X это номер группы. Назначение данных тегов противоположно описанным в предыдущем пункте. Например, вы можете указать [not-profile-user-group=1,2] Текст [/not-profile-user-group] и в данном случае будет выведен текст, если просматривается профиль пользователя, не принадлежащий администраторам и главным редакторам. Тем самым вы можете для разных групп пользователей, делать различное оформление их профиля.

qДля шаблона вывода статической страницы (static.tpl или любого другого шаблона, назначенного странице) добавлен новый тег {text limit="x"} который выводит только текст добавленных для статической страницы без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов. При этом сокращение текста происходит до последнего логического слова, а не обрывается на середине слова.

qДля шаблона вывода статической страницы (static.tpl или любого другого шаблона, назначенного странице) добавлено использование новых тегов: {image-x} который выводит URL картинки, находящейся в тексте статической страницы, где "x" это номер картинки в тексте страницы, например, {image-1} выведет URL первой картинки в тексте страницы. Добавлено использование тегов [image-x] текст [/image-x], которые выводят указанный в них текст, только если картинка с номером "x" присутствует в тексте страницы

qДля статических страниц добавлена специальная разметка в метатегах согласно протоколу Open Graph http://ogp.me/, благодаря ей, для социальных сетей и поисковиков, в метатегах будут добавляться название сайта, ссылка на изображение в статической странице, ссылка на видео (если таковое присутствует в статической странице и опубликовано при помощи тега [video]), а также ссылка на аудио (если таковое присутствует в статической странице и опубликовано при помощи тега [audio]). Все это позволяет более лучше и качественнее индексировать ваш сайт и интегрировать его с социальными сетями.

qДля шаблона вывода прикрепленных к новости файлов (attachment.tpl) добавлена поддержка нового тега {extension}, который выводит расширение загруженного к новости файла. Тем самым вы можете, например, задавать в шаблоне для вывода загруженных файлов различные пиктограммы, в зависимости от типа файла и его расширения.

qДля каждого всплывающего окна, которое вызывает скрипт, добавлено назначение собственного уникального класса. Тем самым вы можете легко переназначить для него визуальное оформление окна, персонально для каждого окна. Например, его размеры, или визуальный вид.

qДобавлена поддержка изменения дизайна админпанели скрипта при помощи своих шаблонов, созданных для сайта. Для этого достаточно разместить в папке своего шаблона, который у вас назначен по умолчанию в настройках скрипта, файл adminpanel.css в котором вы можете разместить и переназначить оформление классов CSS, которые используются панелью управления. В случае, если такой файл присутствует у вас в папке шаблона, то он будет подключен панелью управления автоматически. Так как вся верстка панели управления основана на CSS, вы можете из своего шаблона полностью изменить визуальное оформление панели управления, например, цветовое оформление. При этом при обновлении на новые версии скрипта, ваши изменения также будут сохраняться и автоматически действовать и на новых версиях.

qПереработано формирование воспроизведения видео на сайте. Для всех современных форматов видео, применяется исключительно HTML5 плеер, возможность использования для них устаревшего флэш плеера отключена. Флэш плеер используется только в случае если вставляется флэш видео в формате .flv. Для воспроизведения аудио, также применяется только HTML5 плеер. Данное нововведение необходимо для более качественной поддержки всех типов устройств, для воспроизведения видео, включая смартфоны и планшеты.

qВнесены изменения в работу парсинга текста новостей относительно обратной конвертации HTML тегов для изображений (тега img). В случае если картинка была вставлена в виде ББ тегов, то при редактировании она также переводится в ББ теги. В случае если картинка была вставлена при помощи HTML тега, то при редактировании она также остается в виде HTML тега. Данное нововведение позволяет более гибко писать тексты новостей, если картинкам нужно задать какие-то дополнительные HTML свойства, например, стили или классы CSS и т.д.

qДобавлена поддержка сжатия изображений для PNG формата при их загрузке на сервер, что позволяет снизить размер картинок, после их загрузки на сервер.

qОптимизирован вывод загруженных к новостям файлов. А именно подсчет размеров файлов и его хеш сумм производится только в случае если соответствующие теги стоят в шаблоне attachment.tpl, и в случае если их нет, то работа по получению этой информации скриптом не производится. Что позволяет существенно сократить скорость работы скрипта и снизить нагрузку на сервер.

qС сожалением были вынуждены отключить поддержку сервиса "Чистый Веб" от Яндекса. В связи с прекращением поддержки данного сервиса со стороны Яндекса.

qДобавлено автоматическое подключение плеера DLE для видео опубликованного в новостях, и которые выводятся тегом {custom ...} на сайте.

qУлучшена работа админпанели при работе со смартфонами, в частности улучшена загрузка файлов со смартфонов, а также работа всплывающих окон в админпанели, улучшена контрастность некоторых элементов админпанели.

qДобавлена возможность перемещения всплывающих окон по экрану для сенсорных устройств, не имеющих мышки (смартфоны, планшеты и т.д.).

qДобавлена поддержка скриптом линейки MySQL 5.7.x

qПереработан и адаптирован код скрипта, для поддержки линейки PHP 7.xx

qОбновлен до актуальной версии PHP класс для работы с почтой, улучшена совместимость с некоторыми SMTP серверами.

qОбновлен HTML5 плеер до актуальной версии, улучшена поддержка и его работа на некоторых моделях смартфонов.

qОбновлен визуальный редактор TinyMCE до актуальной версии, улучшена его работа в новом браузере Edge от Microsoft.

qИсправлена проблема, при которой если дополнительному полю было указано использование без редактора, то при быстром редактировании новости на сайте, редактор все равно подключался.

qИсправлена проблема, связанная с некорректной обработкой вывода прикрепленных загруженных файлов, в случае вывода новостей при помощи тега {custom ...}

qИсправлена проблема, при которой не работало удаление всех комментариев у конкретной новости, в разделе редактирования новостей в админпанели скрипта.

qИсправлена проблема, при которой при создании новой категории в админпанели, не сохранялась информация, о том, что не нужно транслировать новости в RSS поток, если это указывалось.

qИсправлена проблема, при которой неверно формировались ссылки в письмах, если в настройках скрипта в качестве URL сайта было просто указано "/".

qИсправлена проблема, при которой не очищался автоматически кеш RSS информеров каждый час.

Список изменений относительно версии 10.4:

qДобавлена новая система древовидных комментариев к новостям. Данная система комментирования, позволяет посетителям отвечать на конкретные отдельные комментарии, и выводить комментарии к новостям в виде дерева. Данная система комментирования включается в админпанели в настройках комментариев. При этом вы также можете указать максимальный уровень вложенных комментариев. При включении данной системы на сайте, мы рекомендуем вам также обратить внимание на такой параметр настроек, как количество комментариев на одну страницу. В случае использования древовидных комментариев, это будет количество именно родительских комментариев на одну страницу, а реальное количество комментариев с учетом вложенных ответов может быть больше.

qДля шаблона вывода комментариев (comments.tpl) добавлен новый тег [reply] текст [/reply], который выводит текст в них, в виде ссылки на открытие всплывающего окна для ответа на комментарий, в случае если включена поддержка древовидных комментариев, а в случае если она отключена вставляет логин выбранного комментатора в форму добавления комментариев.

qДля шаблона вывода комментариев (comments.tpl) добавлены новые теги [treecomments] текст [/treecomments], которые выводят текст, заключенных в них, в случае если включены древовидные комментарии в настройках скрипта. А также добавлены теги [not-treecomments] текст [/not-treecomments], которые выводят текст, заключенный в них, в случае если древовидные комментарии отключены. Данные теги позволят вебмастерам создавать более гибкие шаблоны, которые будут выводится по-разному в зависимости от настроек скрипта в данном вопросе.

qДля шаблона вывода комментариев (comments.tpl) добавлен новый тег {replycount}, который выводит количество имеющихся ответов на данный комментарий.

qВ настройки скрипта в админпанели, добавлена возможность отключать редактор для комментариев и персональных сообщений. В случае отключения редактора, пользователи не будут иметь возможности использовать какое-либо оформление при добавлении комментариев, а смогут писать только текст. При этом также отключается обработка всех ББ тегов и их ручное написание не будет иметь какого-либо эффекта, за исключением одного тега цитаты "quote", который необходим для функционирования цитирования и ответов на комментарии и персональные сообщения. Данная возможность будет полезна тем вебмастерам, которые хотят минимизировать возможности по оформлению текстов комментариев и персональных сообщений.

qВ настройки скрипта в админпанели, добавлена возможность включать режим быстрого ответа на комментарий. При данном режиме, ответ на комментарий вводится не в отдельном всплывающем окне, а выводится упрощенная форма ответа на комментарий, чуть ниже самого комментария. Также запрашивается минимальный набор необходимых данных, и отключается редактор для ответа на комментарий. Другими словами, основной комментарий может публиковаться полноценно, с использованием форматирования, а ответы на него уже в упрощенном виде.

qСнижена нагрузка на базу данных MySQL при просмотре комментариев к публикациям на сайте.

qПолностью переработан дизайн стандартного BBCODES редактора в админпанели. Он получил современный дизайн, соответствующий оформлению админпанели. Для кнопок были использованы векторные шрифты, что делает кнопки контрастными и хорошо читаемыми на мониторах, имеющих высокое пиксельное разрешение и при масштабировании в OS.

qДля BBCODES редактора в админпанели, добавлена поддержка следующих новых кнопок и BB тегов: [sub] текст [/sub] - выводят текст в нижнем индексе[sup] текст [/sup] - выводят текст в верхнем индексе [justify] текст [/justify] - выравнивает текст по обеим сторонам и слева и справа

qДля BBCODES редактора в админпанели, добавлена поддержка вставки заголовков текста. Заголовки вставляются с использованием специальной новой кнопки в редакторе и могут использоваться заголовки от <H1> до <H6>.

qДобавлена поддержка нового файла шаблона для вывода загруженных и прикрепленных к новостям файлов. Имя нового файла шаблона: attachment.tpl, в котором вы можете задать оформление для показа прикрепленных файлов. Тем самым вы можете гибко задать любое визуальное оформление тега [аttachment=...], который вы используете при вставке в текст новостей.

qДобавлена глобальная поддержка во всех шаблонах тега для пользовательского вывода новостей {custom ....}. Теперь вы можете использовать данный тег во всех без исключения файлах шаблона, а не только в строго определенных.

qДля тега пользовательского вывода новостей {custom ....}, добавлена поддержка использования динамических параметров, на основе других шаблонных тегов. Например, если ранее вы могли использовать данный тег в шаблонах только с использованием заранее определенных в шаблоне параметрах {custom id="1,2"}, то теперь можете использовать этот тег с параметрами {custom id="[xfvalue_x]"}, а значения ID новостей задавать при добавлении новости в доп. полях новостей. Тем самым открываются практически безграничные возможности по выводу контента новостей на страницах вашего сайта.

qДобавлено автоматическое акцептирование введенных значений для облака тегов, метатегов и дополнительных полей, имеющих опцию перекрестных ссылок, без необходимости нажатия кнопки Enter на этих полях.

qДобавлена новая автоматическая система защиты комментариев от спама на основе облачного сервиса "Яндекс Чистый Веб". Подробнее об этом сервисе вы можете прочитать на странице https://tech.yandex.ru/. Особенностью данной защиты является то что анализируется непосредственно сам текст комментариев на наличие признаков спама, а не только на основе IP и e-mail пользователя, хотя эти данные также учитываются.

qУлучшена поддержка SSL для сайтов. Добавлена автоматическая поддержка https протокола, при использовании внешних сервисов (таких как gravatar) и плееров (youtube и другие) сайта, если ваш сайт использует https протокол.

qДобавлена поддержка и использование HTML5 плеера, при вставке аудиофайлов, если данный плеер включен в настройках проигрывателей.

qПереработана и улучшена система фильтрации тега iframe в новостях, которая позволяет добавлять iframe только для доверенных доменов. Проверка стала универсальной и проверяет только имя домена без протокола и www алиаса данного домена. Тем самым в случае если видео сервис вносит изменения в свой код плеера, то он продолжает работать и приниматься скриптом DLE. Например, если раньше видеосервис youtube публиковал ссылки на свой плеер как //www.youtube.com/ а сейчас изменил на https://www.youtube.com/, то новая система автоматически будет акцептировать и эти ссылки.

qДля шаблона вывода комментариев (comments.tpl) добавлены новые теги [comments-author] текст [/comments-author], которые выводят текст, заключенный в них, если пользователь, просматривающий страницу сайта, является автором данного комментария. А также теги [not-comments-author] текст [/not-comments-author], которые выводят текст, заключенный в них, если пользователь, просматривающий страницу сайта, не является автором данного комментария. Данные теги позволяют вебмастерам делать шаблон комментариев таким образом, чтобы посетители сайта могли сразу видеть визуально свои собственные комментарии, например, по отличительному цветовому оформлению его комментариев.

qДля шаблона вывода комментариев (comments.tpl) добавлены новые теги [news-author] текст [/news-author], которые выводят текст, заключенный в них, если комментарий принадлежит автору данной новости, а также теги [not-news-author] текст [/not-news-author], которые выводят текст, заключенный в них, если комментарий не принадлежит автору данной новости. Тем самым вы можете визуально выделять на страницах вашего сайта, те комментарии, которые пишет автор публикации.

qДля шаблона вывода комментариев (comments.tpl) добавлены новые теги [positive-comment] текст [/positive-comment], которые выводят текст, заключенный в них, если комментарий имеет позитивный рейтинг, [negative-comment] текст [/negative-comment], которые выводят текст, заключенный в них, если комментарий имеет негативный рейтинг, [neutral-comment] текст [/neutral-comment], которые выводят текст, заключенный в них, если комментарий имеет нейтральный рейтинг. Тем самым вы можете визуально выделять на странице или скрывать оформление и текст как положительно оцененных комментариев, так и негативно оцененных.

qДобавлена возможность отдельного вывода дополнительных полей для новости в шаблоне добавления новости (addnews.tpl). Для этого были добавлены следующие теги: [xfinput_X], где X это имя дополнительного поля для новостей, которые выводят ваше выбранное дополнительное поле в форме добавления новости в нужном вам месте. Тем самым вы можете как угодно и где угодно расположить добавление нужного поля в вашей форме, а не только общим тегом {xfields}

qДобавлена возможность отдельного вывода дополнительных полей профиля пользователей в шаблонах регистрации и профиля пользователей (registration.tpl и userinfo.tpl). Для этого были добавлены следующие теги: [xfinput_X], где X это имя дополнительного поля для профиля, которые выводят ваше выбранное дополнительное поле в форме регистрации и редактировании профиля пользователя в нужном вам месте. Тем самым вы можете как угодно и где угодно расположить добавление нужного поля в вашей форме, а не только общим тегом {xfields}

qВ настройки профиля на сайте для удобства посетителей вашего сайта, в список часовых поясов, добавлено указание какой часовой пояс используется на сайте по умолчанию, тем самым они могут решить, стоит им его менять в настройках своего профиля или нет.

qДобавлена возможность задавать ограничение на доступ к аккаунту пользователя на сайте или к админпанели с использованием маски подсети. Например указывать не только 10.96.*.*, но и например 10.96.0.0/11, что будет являться диапазону адресов с 10.96.0.0 до 10.127.255.255. Использование маски позволяет более точно описывать диапазон динамических адресов вашего интернет провайдера, для ограничений доступов к аккаунту.

qДобавлена поддержка подключения к серверу Memcache c использованием UNIX сокетов, можно указывать не только сервер и порт, но указывать путь к сокету, например, "unix:///home/login/.system/memcache/socket".

qДобавлена возможность очистки результатов опросов, назначенных новости, при редактировании данной новости в админпанели.

qВ админпанели, в разделе редактирования исходного кода рекламных материалов, добавлен редактор с подсветкой исходного кода, для удобства его редактирования.

qВ настройки групп в админпанели добавлена возможность ограничивать время, в течении которого группе разрешено редактировать новости. Вы можете указать для выбранной группы, в течении скольких дней, после публикации новости ее разрешено редактировать. По истечении указанного количества дней, пользователи из данной группы больше не смогут редактировать эти новости. Данное нововведение будет полезно администраторам сайтов, которые не хотят, чтобы старые новости подвергались какому-либо изменению со стороны других пользователей.

qПри отправке персонального сообщения на сайте добавлена проверка на основе облачного сервиса, является ли отправитель спамером или нет. Данная возможность включается и отключается для каждой группы пользователей персонально в настройках групп в админпанели. Тем самым вы получаете дополнительные механизмы защиты персональных сообщений от спама.

qДля шаблона регистрации (registration.tpl) добавлена поддержка тегов быстрой авторизации через социальные сети. Это те же теги, что и используются в шаблоне login.tpl, такие как [vk] {vk_url} [/vk] и т.д.

qДобавлена поддержка новой системы защиты от спам ботов Recaptcha 2.0. Использование данной новой системы позволяет вашим сайтам более дружественно относится к пользователям, и более легко подтверждать что они не являются роботами, а также более надежно защищать ваши сайты от спам ботов. Внимание при переходе на данную систему, если вы ранее использовали общие ключи, которые шли в комплекте со скриптом, то вам необходимо зарегистрировать ваши сайты персонально на сервисе рекаптчи, и использовать свои собственные ключи. Общие ключи больше недействительны.

qДля вывода новостей в пользовательском формате тегом {custom ....} добавлен новый параметр tags="слово1,слово2", который выводит новости которые содержат перечисленные ключевые слова из облака тегов. Например тег {custom tags="новости,шаблоны"} выведет все новости, которые содержат ключевые слова из облака тегов "новости" и "шаблоны".

qПереработана и улучшена система отправки писем с сайта, основным классом для отправки писем стал использоваться класс PHPMailer 5.2.9. Что позволило существенно увеличить совместимость с различными SMTP серверами, а также были устранены проблемы с отправкой писем с использованием некоторых SMTP серверов (например, при использовании SMTP сервера от mail.ru). Для разработчиков сторонних дополнительных модулей, использующих стандартный класс для отправки писем, добавлена возможность отправлять вложенные файлы в письмах.

qПри загрузке аватаров посетителями сайта в свой профиль, добавлено также сохранение в базе данных и имени домена где находится и храниться аватар. Данное нововведение будет особенно полезно сайтам, которые используют используют несколько доменов и сайтов для своего проекта и объединяют базу данных пользователей в единую. Тем самым вашим посетителям не придется на каждом из ваших сайтов загружать аватар повторно, он будет корректно и отображаться на других доменах и сайтах в рамках объединённого проекта.

qСогласно новым требованиям системы "Яндекс Новости", для RSS была изменена система логотипов для данной системы. Теперь обычный логотип должен находиться в файле yandexlogo.png в корне вашего сайта, а квадратный логотип 180 на 180 пикселей должен находиться в файле yandexsquarelogo.png в корне вашего сайта.

qУлучшено отображение формы добавления публикаций в админпанели, при использовании мониторов с небольшим разрешением экрана, а также мониторов, имеющих большую пиксельную плотность, но не большие физические размеры.

qДобавлено использование Gzip сжатия для HTML5 плеера. Тем при использовании сжатия JS файлов в настройках скрипта, он также будет сжиматься и как следствие быстрее загружаться.

qДобавлена возможность указания домашней страницы сайта в настройках скрипта, без указания протокола. Например, вы можете указать вместо "http://site.ru/" просто "//site.ru/" или "/". Данное нововведение будет особенно полезно, для тех, кто делает сайт доступным одновременно по HTTP и HTTPS протоколам. Или планирует в дальнейшем переключить сайт с одного протокола на другой.

qДобавлено отображение количества проголосовавших в опросах к публикациям, сразу после голосования, либо при нажатии на кнопку "Результаты".

qОбновлен визуальный редактор TinyMCE до актуальной версии. Подробнее об изменениях вы можете прочитать на странице http://www.tinymce.com/develop/changelog/index.php?type=tinymce

qИсправлена проблема, связанная с некорректной работой календаря в админпанели скрипта, при перелистывании месяцев в календаре, если текущая дата больше чем количество дней в следующем месяце.

qИсправлена проблема, при которой не принимались размеры для средней копии загружаемой картинки, указываемые в окне загрузки изображений, при загрузке изображений через внешний URL.

qИсправлена проблема, при которой происходило удаление обратного слеша при сохранении информации в блокноте панели управления.

qИсправлена проблема, при которой не показывался HTML5 плеер при предварительном просмотре новостей, перед публикацией их на сайте.

qИсправлена проблема, при которой нельзя было редактировать дополнительные поля при быстром редактировании, если в их значении было указано "0"

qИсправлена проблема, при которой невозможно было загрузить файлы на сервер, если перед его расширением было две точки.

Список изменений относительно версии 10.3:

qДобавлена новая система выставления рейтинга для опубликованных новостей на сайте. Теперь в настройках скрипта вы можете выбрать тип используемого рейтинга на сайте. В настройках скрипта, в админпанели, Вы можете выбрать из трех доступных систем:

Оценка - при данном типе используется пятизвездочный рейтинг публикации. Посетители могут выставлять оценку новости от 1 до 5 и рейтинг выводится в виде усредненной оценки. По сути это существовавший ранее в скрипте рейтинг для публикаций.

Только 'Нравится' - при данном типе, посетитель может отметить, что ему нравится данная публикация (система лайков) и выводится количество пользователей, которым понравилась ваша публикация.

'Нравится' или 'Не нравится' - при данном типе посетители отмечают нравится ли им публикация или не нравится. В данном случае выводится общее значение рейтинга, например, +20 или -10 и т.д.

qДля поддержки новой системы рейтинга в шаблоны краткой и полной (shortstory.tpl и fullstory.tpl) новости добавлена поддержка следующих новых шаблонных тегов:

[rating-type-1] текст [/rating-type-1] - выводят текст, заключенный в них, если в настройках скрипта включено использование первого типа рейтинга 'Оценка'.

[rating-type-2] текст [/rating-type-2] - выводят текст, заключенный в них, если в настройках скрипта включено использование второго типа рейтинга 'Только Нравится'.

[rating-type-2] текст [/rating-type-2] - выводят текст, заключенный в них, если в настройках скрипта включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.

[rating-minus] текст [/rating-minus] - выводят текст, заключенных в них, в виде ссылки для уменьшения рейтинга публикации, выводится данная ссылка только если используется третий тип рейтинга.

[rating-plus] текст [/rating-plus] - выводят текст, заключенных в них, в виде ссылки для увеличения рейтинга публикации, выводится данная ссылка только если используется второй и третий тип рейтинга.

Также поддержка тегов [rating-type-1] текст [/rating-type-1], [rating-type-2] текст [/rating-type-2], [rating-type-2] текст [/rating-type-2] добавлена и для шаблона вывода профиля пользователя userinfo.tpl

qДобавлена поддержка новой системы выставления рейтинга для комментариев, опубликованных на сайте. Включение рейтинга для комментариев осуществляется в настройках скрипта в админпанели скрипта. А также в настройках групп пользователей вы можете разрешить или запретить выставление рейтинга для комментариев, для каждой группы пользователей персонально. Также, как и для рейтинга публикаций, в настройках скрипта вы можете выбрать какой тип рейтинга использовать для комментариев. Вы можете выбрать из трех доступных систем:

Оценка - при данном типе используется пятизвездочный рейтинг комментариев. Посетители могут выставлять оценку комментарию от 1 до 5 и рейтинг выводится в виде усредненной оценки.

Только 'Нравится' - при данном типе, посетитель может отметить что ему нравится данный комментарий (система лайков) и выводится количество пользователей, которым понравился данный комментарий.

'Нравится' или 'Не нравится' - при данном типе посетители отмечают нравится ли им комментарий или не нравится. В данном случае выводится общее значение рейтинга, например, +20 или -10 и т.д.

qДля поддержки новой системы рейтинга комментариев в шаблон вывода комментариев (comments.tpl) добавлена поддержка следующих новых шаблонных тегов:

[rating-type-1] текст [/rating-type-1] - выводят текст, заключенный в них, если в настройках скрипта включено использование первого типа рейтинга 'Оценка'.

[rating-type-2] текст [/rating-type-2] - выводят текст, заключенный в них, если в настройках скрипта включено использование второго типа рейтинга 'Только Нравится'.

[rating-type-2] текст [/rating-type-2] - выводят текст, заключенный в них, если в настройках скрипта включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.

[rating-minus] текст [/rating-minus] - выводят текст, заключенных в них, в виде ссылки для уменьшения рейтинга комментария, выводится данная ссылка только если используется третий тип рейтинга.

[rating-plus] текст [/rating-plus] - выводят текст, заключенных в них, в виде ссылки для увеличения рейтинга комментария, выводится данная ссылка только если используется второй и третий тип рейтинга.

{rating} - выводит выставленный для комментария рейтинг.

{vote-num} - выводит количество пользователей, которые выставили рейтинг для данного комментария.

qДля шаблонов вывода профиля пользователя (userinfo.tpl и profile_popup.tpl) добавлена поддержка следующих новых тегов для вывода суммарного рейтинга комментариев пользователя:

[comments-rating-type-1] текст [/rating-type-1] - выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев первого типа рейтинга 'Оценка'.

[comments-rating-type-2] текст [/rating-type-2] - выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев второго типа рейтинга 'Только Нравится'.

[comments-rating-type-2] текст [/rating-type-2] - выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев третьего типа рейтинга 'Нравится' или 'Не нравится'.

{commentsrate} - выводит суммарный рейтинг всех комментариев данного пользователя.

qДобавлена возможность объединения старых, уже зарегистрированных аккаунтов на сайте, с авторизацией при помощи социальных сетей. В случае если пользователь уже был зарегистрирован на сайте, и при этом входит на сайт с использованием социальной сети, в которой используется тот же e-mail адрес что и на сайте, то на его e-mail адрес будет отправлено письмо с подтверждением на объединение данных аккаунтов. И в случае подтверждения, он сможет входить в свой аккаунт на сайте через данную социальную сеть. Также если он пользуется несколькими социальными сетями, с одним и тем e-mail адресом, он может использовать любую из них для авторизации. В целях безопасности данная опция отключена для пользователей, находящихся в группе администраторов сайта.

qДобавлена возможность для всех шаблонов e-mail сообщений, устанавливать, в каком формате необходимо отправлять письма в HTML формате или в текстовом формате. Тем самым при использовании HTML формата писем, вы можете задать индивидуальное оформление HTML для писем, которые отправляются с вашего сайта.

qВ админпанели, в разделе настроек шаблонов для E-mail сообщений, добавлен новый шаблон для писем, отправляемых при использовании массовой рассылки писем через панель управления скриптом. В данном шаблоне вы задаете необходимое вам HTML оформление писем, тем самым можете сделать персонализированное оформление писем для вашего сайта.

qВ админпанели, в разделе управления пользователями, добавлена возможность удаления всех новостей определенного пользователя. Для этого в разделе управления пользователями, вам необходимо кликнуть по количеству новостей у пользователя и выбрать пункт "Удалить все".

qВ настройки скрипта в раздел настроек безопасности, добавлена возможность указания интервала, в течении которого будет блокироваться IP посетителя на авторизацию, после указанного количества ошибочных вводов пароля. Ранее этот интервал был по умолчанию на 20 минут, а теперь вы можете его установить сами по своему желанию на более больший период времени, что позволит наиболее лучше обезопасить сайт от перебора паролей к аккаунтам.

qДобавлена полная поддержка скриптом протокола IPv6. Если посетитель вашего сайта будет иметь адрес IP в данной версии протокола IP, то он также будет поддерживаться скриптом, предоставляя пользователю все доступные возможности скрипта.

qДобавлена возможность при вставке ссылки в стандартном редакторе BBCODES, указывать также и всплывающую подсказку (title) для данной ссылки.

qДобавлено корректное изменение URL браузера при включении навигации по комментариям при помощи AJAX. Теперь при использовании данной навигации, автоматически также изменяется и URL браузера, что необходимо если посетитель решит перегрузить страницу браузера или скопировать URL.

qДобавлена автоматическая защита от удаления публикаций, путем случайного выставления даты на удаление во вкладке "дополнительно", при добавлении или редактировании публикаций. Теперь помимо того, что необходимо выбрать дату, также необходимо выбрать обязательно и действие, которое необходимо произвести с публикацией по истечении указанного срока.

qВ систему ведения логов действий в админпанели, добавлена также и автоматическая запись информации о том, что публикация была удалена по истечении срока, установленного в параметрах данной новости.

qВ админпанели в разделе редактирования новостей, для расширенного поиска, добавлена возможность выбора порядка сортировки новостей по количеству комментариев и по количеству просмотров.

qДобавлена возможность использования шаблонов при выводе RSS вашего сайта. Для этого используется файл шаблона rss.tpl в общей папке шаблонов /templates/. Тем самым вы можете гибко формировать выводимую информацию в вашем RSS потоке, например, включать туда вывод информации из доп. полей новостей.

qВ настройки категорий в админпанели управления скриптом, добавлена возможность включать или исключать новости опубликованные в данной категории из общего RSS потока. Данное нововведение будет полезно для сайтов, которые хотят исключить определенные категории из RSS, например, при публикации потока в системе Яндекс Новости.

qДля шаблонов main.tpl, fullstory.tpl и addcomments.tpl добавлена возможность использования тегов вывода авторизации пользователей на сайте с использованием социальных сетей. Это те же теги, что и используются в шаблоне login.tpl, такие как [vk] {vk_url} [/vk] и т.д. Тем самым вы можете гибко на страницах вашего сайта предлагать посетителям авторизоваться на вашем сайте, чтобы им не приходилось искать форму авторизации на вашем сайте. Например, если посетитель пролистал вашу страницу до конца читая комментарии к публикации и хочет оставить комментарий, то в форме добавления комментария, вы можете предложить ему также сразу авторизоваться на вашем сайте.

qДля тега вывода публикаций в пользовательском формате {custom ...} добавлен новый параметр categoryexclude="список категорий", который полностью противоположен параметру category="список категорий" и позволяет вывести новости, которые не принадлежат указанным в параметре категориям. Например, {custom categoryexclude="2,7"} выведет все новости которые не принадлежат категориям и id 2 и 7.

qДля тега вывода публикаций в пользовательском формате {custom ...} добавлен новый параметр idexclude="список id новостей", который полностью противоположен параметру id="список id новостей" и позволяет вывести новости, которые не принадлежат указанным в параметре id. Например, {custom idexclude="5-10"} выведет все новости, id которых не принадлежит диапазону от пяти до десяти.

qДля тега вывода публикаций в пользовательском формате {custom ...} добавлен новый параметр sort="asc" и sort="desc", который позволяет указать порядок сортировки публикаций. При использовании значения desc публикации сортируются по убыванию, а при использовании asc по возрастанию. Критерий сортировки указывается также, как и ранее в параметре order.

qДля шаблона вывода RSS информеров (informer.tpl) добавлен новый тег {link} который предназначен для вывода только URL ссылки на страницу источника публикации. Данный тег предназначен для более гибкого оформления шаблона RSS информера и оформления ссылки со своими специальными дополнительными параметрами.

qВ настройки скрипта добавлена возможность включения авторизации на сайте только с использованием социальных сетей. При включении данной настройки, внутренняя регистрация на сайте, автоматически отключается и на сайте смогут авторизоваться только пользователи, имеющие аккаунты в социальных сетях.

qДобавлено автоматическое удаление сортировки публикаций по комментариям, при выводе пользовательской сортировки публикаций с использованием тега {sort} в шаблоне main.tpl, в случае если в настройках скрипта было запрещено комментирование публикаций.

qПроведена адаптация скрипта для корректной поддержки линейки PHP 5.6.x

qДобавлена поддержка настройки, запрещающей регистрацию нескольких пользователей с одного IP на сайте, также и для авторизации на сайте через социальные сети.

qДобавлена более правильное и интеллектуальное сокращение текста в метатеге 'description' при его автоматическом формировании. Сокращение текста производится по завершении логического слова, а не обрывается посередине слова.

qДобавлено ограничение на использование символа '#' в логинах пользователей при их регистрации на сайтах. Т.к. данный символ некорректно обрабатывается модулем mod_rewrite для Апача, в правилах ЧПУ, что может приводить к проблемам с просмотром профилей на сайте данных пользователей при включенном ЧПУ.

qДобавлена система автоматического полного сброса кеша скрипта, после восстановления базы данных из резервных копий.

qДобавлено автоматическое сжатие JS скриптов для HTML5 плеера, если такое сжатие включено в настройках скрипта. Что позволяет ускорить загрузку страниц, использующих данный плеер, в браузер.

qВнесены изменения в логику работы тегов [declination=X] текст [/declination]. Если ранее данный тег выводил число X вместе со словом "текст" в нужном склонении. То теперь данный тег выводит только текст в нужном склонении без числа. Например, если раньше тег [declination={comments-num}]комментари|й|я|ев[/declination] выводил "2 комментария", то теперь тег выводит просто "комментария". Что позволяет использовать данный тег для построения более сложных предложений с нужными склонениями состоящими из нескольких слов. Также данный тег получил глобальную поддержку во всех шаблонах.

qДля шаблона RSS информеров добавлена поддержка нового тега {date=формат даты}, который выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком, но и ее отдельные части. Формат даты задается задается согласно формату, принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время.

qДобавлена поддержка новых российских часовых поясов, введенных после 26 октября 2014 года.

qПроведены улучшения в верстке панели управления скриптом, исправлены некоторые ошибки. Улучшена контрастность текста, для повышения удобства чтения текстов.

qОбновлен визуальный редактор TinyMCE до актуальной версии.

qИсправлена проблема, при которой всегда создавалась средняя копия картинки при загрузке изображения по URL, даже если это отключалось соответствующей галочкой перед непосредственной загрузкой файла.

qИсправлена проблема, связанная с некорректным цитированием комментариев при использовании визуальных WYSIWYG редакторов, если комментарий начинался с какого-либо HTML тега.

qИсправлена проблема при автоматическом переносе длинных слов в комментариях, при которой происходил повторный перенос слов в случае редактирования комментария повторно.

qИсправлена проблема, связанная с некорректной работой редактора шаблонов в админпанели скрипта, на компьютерах Mac c OS X.

qИсправлена проблема, при которой мог происходить некорректный поиск похожих новостей, если была включена опция поиска похожих новостей, находящихся в той же категории что и сама новость.

qИсправлена проблема с обработкой ББ тегов, связанная с возможным повреждением общей верстки шаблона, при определенной комбинации тегов в тексте и верстки шаблона.

qИсправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 10.2:

q1. Добавлена возможность авторизации на сайте с использованием социальный сетей. Включается данная поддержка в настройках скрипта в панели управления. А настройка непосредственно социальных сетей осуществляется в специальном новом разделе панели управления: "Настройка социальный сетей". В данном разделе вы можете настроить какие именно социальные сети вы хотите поддерживать на своем сайте, а также указать необходимые параметры и ключи для работы конкретной социальной сети. Также в данном разделе предоставлена подробная справка как создавать приложения в социальных сетях для авторизации. Всего на данный момент поддерживается шесть социальных сетей: Вконтакте, Одноклассники, Facebook, Яндекс, Mail.ru, Google. Тем самым ваши посетители могут быстро авторизоваться на вашем сайте использованием своего логина и пароля в социальных сетях, без необходимости прохождения процедуры регистрации с вводом каптч, подтверждением E-mail и прочего.

qДобавлена возможность создавать при загрузке изображений на сервер не только уменьшенных копий, но и копий среднего размера загружаемых изображений. Тем самым теперь вы можете создавать при загрузке изображений маленькое превью картинки, среднюю уменьшенную копию и оригинальное изображение.

qДобавлена возможность при вставке загруженных к новостям картинок указывать в каком виде их вставлять. А именно, увеличивать их при клике на них до оригинального изображения, или вставлять их просто в виде изображений, без каких-либо ссылок в них.

qВ настройках скрипта в панели управления скриптом, была убрана настройка смещения времени. Вместо нее, добавлен более удобный выбор часового пояса сервера, по которому будет работать скрипт. Использование часовых поясов более удобно, т.к. автоматически будет производится переход на летнее и зимнее время (например, если сервер находится в Европе, а вы установили Московский часовой пояс, то вам не нужно производить настройки два раза в год). А также в RSS будет транслироваться корректный часовой пояс вашего сервера.

qДобавлена возможность персонального выбора каждым зарегистрированным пользователем своего часового пояса в котором он находится. Данная возможность позволяет посетителям сайта видеть для себя корректное время публикации статей и комментариев. Например, сервер и администрация сайта находится в Москве, а зарегистрированный пользователей находится в Красноярске, то этот пользователь может зайти на сайте в настройки своего профиля и выбрать Красноярский часовой пояс, и после этого он будет видеть дату и время новостей и комментариев уже по своему Красноярскому времени, и т.д.

qДля шаблона редактирования профиля пользователя (userinfo.tpl) добавлен новый тег {timezones} который выводит список доступных часовых поясов в системе, и позволяет выбрать ему свой часовой пояс для своего профиля на сайте.

qДобавлена возможность для опросов, добавленных к публикациям, выводить их не только при просмотре полных новостей, но и при просмотре кратких новостей. Для этого в шаблоне кратких новостей (shortstory.tpl) вы можете использовать тег {poll}. Оформление самого опроса осуществляется также в шаблоне poll.tpl

qДля шаблонов вывода кратких новостей (shortstory.tpl) добавлена возможность использования тегов баннеров, добавленных в управлении рекламными материалами в админпанели. Тем самым вы можете очень гибко выводить баннеры на страницах своего сайта совместно с тегами [newscount=x] {banner_x} [/newscount] и самостоятельно определять после какой новости на странице вы хотите осуществить вывод рекламы.

qДля шаблонов вывода кратких и полных новостей (shortstory.tpl и fullstory.tpl) добавлены новые теги [add-favorites] текст [/add-favorites], которые выводят текст в них в виде ссылки на добавление новость в закладки на сайте, а также добавлены теги [del-favorites] текст [/del-favorites], которые выводят текст в них в виде ссылки удаление новости из закладок на сайте. Данные теги позволят более гибко настраивать дизайн своего сайта, для тех, кто хочет отказаться от общего тега {favorites}, который выводит только одну заранее запрограммированную картинку на данные действия.

qДобавлены новые глобальные теги для шаблонов: [smartphone] текст [/smartphone], которые выводят текст, заключенный в них, если сайт просматривается при помощи смартфона, а также теги [not-smartphone] текст [/not-smartphone], которые выводят текст, заключенный в них, если сайт просматривается посетителем не со смартфона. Данные теги являются глобальными и могут использоваться во всех файлах шаблона. Тем самым вы можете гибко настраивать вывод контента своего сайта, в зависимости от используемого посетителем устройства, например, управлять выводом рекламы для устройств и многое другое.

qДобавлены новые глобальные теги для шаблонов: [tablet] текст [/tablet], которые выводят текст, заключенный в них, если сайт просматривается при помощи планшета, а также теги [not-tablet] текст [/not-tablet], которые выводят текст, заключенный в них, если сайт просматривается посетителем не с использованием планшета. Данные теги являются глобальными и могут использоваться во всех файлах шаблона. Тем самым вы можете гибко настраивать вывод контента своего сайта, в зависимости от используемого посетителем устройства, например, управлять выводом рекламы для устройств и многое другое.

qДобавлены новые глобальные теги для шаблонов: [desktop] текст [/desktop], которые выводят текст, заключенный в них, если сайт просматривается при помощи десктопного браузера (настольные компьютеры, ноутбуки), а также теги [not-desktop] текст [/not-desktop], которые выводят текст, заключенный в них, если сайт просматривается посетителем не с использованием десктопного браузера. Данные теги являются глобальными и могут использоваться во всех файлах шаблона. Тем самым вы можете гибко настраивать вывод контента своего сайта, в зависимости от используемого посетителем устройства, например, управлять выводом рекламы для устройств и многое другое.

qДобавлена возможность указывать для статический страниц файлы шаблонов, находящиеся не только в корневой папке шаблона, но и файлы, находящиеся в подпапках шаблона.

qДобавлена возможность в модуле перекрестных ссылок назначать для каждого ключевого слова, сколько замен данного слова должно производится на странице.

qДля полнотекстового поиска на сайте добавлен логический режим работы поиска, что позволяет существенно улучшить поиск по сайту и релевантность найденной информации по поисковому запросу. Данное нововведение позволяет показывать посетителю наиболее подходящие под его запрос найденные новости, комментарии или статические страницы.

qУлучшен алгоритм обработки уже находящихся ссылок на странице при замене ключевых слов из модуля перекрестных ссылок. Теперь больше не требуется обязательное отсутствие HTML тегов внутри ссылок, замена в них не будет производится независимо от этого.

qУлучшен алгоритм нахождения и замены ключевых слов из модуля перекрестных ссылок, благодаря чему удалось существенно увеличить скорость работы скрипта при большом объёме ссылок.

qДля модуля управления перекрестными ссылками в админпанели скрипта добавлена возможность массовой установки области замены ключевых слов, а также добавлена возможность массово устанавливать учитывать регистр букв или нет.

qДобавлена возможность редактирования значений дополнительных полей для профиля пользователя, непосредственно в админпанели скрипта в разделе настроек собственного профиля пользователем.

qДля шаблона вывода информации о зарегистрированном пользователе на сайте (login.tpl) добавлена возможность вывода значений его дополнительных полей, которые он заполнил при регистрации или в настройках своего профиля. Для вывода дополнительных полей профиля используются точно такие же теги, как и в шаблонах профиля (userinfo.tpl) и в шаблонах комментариев (comments.tpl).

qИз базы данных профилей пользователей убрано стационарное поле ICQ. Данное решение принято с тем что данный мессенджер потерял свою актуальность и использование этого поля незначительно, при том что оно занимает место в базе данных. При этом при необходимости вы можете создать данное поле как дополнительное поле для профиля и использовать его при необходимости на сайте.

qДобавлено указание номера просматриваемой страницы полной новости, в метатеге title, если новость была разбита на несколько страниц.

qВ настройки скрипта добавлена возможность назначение символа - разделителя, для модуля 'speedbar' (хлебные крошки). Данный символ будет использоваться при выводе навигации данного модуля, разделяя разделы сайта. Тем самым вы можете указать любой собственный разделитель, вместо постоянно используемого ранее символа "»".

qВ настройки скрипта добавлена возможность назначение символа - разделителя, для списка категорий, назначенных новости. Данный символ будет использоваться при выводе списка категорий при показе новостей на сайте, разделяя назначенные категории. Тем самым вы можете указать любой собственный разделитель, вместо постоянно используемого ранее символа "»".

qДобавлен вывод информации о сторонних модулях, установленных в панели управления скриптом, в левой боковой панели быстрой навигации по модулям в админпанели.

qПереработано управление ключевыми словами для облака тегов, метатегов и значений доп. полей, имеющих тип перекрестные ссылки. Теперь вы можете не только удалять их в один клик, но и редактировать без удаления, для этого необходимо дважды кликнуть по нужному вам слову. А также добавлен автоматический разбор вставленных слов при помощи Ctr-V, без необходимости нажатия Enter.

qВ панели управления скриптом, добавлена кнопка для быстрого сворачивания и разворачивания боковой панели. Данное нововведение будет полезным для пользователей, имеющих мониторы с низким разрешением экрана, для увеличения рабочей области.

qДобавлен автоматический сброс Кеша сжатых CSS и JS файлов, при редактировании данных файлов в редакторе шаблонов панели управления.

qДля шаблона панели авторизации (login.tpl) добавлен новый тег {group}, который выводит название группы пользователя сайта в которой он находится в данный момент.

qДобавлена поддержка апострофов, для дополнительных полей новостей, имеющих тип "Использовать значения как гиперссылки", и для которых при этом не был включен безопасный режим. Тем самым вы можете использовать, например, такие слова как О'Брайен, д'Артаньян и т.д.

qДобавлено автоматическое формирование имени ЧПУ для категории, при ее создании в админпанели, если оно не было задано пользователем. При этом при создании данного имени применяется транслитерация от указанного имени категории.

qПри добавлении и редактировании категорий в админпанели скрипта, добавлен контроль зарезервированных имен ЧПУ ссылок для категорий, чтобы пользователями не добавлялись имена, которые зарезервированы в DL

qE для других нужд. Например, вы не сможете добавить корневую категорию с именем "catalog", потому как это имя используется для организации на сайте каталогов, но сможете использовать это имя для подкатегории, где данное имя уже не зарезервировано и т.д.

qДобавлен более удобный выбор категорий при создании или редактировании дополнительных полей новостей в панели управления скриптом.

qВ настройки скрипта добавлена возможность указывать количество дней, в течении которых, необходимо хранить логи скрипта, для модуля "Список всех действий, выполненных в админпанели скрипта". При этом минимальным количеством дней в целях безопасности остается 30 дней, чтобы злоумышленник не мог удалить логи действий, а администратор сайта при желании может увеличить необходимое количество дней, например, до трех месяцев или года и т.д.

qОбновлена библиотека Jquery до актуальной версии v1.11.1

qОбновлен визуальный редактор TinyMCE до актуальной версии.

qОбновлен до актуальной версии HTML5 плеер, в котором были исправлены некоторые ошибки с воспроизведением.

qИсправлена проблема, при которой не работало управление настройками скрипта в админпанели, при использовании смартфонов и планшетов.

qИсправлена проблема, при которой происходила некорректная проверка на заполненность доп. полей, если перед полем с типом "список", было обязательное поле с другим типом.

qИсправлена проблема, при которой если поиск производится повторно, а пользователь при этом находился не на первой странице поисковой выдачи, он мог получать пустую страницу, если в новых результатах найдено меньшее количество новостей. Теперь новый поиск возвращает пользователя на первую страницу поисковой выдачи.

qИсправлена проблема, при которой модуль 'speedbar' (хлебные крошки), выводил вложенное нахождение пользователя на статической странице, а при этом фактически он находился на главной странице сайте, если в настройках скрипта был включен показ статической страницы по умолчанию для главной страницы сайта.

qИсправлена проблема, при которой если пользователь редактировал новость, ожидающую модерацию на сайте, не мог управлять загруженными к данной новости картинками, а если при редактировании новости загружал повторно картинки, они не назначались данной новости.

qИсправлена проблема, связанная с некорректной работой тегов [newscount=x] текст [/newscount], при использовании их в пользовательском выводе новостей тега {custom ...}

Список изменений относительно версии 10.1:

qПолностью принципиально новая панель управления скриптом DLE. Дорогие друзья, в данной версии скрипта мы хотим вам предоставить полностью обновлённую панель управления скриптом. Данная панель была разработана с использованием всех последний новейших технологий, которые позволяют сделать процесс управления новостями и другими разделами скрипта, более удобными и информативно понятными. Помимо нового современного дизайна, данная панель управления является адаптивной и способной самостоятельно подстраиваться под используемые устройства, тем самым обеспечивается более удобное управление как с использованием десктопного компьютера, так и с использованием планшетов и смартфонов. Учитывая важность таких моментов как мышечная и зрительная память, а также привычка, мы постарались создать новую панель управления такой, чтобы все для вас оставалось на привычных местах, и вам не пришлось затрачивать много времени на освоение и изучение новой панели управления. Мы очень надеемся, что новая панель вам понравиться, и вы оцените ее по достоинству. В связи с тем, что в новой панели управления активно используются HTML5 и CSS3 стандарты, мы были вынуждены отказаться от поддержки устаревших браузеров IE, для работы в новой панели вам понадобится IE10 и выше, а также актуальные версии браузеров Chrome, Firefox и Opera.

qВсе javascript файлы административной панели DLE теперь отделены от пользовательской части сайта и работают независимо. Например, если вы захотите самостоятельно обновить библиотеки сайта, например такие как Jquery и Jquery UI, вы можете это делать не опасаясь за совместимость с работой административной панели.

qДобавлена новая система управления ключевыми словами для облака тегов и ключевыми словами для мета тегов при редактировании новостей в админпанели. Теперь вы сможете легко в один клик удалять не нужные вам ключевые слова, а также добавлять новые. Перечислять их через запятую больше не нужно, все заполняется интуитивно понятно.

qВ админпанели в разделе управления группами добавлена возможность указания, на основе какой группы, создавать новую группу. Тем самым вы можете создавать новые группы, на основе каких-либо настроенных групп, в качестве шаблона для новой группы.

qВнесены изменения в логику показа рекламных материалов в админпанели, теперь вместо показа добавленного рекламного кода, показывается подсвеченный его исходный код, тем самым при добавлении каких-либо фрагментов HTML тегов, не будет нарушаться верстка админпанели, и вы всегда сможете управлять и редактировать код, непосредственно панели управления.

qСущественно улучшен и переработан модуль редактирования комментариев в админпанели скрипта. Добавлена возможность одиночного удаления комментариев при помощи технологии AJAX, а также добавлена возможность пометки комментария как "Спам" и как следствие автоматического бана спамера и удаления всех его комментариев, и уведомление облачного сервиса о спамере, если это включено в настройках скрипта.

qДобавлена функция динамической загрузки комментариев по мере просмотра посетителем страницы с полной новостью и чтения им комментариев. Данная функциональность основана на принципе: "Отложенная загрузка" и применяется с использованием технологии AJAX. Например, вы установили показывать 30 комментариев на каждую страницу, а у новости 100 комментариев, то при заходе на страницу с новостью, для пользователя будет показано первые 30 комментариев, по мере скроллинга страницы вниз и чтения комментариев, по окончании списка комментариев, вместо навигации по комментариям, на страницу будут автоматически подгружены следующие 30 комментариев и т.д. по мере скроллинга страницы, пока не будут показаны все комментарии к новости. Данная функциональность включается и отключается в настройках скрипта.

qДобавлена возможность указывать заголовок страницы правил сайта непосредственно в админпанели, при редактировании правил для сайта.

qДля вывода новостей с использованием пользовательского тега {custom ...} добавлена возможность вывода навигации по страницам. Для этого добавлен новый параметр тега navigation="yes". При добавлении данного параметра к пользовательскому тегу, будет выводится постраничная навигация по новостям, выводимым данным тегом. Тем самым вы можете осуществлять вывод новостей именно по вашим параметрам и при этом сохранять навигацию по страницам, если новостей по данным параметрами много. Навигация выводится только для страниц сайта, которые поддерживают навигацию для тега {content}, например, главная страница, страницы категорий и т.д. Если же страница не поддерживает навигации, например, вывод полной новости, или статической страницы, то для данного тега навигация автоматически также будет отключена.

qДля тега пользовательского вывода новостей {custom ...} добавлен новый параметр fixed="without", который выводит только новости, которые не были зафиксированы при публикации.

qОбновлен HTML5 плеер до актуальной версии, добавлена поддержка полноэкранного режима в браузере IE11.

qВ модуле перекрестных ссылок добавлена возможность использования ссылок, содержащих в себе URL кодированные символы.

qДобавлена проверка e-mail пользователя при его смене в профиле на то, находится ли данный адрес или пул адресов в списке адресов, запрещенных администратором к регистрации на сайте. Ранее данная проверка проводилась только при первоначальной регистрации посетителя на сайте.

qДобавлено указание логина пользователя в e-mail письме, которое отправляется пользователю, в случае смены им своего e-mail адреса в профиле. Данное нововведение будет полезным также администраторам сайтов, в случае если e-mail адрес пытается сменить бот на несуществующий, в результате администраторам приходят письма о недоставке, и они могут видеть кто меняет данные, и соответственно принять меры к данному пользователю.

qДобавлена удобная система добавления и редактирования дополнительных новостей в админпанели, имеющих свойство "Использовать как гиперссылки". Теперь можно удалить ненужные значение в один клик.

qДобавлена возможность разрешать в управлении рекламными материалами на сайте, вставку рекламных тегов непосредственно в текст новостей. Данная возможность устанавливается отдельного для каждого баннера. Вы можете разрешить или запретить вставку рекламного тега в текст новости. Если для тега будет разрешена вставка в текст новости, то при написании данного тега в тексте новостей, рекламный блок будет опубликован на сайте на месте данного тега. Тем самым вы можете размещать рекламу непосредственно в тексте новостей в удобном для вас месте.

qДобавлена возможность предосмотра рекламных материалов, добавленных в админпанели при помощи отдельного всплывающего окна.

qДля модуля управления перекрестными ссылками добавлена возможность указания области применения, где будет производиться замена ключевого слова ссылкой. Вы можете для каждого ключевого слова указать либо замену по всей страницы, либо замену в новостях и комментариях, либо замену только в новостях, либо замену только в комментариях.

qВ модуле управления перекрестными ссылками в админпанели, добавлена проверка на уже существующие в базе данных ключевые слова. Тем самым избегается появление дубликатов ключевых слов.

qДля модуля управления перекрестными ссылками добавлена возможность использование множественного склонения слов в пределах ключевой фразы, с указанием склонения для нескольких слов одновременно. Например, вы можете указать для замены фразу Иван(ов|ова|ову) Ива(н|на|ну) Иванови(ч|ча|чу). А также добавлена возможность комбинирования фразы из нескольких слов, как содержащий склонения, так и не содержащий, например, фраза: Ремон(т|та|ту) мебели.

qИзменен алгоритм вывода информации при помощи тега {title} в шаблоне вывода похожих новостей (relatednews.tpl). При использовании данного тега будет выводится полный заголовок новости без его обрезания до 75 символов как ранее

qДля шаблона вывода похожих новостей (relatednews.tpl) добавлена поддержка нового тега {title limit="x"}, который выводит заголовок новости, сокращенный до указанного количества в теге X символов. При этом сокращение заголовка производится до завершения логического слова, а не обрывается посередине.

qДля шаблона вывода кратких новостей (shortstory.tpl) добавлена поддержка новых тегов [not-newscount=X] текст [/not-newscount], которые является противоположностью уже существующих тегов [newscount=X] текст [/newscount], и выводят текст заключенный в данные теги при показе любых по счету новостей, кроме указанных X новостей. Данный тег будет полезен, если вы хотите выводить какие-либо элементы оформления во всех новостях при показе кратких новостей, кроме вышеуказанных. Например, что-либо не показывать в первой по списку новости.

qДля шаблона вывода комментариев (comments.tpl) добавлена поддержка новых тегов [not-commentscount=X] текст [/not-commentscount], которые является противоположностью уже существующих тегов [commentscount=X] текст [/not-commentscount], и выводят текст заключенный в данные теги при показе любых по счету комментариев, кроме указанных X комментариях. Данный тег будет полезен, если вы хотите выводить какие-либо элементы оформления во всех по счету комментариях, кроме вышеуказанных. Например, что-либо не показывать в первом по списку комментарии.

qДля стандартного ББ редактора добавлена возможность совместного использования ссылок, написанных при помощи ББ тегов и написанных с использованием HTML кода. HTML код ссылки не будет автоматически заменяться на ББ теги при редактировании.

qПри отключении показа видео и аудиоматериалов для мобильной версии сайта, в настройках скрипта, добавлено также отключение показа видеоматериалов, опубликованных в новости при помощи тега [mediа=...].

qДобавлена поддержка вставки видео с сервиса "Видео mail.ru" с использованием прямой вставки получаемого на видео сервисе кода с тегом <ifrаme ...>.

qДобавлена проверка правописания русского языка в визуальном редакторе TinyMCE. Проверка производится с использованием соответствующего сервиса Яндекса.

qВнесены изменения в алгоритмы показа и ротации баннеров, задаваемых в панели управления скриптом. Теперь вы можете задавать баннерам одно и то же имя и при этом указывать им разные условия для показа. Например, вы можете задать одному баннеру показываться в одной категории и другому баннеру с тем же именем в другой категории, что упрощает верстку шаблона, при которой вы можете добавить в шаблон только один тег и управлять его показом в панели управления.

qДобавлено автоматическое удаление пользователя из подписчиков на комментарии, если пользователь банится на сайте. Тем самым забаненному пользователю не будет приходить уведомления о новых комментариях.

qОбновлен до актуальной версии визуальный редактор TinyMCE.

qИсправлена проблема, при которой посетители сайтов могли видеть новость, которая уже опубликована, но время ее публикации еще не наступило, вбив соответствующий номер новости в URL браузера. Теперь просматривать подобные новости могут только администраторы и редакторы сайта.

qИсправлена проблема, при которой если новость в админпанели добавляется не от имени авторизованного пользователя, а указывается другой логин автора, то загруженные картинки от имени данного пользователя не назначались данной новости.

qИсправлена проблема, при которой во время перестроения публикаций в админпанели происходило повреждение текста, опубликованного в тегах [cоde]...[/cоde], если использовались при этом визуальные редакторы.

qИсправлена проблема, при которой мог сбиться счетчик комментариев у новости, если комментарии удалялись в разделе "IP утилиты" и при этом часть комментариев пользователя, находилась на модерации.

qИсправлена проблема, при которой отправлялись уведомления о новых комментариях пользователям, если данные комментарии только отправлялись на модерацию.

qИсправлена проблема с некорректной вставкой тегов [leech] в визуальном редакторе TinyMCE.

qИсправлена проблема при которой не работало цитирование в комментариях, при включении для комментариев редактора TinyMCE.

qИсправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 10.0:

qВ админпанели добавлен новый раздел "Перекрестные ссылки". Данный раздел предназначен для быстрого создания перелинковки по сайту по ключевым словам. В данном разделе вы задаете ключевое слово и URL, в случае нахождения данного ключевого слова на вашей странице, оно будет заменено на гипертекстовую ссылку. В отличии от модуля "фильтр слов", который также имеется в админпанели, в данном модуле ключевые слова ищется по всей странице, включая весь контент (новости, комментарии, шаблоны, сторонние модули и т.д.), а не только в новостях и комментариях. Также любое внесение или изменение ключевых слов в данном разделе, приводит к моментальному применению по всему сайту и всем страницам сайта, и не требуется никакого перестроения публикаций. Также в данном модуле поддерживается указание склонения слов, например вы можете задать ключевое слово "Иван(ов|ова|ову)" и ссылка будет применяться к словам: Иванов, Иванова, Иванову и т.д. Поиск ключевых слов осуществляется только по словам целиком, а не просто по всем вхождениям в тексте.

qДобавлен новый HTML5 плеер для воспроизведения видео на сайте. Данный плеер включается в настройках видеопроигрывателей и применяется когда вы публикуете видео в mp4 формате, сжатого кодеком H.264, используя теги [vidеo=http://site.ru/video.mp4]. А также он применяется при вставке видео с сервиса Youtube при помощи тега [mеdia=http://www.youtube.com/watch?v=rT_OmTMwvZI]. Данный плеер имеет одно очень важное преимущество относительно флэш плеера, а именно он не требует дополнительных плагинов для браузера, и видео может быть просмотрено на вашем сайте, если посетитель использует смартфоны при просмотре вашего сайта.

qДобавлен контроль и обработка неверных ЧПУ ссылок для статических страниц. Теперь совместно с новостями, некорректные ЧПУ ссылки обрабатываются и для статических страниц. Тем самым, если включен ЧПУ на сайте, то все ссылки без ЧПУ на статические страницы будут автоматически, при помощи 301 редиректа, перенаправлены на корректные ссылки.

qВ настройки скрипта добавлена возможность установки поиска похожих новостей для публикации, только из тех категорий, которым принадлежит данная публикация. Тем самым вы можете установить, чтобы похожие новости искались либо по всему сайту, либо только из тех категорий, которым принадлежит опубликованная новость.

qДля RSS экспорта новостей, предназначенных для экспорта в Яндекс новости, добавлена возможность экспортирования в RSS поток ссылок на картинки находящиеся в подробной новости.

qПолностью переработано формирование навигации по страницам полной новости, если текст публикации был разбит на несколько страниц. Теперь для навигации по страницам полной новости введен дополнительный файл шаблона splitnewsnavigation.tpl где вы можете задать любой удобный для вас вид навигации.

qВ настройки категорий в админпанели добавлена возможность для каждой категории отдельно устанавливать настройку: «Выводить новости опубликованные в субкатегориях». При этом глобальная настройка для всех категорий также остается в настройках скрипта. Тем самым вы можете персонально для каждой категории устанавливать нужно ли выводить новости из субкатегорий или нет. Например, вы можете глобально разрешить данную настройку, а для определенных категори

qй запретить, и наоборот.

qВ настройки скрипта добавлена возможность включения и отключения автоматической генерации мета тегов 'description' и 'keywords' в случае если они не были заполнены вручную при публикации новости. Ранее автоматическое формирование мета тегов существовало всегда, теперь при желании вы можете это отключить.

qВ настройки скрипта добавлена возможность устанавливать список IP адресов с которых разрешен доступ к админпанели. В отличие от ограничения по IP в настройках профилей, данное ограничение распространяется только на админпанель DLE и применяется для всех пользователей, имеющих доступ к админпанели, даже если пользователь появится минуя скрипт DLE, например будет внедрен в базу данных MySQL.

qВ настройки групп в админпанели скрипта добавлена возможность разрешать или запрещать для определенных групп пользователей восстановление забытых паролей на сайте. Данную возможность рекомендуется отключать для групп пользователей, имеющих расширенные полномочия на сайте, тем самым в случае кражи у пользователей почтовых аккаунтов, нельзя будет получить доступ к их аккаунтам на вашем сайте, путем функции восстановления забытого пароля.

qДобавлен новый тип автоматической фильтрации спама на сайте, а именно "слабая фильтрация". Тем самым фильтрация теперь работает следующим образом: При слабой фильтрации пользователь или его комментарий будет отклонен если вероятность того что он спамер составляет более 80%, при умеренной фильтрации пользователь или его комментарий будет отклонен если вероятность того что он спамер составляет более 50%, при усиленной фильтрации достаточно его нахождения в спам базе, для отклонения доступа, вероятность при этом не учитывается.

qОбщая настройка автоматической защиты от спама при добавлении комментариев, была перенесена из настроек скрипта, в настройки групп. Тем самым вы можете включать и отключать данную настройку для различных групп пользователей.

qДобавлен контроль E-mail адреса при регистрации, при проверке является ли посетитель возможным спамером. Ранее проверка при регистрации осуществлялась только по IP адресу, теперь проверка осуществляется и по E-mail адресу.

qДля модуля 'хлебные крошки' (speedbar) добавлена нумерация страница страниц при навигации по страницам того или иного раздела сайта.

qДобавлена возможность подключать в шаблонах при помощи тега {include file="file.tpl"} файлы шаблонов, из других шаблонов. Для этого необходимо указать путь к файлу начиная от корня шаблонов /templates/, например {include file="/templates/file.tpl"} или {include file="/templates/Gemini/file.tpl"} и т.д. Данное нововведение будет полезно для сайтов, которые используют несколько шаблонов одновременно на сайте и которым необходимо например подключать во всех шаблонах, один универсальный файл шаблона.

qДобавлены новые режимы работы и возможности для антивируса в админпанели скрипта. Теперь в случае если не был создан снимок системы и вы нажимаете на кнопку "Антивирус" в панели управления скриптом, то происходит проверка только папок скрипта DLE. В случае если вы нажимаете на тщательную проверку, то сканируются все папки в корне вашего сайта, независимо от того принадлежат ли они DLE или нет. В случае если вы создаете снимок файлов, то делается снимок всех без исключения важных файлов на сервере, независимо от их расположения и от того находятся ли они в папках DLE. Тем самым встроенный антивирус в DLE может контролировать изменения в любых важных файлах на сервере, даже в файлах других скриптов, не имеющих отношение непосредственно к DLE.

qДля модуля вывода стандартной каптчи добавлены новые алгоритмы вывода текста, усложняющие автоматическое распознавание.

qДобавлена защита администрации от самих себя при редактировании собственного профиля в разделе редактирования пользователей, а именно они больше не могут менять собственную группу, и тем самым защищаются от случайного переноса в другую группу. Другими словами, неопытные пользователи скрипта, не смогут больше забанить сами себя.

qДобавлена возможность назначения автора публикации еще при первичном написании публикации в админпанели скрипта, а не только при редактировании публикации.

qДобавлен новый механизм ротации баннеров, добавленных в админпанели скрипта в разделе управления рекламными материалами. Ранее, в случае если баннеры имели одинаковые имена, ротация происходила в случайном порядке. Теперь, при первом заходе на сайт, пользователю показывается баннер в случайном порядке, а при посещении последующих страниц сайта, ему будут показываться ранее еще не просмотренные баннеры, тем самым ему будут показаны все баннеры заданные в панели управления.

qДобавлена поддержка нового формата кода, который используется для вставки видео с сервиса Youtube.

qДобавлена поддержка тегов [hidе] текст [/hidе], предназначенных для вывода скрытого текста, в дополнительных полях для новостей, если вывод новостей осуществляется при помощи пользовательского тега {custom ....}

qДля шаблонов вывода краткой и полной новости (shortstory.tpl и fullstory.tpl), а также для шаблонов вывода комментариев и персональных сообщений (comments.tpl и pm.tpl) добавлена поддержка новых тегов [declination=X]текст[/declination], предназначенных для склонения слов относительно чисел. В качестве параметров тега вместо X передается число, а вместо "текст" передается корень слова с окончаниями. Окончания слова перечисляются при помощи символа "|". Данный тег полезно использовать с другими тегами, выводящими например количество просмотров новости или количество комментариев. Например [declination={comments-num}]комментари|й|я|ев[/declination] в зависимости от количества комментариев будет выводить: "1 комментарий", "2 комментария", "10 комментариев" и т.д. Или например тег [declination={views}]просмотр|а|ов[/declination] в зависимости от количества просмотров новости будет выводить "1 просмотр", "2 просмотра", "5 просмотров" и .д.

qДля шаблонов вывода кратких новостей (shortstory.tpl), а также для шаблонов пользовательского вывода новостей при помощи тега {custom ....} добавлена поддержка нового тега: [newscount=x] текст [/newscount] который выводит текст указанный в тегах если показывается X новость, где X это число показываемой на странице новости. Например [newscount=1] текст [/newscount] покажет текст при показе первой по счету на странице новости. Данный тег полезен для вебмастеров, которые хотят например регулировать где им показывать рекламу на сайте между новостями. Например, добавленный в самый конец шаблона код [newscount=2,5] рекламный код [/newscount], будет показывать рекламу после второй и пятой новости.

qПолностью переработан вывод результатов поиска по сайту. Теперь для шаблона выводов результатов поиска (searchresult.tpl) вы можете использовать точно такие же теги без ограничений, какие вы используете в шаблонах вывода кратких новостей и в шаблонах вывода комментариев. Тем самым страница поиска и выводов результатов больше ничем не ограничена по функциональности и по используемым тегам.

qДобавлена возможность снимать новость с публикации на сайте, при быстром редактировании новости.

qДобавлена возможность поиска похожих новостей, при добавлении новостей на сайте. При этом в отличие от поиска похожих новостей в админпанели, при добавлении на сайте не предлагается удаление или редактирование новостей, только их просмотр.

qУлучшена система вставки ссылок в BBCODES редакторе. Ввод ссылки и текста для ссылки осуществляется в пределах одного окна, а также производится автоматический анализ выделенного текста в редакторе, является она ссылкой или нет, и заполняется соответствующее поле в окне.

qДля шаблона E-mail сообщений, которое используется для отправки уведомлений о появлении нового комментария для администрации сайта и подписчиков, добавлен новый тег {%title%} который выводит заголовок новости в которой был написан новый комментарий. А также добавлена поддержка ЧПУ для тега {%link%} в данном шаблоне.

qДля тега пользовательского вывода публикаций {custom ...} для атрибута id="...", добавлена поддержка указания диапазона ID новостей с использованием тире. Например, тег {custom id="1,4-8,11" aviable="global" order="date"} выведет новости c номером 1, новости с диапазоном id c 4 по 8, а также новость с номером 11.

qДля шаблона вывода персональных сообщений (pm.tpl) добавлена возможность просмотра, является ли пользователь в данный момент онлайн или оффлайн на сайте. Для этого были добавлены теги: [online] текст [/online] - выводят текст если пользователь онлайн, [offline] текст [/offline] - выводят текст если пользователь оффлайн. Статус активности пользователя определяется интервалом в 20 минут, если в течении 20 минут не было никакой активности и посещений сайта от данного пользователя, то его статус автоматически становится оффлайн.

qДля шаблона вывода комментариев (comments.tpl) добавлено использование новых тегов: [commentsgroup=1,2,3] текст [/commentsgroup] которые выводят заключенный в них текст указанных в них, если комментарий был написан пользователем принадлежащем перечисленным группам, также добавлен тег [not-commentsgroup=1,2,3] текст [/not-commentsgroup], который выводит заключенный в них текст если комментарий был написан пользователем не принадлежащем указанным группам. Тем самым у вас появляется возможность сделать разное оформление комментариев написанных различными группами пользователей. Например, вы можете сделать один вид комментариев, оставленных администраторами, и другой вид комментариев оставленных обычными посетителями.

qДля шаблона вывода комментариев (comments.tpl) добавлена поддержка нового тега: [commentscount=x] текст [/commentscount] который выводит текст указанный в тегах если показывается X комментарий, где X это число показываемого на странице комментария. Например [commentscount=1] текст [/commentscount] покажет текст при показе первого по счету на странице комментария. Данный тег полезен для вебмастеров, которые хотят например регулировать где им показывать рекламу на сайте между комментариями. Например, добавленный в самый конец шаблона код [commentscount=1,10] рекламный код [/commentscount], будет показывать рекламу после первого и десятого комментария.

qДобавлена поддержка кириллических доменов для тегов [leech=....] при публикации защищенных ссылок в новостях, для сайтов использующих кодировку windows-1251.

qУлучшена система выбора категорий при публикации и редактировании новостей в админпанели скрипта. Выбранные категории больше не убираются из списка, а остаются, при этом выделяются цветом. Тем самым вы можете и дальше легко ориентироваться в структуре категорий, при их выборе.

qУбран устаревший флэш загрузчик файлов, т.к. одновременную загрузку нескольких файлов поддерживает стандартных загрузчик во всех современных браузерах, а также улучшено визуальное отображение загрузки файлов в стандартном загрузчике.

qОбновлен визуальный редактор TinyMCE до актуальной новой линейки 4.x

qИсправлена проблема, при которой не работал поиск на главной странице, если в качестве главной в настройках скрипта был включен показ статической страницы.

qИсправлена проблема, при которой нельзя было добавлять в фильтр по логину в админпанели скрипта, логины содержащие в себе кириллицу, если на сервере установлена версия PHP 5.4.x. и выше.

qИсправлена проблема, связанная с некорректной публикацией заголовка новости в мета тегах страницы, если заголовок содержит кавычки.

qИсправлена проблема, связанная с некорректной работой каптчи Recaptcha от сервиса Google, при использовании на сайте SSL протокола.


Установка и обновление скрипта

Navigation: Работа с движком >

Установка и обновление скрипта

 Return to chapter overview

Установка скрипта на сервер

Установка скрипта на сервер проходит в автоматическом режиме и не должная вызывать особых проблем, но вам необходимо выполнить некоторые действия по настройке прав доступа на папки.

1.Для начала скопируйте все файлы из папки upload в данном архиве на ваш сервер.

2.Установите для папки templates и всем вложенным в нее папкам права на запись (CHMOD 777)

3.Установите для всех файлов в папке templates права на запись (CHMOD 666)

4.Установите права для записи (CHMOD 777) для папок backup, uploads, а также для всех папок, находящихся внутри них.

5. Установите права для записи (CHMOD 777) для папок /engine/data/, /engine/cache/, /engine/cache/system/.

6.Запустите файл install.php в URL вашего браузера и следуйте его инструкциям.

Внимание: чистая установка скрипта приводит к удалению данных ранее установленного скрипта DLE, для обновления установленного скрипта читайте инструкцию по обновлению ниже.

Автоматический инсталлятор проверит все необходимые файлы и настроит подключение к базе данных. После завершения установки вы сможете посмотреть работу скрипта на демонстрационной странице http://website.com/index.php. Для доступа к админпанели необходимо запустить http://website.com/admin.php

Обновление скрипта с более старых версий или демоверсий:

1.Создайте резервную копию базы данных и всех файлов скрипта на сервере.

2.Обновите все файлы из папки /upload/ вашего архива (за исключением /templates/). Внимание: Файлы из архива дистрибутива, нужно заливать на сервер поверх существующих, а не удалять предварительно папки на сервере.

3.Запустите файл http://website.com/upgrade/index.php, и следуйте дальнейшим инструкциям.

4.Удалите папку /upgrade/ и файл install.php с вашего сервера.

5.В админпанели на главной странице выберите "Очистку кеша", а также полностью очистите кеш браузера, чтобы он скачал новые JS файлы с сервера, а не использовал старые файлы из кеша

6.Внесите необходимые изменения в ваши шаблоны, согласно списку изменений, опубликованному на сайте по адресу: http://dle-news.ru/extras/diffs/

7.Проверьте настройки скрипта в админпанели.

Внимание: обновление скрипта возможно только с версий 3.5 и выше, поддержка более ранних версий прекращена.


Начало работы и шаблоны

Navigation: Работа с движком >

Начало работы и шаблоны

 Return to chapter overview

Одной из особенностей движка является то, что в него можно подключить любой существующий дизайн не испытывая при этом каких-либо ограничений. Движок поддерживает работу с несколькими шаблонами одновременно. Все шаблоны находятся в папке /tеmplates/. Каждая вложенная папка в этой папке является отдельным макетом сайта. Поэтому если вы скачали новый скин для движка просто скопируйте его в папку и разрешите его использование в админ панели. Также вы можете разрешить смену дизайна для посетителей вашего сайта и они сами смогут выбрать, как будет выглядеть их любимый сайт. Также вы можете установить количество новостей, выводимых на страницу, для этого зайдите в настройки скрипта и установите соответствующий параметр.

Внимание: В файлах шаблона вы можете использовать обычный html текст, либо можете использовать специальные теги, для вставки тех или иных возможностей, прочитать подробнее о допустимых тегах вы сможете в данном руководстве ниже в разделе Шаблоны.


Вывод новостей на страницах

Navigation: Работа с движком >

Вывод новостей на страницах

 Return to chapter overview

Основной макет вашей страницы находится в файле шаблона main.tpl именно этот файл скрипт DLE подгружает в первую очередь и к нему подключаются все другие компоненты движка. Остановимся на основных из них. {AJAX}, {info}, {content}, {custom} именно эти теги отвечают за правильный вывод новостей.

Тег {AJAX} выводит служебные скрипты JavaScript необходимые для нормальной работы движка в целом и технологии AJAX в частности. Рекомендуется размещать в самом начале шаблона после тега <body>

Тег {info} выводит служебную информацию и ошибках о произведенных действиях (например "Вход не выполнен, неверный пароль" или "Необходимо заполнить все поля") рекомендуется устанавливать перед тегом {content}

Тег {content}, отвечает за непосредственный вывод статей и прочих встроенных модулей в движок

Тег {tags}, отвечает за вывод облака тегов (специальных ключевых слов добавленнных в новость)

Теги [sort]{sort}[/sort], отвечают за вывод выбора пользователем порядка сортировки новостей, если это разрешено в настройках скрипта

Тег {custom}, отвечает за вывод статей в пользовательском формате, имеет следующие параметры:

{custom id="1,2,5-8" category="2,3,5-8" author="x" days="x" template="custom" available="global" navigation="no" from="0" limit="10" fixed="yes" order="date" sort="desc" cache="yes"}

Где

id это список ID новостей которые вы хотите вывести, разделяются запятой без пробелов. Также вы можете указывать диапазон ID новостей при помощи тире. Например 1,4-8,11 выведет новости c ID 1, новости имеющих id c 4 по 8, а также с ID 11.

idexclude полностью противоположен параметру id="список id новостей" и позволяет вывести новости, которые не принадлежат указанным в параметре id. Например, {custom idexclude="5-10"} выведет все новости, id которых не принадлежит диапазону от пяти до десяти.

category это список ID категорий, из которых производить выборку новостей, разделяются запятой без пробелов. Также вы можете указывать диапазон категорий при помощи тире. Например 1,4-8,11 выведет новости из категории 1, категорий имеющих id c 4 по 8, а также из категории 11.

categoryexclude полностью противоположен параметру category="список категорий" и позволяет вывести новости, которые не принадлежат указанным в параметре категориям. Например, {custom categoryexclude="2,7"} выведет все новости которые не принадлежат категориям и id 2 и 7.

tags это список ключевых слов из облака тегов, назначенных новостям. Например тег {custom tags="новости,шаблоны"} выведет все новости, которые содержат ключевые слова из облака тегов "новости" и "шаблоны".

template файл шаблона который будет использоваться при выводе новостей в данном случае это будет custom.tpl если вы используете на сайте несколько шаблонов то данный файл должен присутствовать в каждом шаблоне. В данном шаблоне используются теги аналогичные для короткой новости.

available раздел в котором будет выводится запрашиваемые новости, может принимать следующие значения:

global - во всех разделах

main - на главной странице

date - при просмотре новостей за определенные даты

cat - при просмотре категории

showfull - при просмотре полной новости

search - при просмотре результатов поиска

userinfo - при просмотре профиля

register - при регистрации

stats - при просмотре статистики

pm - при просмотре персональных сообщений

feedback - при просмотре обратной связи

favorites - при просмотре закладок

newposts - при просмотре новых сообщений

addnews - при добавлении новости

lastnews - при просмотре последних новостей на сайте

lastcomments - при просмотре последних комментариев

lostpassword - при восстановлении пароля от аккаунта на сайте

static - при просмотре статических страниц

catalog - при просмотре каталога страниц

alltags - при просмотре облака тегов

tags - при просмотре новостей из облака тегов

allnews - при просмотре всех новостей на сайте или всех новостей какого либо пользователя

Вы можете комбинировать разделы при помощи "|", например available="userinfo|register|main" будет выводить ваши новости на главной, при регистрации и при просмотре профиля пользователя.

from номер новости с которой начнется вывод

limit сколько новостей будет выведено

order критерий сортировки новостей, может принимать следующие значения:

date - сортировка новостей по дате

rating - сортировка новостей по рейтингу

reads - сортировка новостей по количеству просмотров

comments - сортировка новостей по количеству комментариев

title - сортировка новостей по заголовкам новостей

rand - сортировка новостей в случайном порядке

sort указывает порядок сортировки публикаций. При использовании значения desc публикации сортируются по убыванию, а при использовании asc по возрастанию.

author логин автора новости, при указании данного параметра будут выводится только новости указанного автора. Допускается перечисление через запятую нескольких авторов. Например, тег {custom author="admin" limit="5"} выведет 5 новостей автора с логином "admin".

authorexclude указывает логины авторов, которые необходимо исключить из показа. Логины авторов в данном параметре также можно перечислять через запятую. Например, при использовании {custom authorexclude="admin,test"} будут выведены новости всех авторов, кроме авторов с логином "admin" и логином "test".

catalog выводятся все публикации содержащие указанный в параметре символьный код. Допускается также перечисление символьных кодов в параметре через запятую. Например, при использовании {custom catalog="а,б"} будут выведены новости, которые содержат символьные коды "а" или "б".

catalogexclude выводятся все публикации, которые не содержат указанный в параметре символьный код. Допускается также перечисление символьных кодов в параметре через запятую. Например, при использовании {custom catalogexclude="а,б"} будут выведены новости, которые не содержат символьные коды "а" и "б".

xfields выводятся все публикации, содержащие указанное в параметре значение дополнительных полей новостей. Допускается также перечисление значений в параметре через запятую. Например, при использовании {custom xfields="значение 1,значение 2"} будут выведены новости, в которых есть дополнительные поля содержащие "значение 1" или "значение 2".

xfieldsexclude выводятся все публикации, не содержащие указанное в параметре значение дополнительных полей новостей. Допускается также перечисление значений в параметре через запятую. Например, при использовании {custom xfieldsexclude="значение 1,значение 2"} будут выведены новости, в которых нет дополнительных полей содержащих "значение 1" и "значение 2".

days указывает временной период, где x это количество дней за которые выводить публикации. Например, тег {custom days="2" limit="5"} выведет 5 новостей за 2 последних дня.

cache принимает значения yes или no - устанавливает кешировать вывод или нет, рекомендуется кешировать для снижения нагрузки.

navigation принимает значения yes или no - устанавливает использовать вывод навигации по страницам или нет. Навигация выводится только для страниц сайта, которые поддерживают навигацию для тега {content}, например, главная страница, страницы категорий и т.д. Если же страница не поддерживает навигации, например, вывод полной новости, или статической страницы, то для данного тега навигация автоматически также будет отключена независимо от указанного значения.

fixed принимает значения yes, no, only или without - устанавливает учитывать ли при выводе публикаций, то что новости были зафиксированы или нет. В случае если указано yes, то зафиксированные новости будут выведены в начале, если no, то зафиксированные новости будут выводится в общем списке новостей без учета данного параметра. В случае если указано значение only, то будут выводится только зафиксированные новости. В случае если указано значение without, то зафикисрованные новости не будут вообще выводится.

Внимание все параметры данного тега являются необязательными, необходимо указать только как минимум один любой параметр, все остальные параметры, если они не заданы, будут взяты из общих настроек скрипта. Например:

{custom id="1,2" order="date"} - выведет новости с ID 1 и 2 и отсортирует их по дате

{custom category="2,7" from="5" cache="yes"} - выведет новости из категорий 2 и 7 при этом количество новостей будет взято из настроек скрипта, а выборка будет осуществляться после 5 новости, отвечающей данному условию

{custom order="date" from="9" limit="5"} - выведет 5 последних новостей, начиная с десятой новости

Помните что каждое использование этого тега создает дополнительную нагрузку на базу данных, т.к. идет дополнительная выборка, поэтому используйте ее с умом если необходимо экономить на ресурсах.

Тег [available=раздел] текст [/available], выводит текст заключенный в теги если просматривается указанный раздел сайта:

Тег принимает параметры аналогичные параметру available тега {custom}. Вы можете комбинировать разделы при помощи "|", например userinfo|register|main

Для примера:

[available=userinfo|register|main] текст [/available]

будет выводить текст заключенный в теги, на главной, при регистрации и при просмотре профиля пользователя.

Внимание вы можете задать также тег [not-available=userinfo|register|main] текст [/not-available] который полностью противоположен тегу aviable и выводить текст везде кроме перечисленных разделов.

Тег [category=X]текст[/category], выводит текст заключенный в теги если просматривается указанная категория:

Тег принимает в качестве параметра ID категории, и допускает перечисление нескольких категорий

[category=1,2,3,7-10] текст [/category]

будет выводить текст заключенный в теги, если посетитель просматривает категории у которых ID равен 1 или 2 или 3, а также с 7 до 10.

Внимание вы можете задать также тег [not-category=1,2,3,7-10] текст [/not-category] который полностью противоположен тегу category и выводить текст везде кроме перечисленных категорий.

Тег [group=X]текст[/group], выводит текст заключенный в теги если пользователь принадлежит указанной группе пользователей:

Тег принимаем в качестве параметра ID группы, и допускает перечисление нескольких групп

[group=1,2,3] текст [/group]

будет выводить текст заключенный в теги, если посетитель является администратором, главным редактором или журналистом.

Внимание вы можете задать также тег [not-group=1,2,3] текст [/not-group] который полностью противоположен тегу group и выводить текст для всех, кроме перечисленных групп.

[page-count=1,2,3] текст [/page-count]

Будет выводить текст заключенный в них, если пользователь находится на определенной по номеру страницы в навигации по новостям, независимо от раздела сайта, где 1,2,3 это номера страниц в навигации. Данный тег позволит очень гибко настроить вывод той или иной информации, на определенной странице и полезен для информационных блоков и рекламы. Вы можете использовать данный тег совместно с другими, опеределяющими разделы сайта и категории.

Например, комбинация тегов [aviable=cat][category=1][page-count=1] текст [/page-count][/category][/aviable] выведут текст, только если пользователь просматривает первую страницу категории с id1, и при этом просматривает именно краткие новости, и при переходе на другую страницу в этой категории, данного текста он уже не увидит.

[not-page-count=1,2,3] текст [/not-page-count]

Выводит текст опубликованный в тегах на любых номерах страниц кроме указанных в теге.

{banner_имя} этот тег предназначен для вывода рекламной информации на сайте. Само имя для баннера задается в специальном модуле в админпанели.

[banner_имя] текст [/banner_имя] выводят текст заключенных в них, если указанный баннер выводится на странице сайта.

{inform_имя} этот тег предназначен для вывода RSS информеров и новостей с других сайтов. Имя и все настройки для данного тега устанавливаются в админпанели скрипта.

[static=имя страницы] текст [/static]

будет выводить текст заключенный в теги, если посетитель просматривает статическую страницу с указанным именем. Допускается также перечесление страниц в теге через запятую. Например [static=test1,test2,test3] текст [/static] будет выводить текст на страницах test1, test2 и test3

[not-static=имя страницы] текст [/not-static]

будет выводить текст заключенный в теги, если посетитель не просматривает статическую страницу с указанным именем. Допускается также перечесление страниц в теге через запятую.

[smartphone] текст [/smartphone]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт с мобильного телефона.

[not-smartphone] текст [/not-smartphone]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт не с мобильного телефона.

[tablet] текст [/tablet]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт с планшета.

[not-tablet] текст [/not-tablet]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт не с планшета.

[desktop] текст [/desktop]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт со стационарного компьютера или ноутбука.

[not-desktop] текст [/not-desktop]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт не со стационарного компьютера или ноутбука.

Также вы можете подключать один шаблон в другой, используя тег {include file="my_block.tpl"} данный тег подключает указанный файл my_block.tpl в шаблон. Тег призван облегчить структуру шаблона, если используется сложная верстка со множеством тегов.

{customcomments id="1,2,5-8" category="2,3,5-8" author="x" days="x" template="custom" available="global" from="0" limit="10" order="date" sort="desc" cache="yes"}

Выводит комментарии в любом месте сайта в пользовательском формате. Данный тег является вспомогательным дополнительным выводом комментариев, и может, например, использоваться для вывода последних комментариев на главной странице сайта в блоке и т.д.

Данный тег может принимать следующие параметры:

id - список ID комментариев, которые вы хотите вывести, разделяются запятой без пробелов. Также вы можете указывать диапазон ID комментариев при помощи тире. Например, 1,4-8,11 выведет комментарии c ID 1, комментарии имеющие id c 4 по 8, а также с ID 11.

category - список ID категорий новостей, из которых производить выборку комментариев, разделяются запятой без пробелов. Также вы можете указывать диапазон категорий при помощи тире. Например 1,4-8,11 выведет комментарии из категории 1, категорий имеющих id c 4 по 8, а также из категории 11.

categoryexclude - полностью противоположен параметру category="список категорий" и позволяет вывести комментарии, новости которых не принадлежат указанным в параметре категориям. Например, {customcomments categoryexclude="2,7"} выведет все комментарии у новостей, которые не принадлежат категориям и id 2 и 7.

author - указывает логин автора комментария, при указании данного параметра будут выводится только комментарии указанного автора. Допускается перечисление через запятую нескольких авторов. Например, тег {customcomments author="admin" limit="5"} выведет 5 комментариев автора с логином "admin".

authorexclude - указывает логины авторов, которые необходимо исключить из показа. Логины авторов в данном параметре также можно перечислять через запятую. Например, при использовании {customcomments authorexclude="admin,test"} будут выведены комментарии всех авторов, кроме авторов с логином "admin" и логином "test".

days - указывает временной период, где x это количество дней, за которые выводить комментарии. Например, тег {customcomments days="2" limit="5"} выведет 5 комментариев за 2 последних дня.

template - файл шаблона который будет использоваться при выводе комментариев в данном случае это будет custom.tpl если вы используете на сайте несколько шаблонов, то данный файл должен присутствовать в каждом шаблоне. В данном шаблоне используются теги аналогичные тем, что вы используете в шаблоне вывода комментариев (comments.tpl).

available раздел в котором будет выводится запрашиваемые комментарии, может принимать следующие значения:

global - во всех разделах

main - на главной странице

date - при просмотре новостей за определенные даты

cat - при просмотре категории

showfull - при просмотре полной новости

search - при просмотре результатов поиска

userinfo - при просмотре профиля

register - при регистрации

stats - при просмотре статистики

pm - при просмотре персональных сообщений

feedback - при просмотре обратной связи

favorites - при просмотре закладок

newposts - при просмотре новых сообщений

addnews - при добавлении новости

lastnews - при просмотре последних новостей на сайте

lastcomments - при просмотре последних комментариев

lostpassword - при восстановлении пароля от аккаунта на сайте

static - при просмотре статических страниц

catalog - при просмотре каталога страниц

alltags - при просмотре облака тегов

tags - при просмотре новостей из облака тегов

allnews - при просмотре всех новостей на сайте или всех новостей какого либо пользователя

Вы можете комбинировать разделы при помощи "|", например available="userinfo|register|main" будет выводить ваши новости на главной, при регистрации и при просмотре профиля пользователя.

from - указывает номер комментария с которой начнется вывод. Нумерация комментариев начинается с нуля. Например, если вы хотите пропустить первый комментарий, который совпадает с вашими условиями, то нужно указывать from="1"

limit - указывает сколько комментариев будет выведено.

order - указывает критерий сортировки комментариев, может принимать следующие значения:

date - сортировка комментариев по дате, например, тег {customcomments order="date" limit="5"} выведет пять последних комментариев.

rating - сортировка комментариев по рейтингу, например, тег {customcomments order="rating" limit="5"} выведет пять самых рейтинговых комментариев.

rand - сортировка комментариев в случайном порядке, например, тег {customcomments order="rand" limit="5"} выведет пять комментариев в случайном порядке.

sort - указывает порядок сортировки комментариев. При использовании значения desc публикации сортируются по убыванию, а при использовании asc по возрастанию.

cache - принимает значения yes или no и указывает кешировать вывод или нет, мы рекомендуем кешировать блоки данного вывода для снижения нагрузки на сервер.

Все параметры данного тега являются необязательными. Достаточно указать одного любого параметра. Вы также можете комбинировать различные параметры данного тега по своему усмотрению.

{* Закомментированный код *}

Данный тег предназначен для комментирования кода, все что заключено между "{*" и "*}" будет удалено из шаблона. И будет отсутствовать при выводе на сайте. Данные теги будут полезны разработчикам шаблонов, для отладки той или иной функциональности, когда нужно временно закомментировать ту или иную функциональность. Данный тег является глобальным и может использоваться во всех шаблонах.


Теги при написании новостей

Navigation: Работа с движком >

Теги при написании новостей

 Return to chapter overview

При написании новостей допустимо использование следующих тегов, если вы не используете WYSIWYG редактор:

[b] текст [/b] Выделяет текст жирным шрифтом

[i] текст [/i] Выделяет текст наклонным шрифтом

[s] текст [/s] Зачеркивает текст

[u] текст [/u] Подчеркивает текст

[sub] текст [/sub] - выводят текст в нижнем индексе

[sup] текст [/sup] - выводят текст в верхнем индексе

[code] текст [/code] отменяет использование форматирования текста заключенного в теги

[left] текст [/left] Выравнивает текст по левому краю

[center] текст [/center] Выравнивает текст по центру

[right] текст [/right] Выравнивает текст по правому краю

[justify] текст [/justify] - выравнивает текст по обеим сторонам и слева и справа

[url=ссылка] текст [/url] Вставка ссылки в новость

[leech=ссылка] текст [/leech] Полностью аналогичен тегу URL, за исключением того что производит шифрование ссылки

[email=ссылка] текст [/email] Вставка e-mail адреса в новость

[img] ссылка [/img] Вставка картинки новость

[img=выравнивание] ссылка [/img] Вставка картинки новость и выравнивание ее по указанному параметру

[img=выравнивание|свой текст для alt] ссылка [/img] Вставка картинки новость и выравнивание ее по указанному параметру, а также назначение картинке собственного описания

[color=цвет] текст [/color] Изменение цвета текста на указанный

[quote] текст [/quote] Цитата

[hide] текст [/hide] Скрывает текст от не зарегистрированного посетителя

{pagebreak} Разрыв страницы

[page=номер страницы] текст [/page] Вставка ссылки на указанный номер страницы внутри новости

[thumb] ссылка [/thumb] Вставка уменьшенной копии картинки новость, с ссылкой на увеличенную картинку

[thumb=выравнивание] ссылка [/thumb] Вставка уменьшенной копии картинки новость, с ссылкой на увеличенную картинку и выравнивание ее по указанному параметру

[thumb=выравнивание|свой текст для alt] ссылка [/thumb] Вставка уменьшенной копии картинки новость, с ссылкой на увеличенную картинку и выравнивание ее по указанному параметру, а также назначение картинке собственного описания

[video=http://test.ru/video.avi] Позволяет установить проигрывание видеофайла в новости

[videо=300x250,http://site.ru/video.mp4] Данный тег позволяет установить размеры видео для данного конкретного тега

[video=http://test.ru/video.avi|http://test.ru/sample.jpg] Позволяет установить проигрывание видеофайла в новости, а также картинку предосмотра для перед началом проигрывания.

[video=http://test.ru/video.avi|http://test.ru/sample.jpg|Описание для видео] Позволяет установить проигрывание видеофайла в новости, установить картинку предосмотра перед началом проигрывания, а также задать отдельное описание для видео, которое будет показано в проигрывателе.

[video=http://test.ru/video.mp4,http://test.ru/video2.mp4] Позволяет установить проигрывание двух видеофайлов в новости, для этого будет создан плейлист из двух видеофайлов. Им также могут быть заданы и картинка для превью и описание, так как указано выше.

[audio=http://test.ru/music.mp3] Позволяет установит проигрывание MP3 в новости

[audio=http://test.ru/music1.mp3,http://test.ru/music2.mp3] Позволяет установит проигрывание плейлиста из нескольких MP3 файлов в новости

[font=имя шрифта] текст [/font] Написание текста определенным шрифтом

[size=размер] текст [/size] Написание текста определенным размером шрифта

[spоiler] текст [/spoiler] Скрывает указанный в теге текст и показывает его при клике на него

[spоiler=Заголовок] текст [/spoiler] Выводит собственный заголовок по щелчку на который будет показан скрытый текст

[media=ссылка на страницу с видео] предназначен для публикации видео на сайте с таких видеохранилищ как youtube.com. В данном теге вы просто указываете URL страницы видеохранилища где размещено видео, скрипт автоматически распознает тип видеохранилища и вставит нужный HTML код для просмотра видео.

[media=300x250,http://....] Данный тег позволяет установить размеры видео для данного конкретного тега

[flash=ширина,высота] Путь к ролику [/flash] предназначенный для вставки флеш роликов в формате swf.

[list]

[*]пункт 1

[*]пункт 2

[/list] Вывод списка на сайте

[ol=1]

[*]пункт 1

[*]пункт 2

[/ol] Вывод пронумерованного списка на сайте

Небольшие пояснения к вставке кодов:

Например если вы хотите вставить картинку в текст то используйте тег [img]http://website/image.jpg[/img], если хотите ее выровнять по левому или по правому краю то используйте [img=left]http://website/image.jpg[/img], если же картинку нужно выровнять по центру то используйте следующее написание [center][img]http://website/image.jpg[/img][/center]. Аналогичный принцип действует и для тега [thumb]. Например, ваша статья содержит несколько страниц, и вы хотите на какой-либо странице помимо стандартной навигации между ними, зашитой в шаблоне, использовать свою ссылку на какую-либо страницу, то вставьте следующий код [page=3] для просмотра 3 страницы жми тут[/page] где 3 это номер страницы вашей новости.


Избранное / Фавориты

Navigation: Работа с движком >

Избранное / Фавориты

 Return to chapter overview

Возможности движка позволяют каждому зарегистрированному пользователю добавлять понравившуюся новость в свои закладки. Не путайте с закладками браузера. После авторизации на сайте каждый посетитель может добавить новость в закладки нажав на плюсик, после этого он может легко просмотреть новость или комментарии к ней, независимо от даты новости и не используя при этом поиск.


Персональные сообщения

Navigation: Работа с движком >

Персональные сообщения

 Return to chapter overview

Все авторизованные на сайте пользователи могут отправлять друг другу персональные сообщения. Данные сообщения в дальнейшем можно просматривать, удалять их, а также отвечать на них. Для этого используется определенный шаблон для их вывода. При редактировании этого шаблона будьте предельно внимательны. Чтобы не нарушить функциональность этого модуля. Для редактирования этого шаблона не требуется знание PHP, однако вы должны разбираться в HTML и его особенностях. Другими словами просто не изменяйте без особой надобности поля для ввода информации из форм.


ЧПУ и настройка

Navigation: Работа с движком >

ЧПУ и настройка

 Return to chapter overview

DataLife Engine использует в своей работе для вывода новостей ЧПУ (человеко-понятный URL), что позволяет тему статьи или любой другой текст добавить в URL браузера, благодаря этому индексация сайта в поисковых системах будет более качественной, что приведет больше посетителей на ваш сайт с поисковых систем. Для работы ЧПУ необходимо чтобы на вашем сервере был установлен модуль modrewrite. Если Ваш сервер не поддерживает этого, то вы можете отключить эту функцию. Для этого вам необходимо обязательно удалить с корневого каталога файл .htaccess и при установке скрипта отключить поддержку этой функции. Для более корректной работы ЧПУ мы рекомендуем устанавливать скрипт в корневую папку вашего сайта.

При включенном ЧПУ ссылки будут имеют следующий вид

Полная новость

С использованием ЧПУ зависит от типа ЧПУ установленного в настройках скрипта

http://website.com/index.php?newsid=1234543 - без использования ЧПУ

Добавление новостей на сайт вашими посетителями

http://website.com/addnews.html - с использованием ЧПУ

http://website.com/index.php?do=addnews - без использования ЧПУ

Профиль пользователя

http://website.com/user/имя пользователя/ - с использованием ЧПУ

http://website.com/index.php?subaction=userinfo&user= имя - без использования ЧПУ

Регистрация на сайте

http://website.com/index.php?do=register - без использования ЧПУ

Обзор непрочитанных сообщений

http://website.com/newposts/ - с использованием ЧПУ

http://website.com/index.php?subaction=newposts - без использования ЧПУ

Вывод всех новостей

http://website.com/lastnews/ - с использованием ЧПУ

http://website.com/index.php?do=lastnews - без использованиия ЧПУ

Вывод всех новостей указанной категории

http://website.com/альтернативное имя категории/ - с использованием ЧПУ

http://website.com/index.php?do=cat&category=альтернативное имя - без использования ЧПУ

Вывод всех новостей за 2005 год

http://website.com/2005/ - с использованием ЧПУ

http://website.com/index.php?year=2005 - без использованиия ЧПУ

Вывод всех новостей за указанный месяц

http://website.com/2005/12/ - с использованием ЧПУ

http://website.com/index.php?year=2005&month=04 - без использования ЧПУ

Вывод всех новостей за указанный день

http://website.com/2005/12/01/ - с использованием ЧПУ

http://website.com/ index.php?year=2005&month=04&day=30 - без использования ЧПУ

Обратная связь с администрацией сайта и другими участниками

http://website.com/index.php?do=feedback

Каталог сайта (сортировка по символьному коду)

http://website.com/catalog/a/ - с использованием ЧПУ

http://website.com/index.php?catalog=а - без использованиия ЧПУ

Вывод облака тегов

http://website.com/tags/ - с использованием ЧПУ

http://website.com/index.php?do=tags - без использованиия ЧПУ

Правила сайта

http://website.com/rules.html - с использованием ЧПУ

http://website.com/index.php?do=rules - без использованиия ЧПУ

Ссылки для вывода всех новостей указанной категории вы должны самостоятельно добавить в дизайн вашей страницы. Более подробно о создании категорий читайте ниже.


Поддержка Смартфонов

Navigation: Работа с движком >

Поддержка Смартфонов

 Return to chapter overview

Datalife Engine позволяет автоматически определять с использованием чего посетитель заходит на ваш сайт. И в случае если пользователь заходит на ваш сайт с мобильного аппарата, то DataLife Engine способен распознать это и подготовить для вывода специальную облегченную версию вашего сайта, с минимумом графики и использованного для передачи трафика.

Для включения данной возможности вам необходимо в Админпанели в настройках скрипта включить пункт: Включить автоматическую поддержку смартфонов, там же в настройках скрипта вы можете включить вывод в новостях картинок или отключить. Также можно принудительно включить отображение версии сайта для смартфонов, для этого нужно перейти по ссылке http://site.ru/index.php?action=mobile

Также в вашей папке шаблонов /templates/ должна находится папка с шаблоном smartphone именно этот шаблон используется для вывода сайта в случае если пользователь зашел на ваш сайт с использованием мобильного телефона. В данном шаблоне вы можете использовать все теже возможности что и в обычном шаблоне. Все теги и возможности полностью идентичны обычному шаблону. Но мы рекомендуем использовать самый минимум и не забывать о размерах экрана мобильного телефона. В архиве дистрибутива мы подготовили один такой стандартный шаблон с самым минимумом информации и размером. На него мы и рекомендуем опираться, при создании собственного шаблона.


Система жалоб на грамматические ошибки на сайте

Navigation: Работа с движком >

Система жалоб на грамматические ошибки на сайте

 Return to chapter overview

В скрипте DataLife Engine присутствует поддержка системы жалоб посетителями сайта, на допущенные грамматические или другие ошибки на сайте. Посетитель сайта, находясь на странице вашего сайта может выделить любой текст в браузере и нажать Ctrl+Enter и ему будет предложено отправить уведомление о грамматической ошибке в выделенном тексте. При этом пользователь может выделить любой текст на любой странице вашего сайта. Поэтому рекомендуем вам разместить какой либо блок-уведомление в какой либо видимой части вашего сайта, что у посетителей есть возможность отправлять уведомления администрации о грамматических ошибках на сайте. Управление жалобами на грамматические ошибки осуществляется в админпанели в разделе управления жалобами. Само уведомление отправляется с сайта с использованием технологии AJAX без перезагрузки страницы, и не доставляет неудобств пользователям.


Добавление новостей

Navigation: Работа с админпанелью >

Добавление новостей

 Return to chapter overview

Вход в админцентр осуществляется по адресу http://website.com/admin.php После авторизации вы сможете добавлять, редактировать и удалять новость, управлять пользователями и шаблонами, производить настройку скрипта, управлять картинками и многое другое.

При добавлении новости на сайт Вам необходимо задать заголовок статьи. Поле ЧПУ URL статьи является необязательным используется при включенных ЧПУ. Вы можете задать там свой текст, который будет в строке браузера, либо можете оставить его пустым, тогда текст будет сформирован из заголовка статьи, с учетом правил транслитации. Поле Дата задает дату новости, если отмечена галочка Текущая дата то будет автоматически вставлена текущая дата, с учетом коррекции времени, либо вы можете снять эту галочку, и ввести дату самостоятельно используя удобный календарь, нажав на значок рядом с полем. Если указать дату которая не наступила, то новость будет автоматически опубликована при наступлении указанной даты, при условии что новость допущена к публикации. Также вы можете выбрать категорию к которой принадлежит статья. После этого используя удобные кнопки для вставки тегов напишите вашу новость в кратком и полном описании, также если созданы дополнительные поля введите информацию и там. Внимание поле Полное описание не является обязательным, если оно пустое, то текст будет автоматически взят с Краткого описания. Используя ссылку [Загрузить картинку] вы сможете вставить в текст новости загруженные на сервер картинки либо загрузить непосредственно для этой статьи свою картинку. Также имеется возможность загрузки картинки непосредственно с другого сервера, минуя загрузку на собственный компьютер. Внимание если вы загружаете для этой статьи собственные картинки, то они будут автоматически удалены с сервера, при удалении новости.


Редактирование новостей

Navigation: Работа с админпанелью >

Редактирование новостей

 Return to chapter overview

Редактирование новостей идентично их добавлению за исключением поля Дата. Вы можете либо не изменять дату, для этого оставьте отмеченным Не изменять дату новости, либо снимите с него флажок и установите на Текущая дата и время, либо введите свою дату используя календарь.


Личные настройки

Navigation: Работа с админпанелью >

Личные настройки

 Return to chapter overview

В данном разделе вы сможете редактировать свой собственный профиль, изменить E-mail адрес, поменять дополнительные поля в виде полного имени, места жительства, установить новый пароль.


Настройка системы

Navigation: Работа с админпанелью >

Настройка системы

 Return to chapter overview

В данной разделе осуществляется общая настройка параметров системы, обратите внимание на то что настройка разбиты на разделы и для выбора раздела просто нажмите на соответствующую иконку. Пожалуй стоит остановиться на каждом пункте подробнее:

Название сайта – Введите название вашего сайта, например «Моя домашняя страница»

Домашняя страница сайта – Введите URL к главной странице, без указания имени файла, например http://website.com/ Обратите внимание на то что слеш на конце обязателен.

E-Mail адрес администратора – Адрес с которого будут отсылаться все письма с сервера для посетителей

Шаблон сайта по умолчанию – Выберите скин, который будет использоваться при отображении вашего сайта по умолчанию

Используемый язык – Выберите язык по умолчанию, который будет использоваться для вывода всех сообщений скрипта

Количество новостей на страницу – Укажите сколько новостей будет показываться при просмотре кратких статей

Включить WYSIWYG редактор при добавлении новостей с сайта - При добавлении новостей посетителями непосредственно с сайта возможно либо с использованием WYSIWYG редактора либо с использованием BBCODES Обратите внимание на то чтобы ваш шаблон был соответственно настроен

Включить WYSIWYG редактор в админпанели - Включает данный редактор в админпанели

Включить WYSIWYG редактор для комментариев и персональных сообщений - При добавлении комментариев посетителями непосредственно с сайта возможно либо с использованием WYSIWYG редактора либо с использованием BBCODES Обратите внимание на то чтобы ваш шаблон был соответственно настроен

Автоматическая разбивка длинных слов – Введите максимальное количество символов в одном слове, при превышение этого значение длинное слово будет автоматически переноситься на новую строчку, данная функция необходима чтобы длинные слова не

испортили общий дизайн сайта

Защита от флуда – Количество секунд в течении которых будет запрещено повторное написание комментария

Смайлики – Перечислите через запятую названия файлов со смайликами, которые будут использоваться при добавлении новостей или комментариев

Коррекция временных зон – Указывается в минутах, необходимо для синхронизации времени сервера со временем с учетом вашего часового пояса, допускаются также и отрицательные значения, если ваше время меньше времени сервера

Автоматическое уменьшение загруженной картинки – Указывается максимальная длина одной из сторон загружаемой картинки, если какая либо сторона по горизонтали или по вертикали превышает указанное значение, то картинка будет уменьшена до этого значения с сохранением пропорций.

Формат времени для новостей – указывается формат в котором будет выводится дата публикации новости

Включить gzip сжатие – Включает передачу контекста в сжатом виде, экономя при этом трафик

Скрывать ссылку на полую новость – скрывает ссылку на полную новость, если новость при этом отсутствует

Комментарии для зарегистрированных – Если установлено «Да» то комментарии смогут добавлять только зарегистрированные на сайте посетители

Разрешить редактирование комментариев – Если установлено «Да» то посетители смогут редактировать свои собственные комментарии, администратор может редактировать комментарии всегда

Разрешить удаление комментариев - Если установлено «Да» то посетители смогут удалять свои собственные комментарии

Формат времени для комментариев - указывается формат в котором будет выводится дата публикации комментария

Включить ЧПУ - Если установлено «Да» то будет включена поддержка ЧПУ

Разрешить фиксацию новостей - Если установлено «Да» то новости при добавлении можно будет фиксировать, фиксация новостей доступна только пользователю со статусом Администратор

Включить кеширование на сайте - Если установлено «Да» то будет включено кеширование страниц, при это теряется часть динамики сайта, до тех пор пока не обновиться кеш, однако включение данного параметра рекомендуется для сайтов с большой посещаемостью.

Включить голосование на сайте - Если установлено «Да» то будет включен модуль голосований на сайте

Включить счетчик просмотров новостей - Если установлено «Да» то будет включен счетчик показывающих сколько раз была просмотрена та или иная статья на сайте

Включить календарь - Если установлено «Да» то будет включен вывод календаря на странице, отключение календаря позволяет сэкономить один запрос к базе данных

Включить вывод архивов - Если установлено «Да» то будет выводиться архив по месяцам, отключение данной функции позволяет сэкономит один запрос к базе данных

Включить поддержку регистрации на сайте - Если установлено «Да» то будет разрешена регистрация посетителей на сайте, отключение данной функции позволяет сэкономить 2 запроса к базе данных, поэтому если вы считаете что регистрация на сайте вам не нужна то просто отключите эту функцию

Способ регистрации на сайте - Возможно два варианта, простой и расширенный при включении расширенного способа будет производиться проверка введенного E-Mail адреса. Пользователь будет должен активировать свой аккаунт при получении соответствующего письма

Разрешить смену скинов посетителями сайта – Если вы установили на сайт несколько шаблонов, то ваши посетители смогут их выбирать по своему усмотрению.

Максимальное количество зарегистрированных пользователей – Максимальное количество пользователей допустимых к регистрации, если указать 0, то регистрация будет осуществляться без ограничений

Автоматическое удаление зарегистрированных пользователей – количество дней через которое будет удален пользователь если он не посещал сайт, если указать 0, то ограничений не будет

Размер фотографии – Максимальный размер любой из сторон фотографии в профиле пользователя, при превышении данного параметра фотография будет автоматически изменена до указанного размера с сохранением пропорций.

Разрешить накладывание водяного знака – Если разрешить то на все загруженные картинки будет наложен водяной знак

Минимальный размер для накладывания водяного знака – Минимальный размер любой из сторон изображения, до которого водяной знак накладываться не будет

Разрешить пользователям загружать картинки - При добавлении новостей с сайта, вы можете своим посетителям разрешить или запретить загрузку картинок на сервер.

Максимально допустимый объём изображения - Если вы разрешили своим посетителям загрузку картинок на сервер, то вы можете ограничить максимальный объем картинки

Автоматическое удаление изображений - Если посетитель загрузил картинку, но не добавил ее в новость, она будет удалена через казанное количество дней.

Качество сжатия .jpg изображения - Качество сжатия JPEG картинки при копировании на сервер


Голосования

Navigation: Работа с админпанелью >

Голосования

 Return to chapter overview

В данном разделе вы можете создавать, редактировать и удалять опросы на сайте. Вы можете создавать опросы которые будут видны на всех страницах сайта, а также опросы которые будут видны только при просмотре определенных категорий.


Статические страницы

Navigation: Работа с админпанелью >

Статические страницы

 Return to chapter overview

Помимо написания динамически изменяемых новостей движок позволяет также написание статических страниц, частое изменение которых не планируется. Для того чтобы создать статическую страницу выберите "Создать новую страницу" после этого напишите название страницы, причем только латинскими буквами, потому что оно будет передаваться в URL сайта для просмотра, также введите описание страницы, это информация только для вас, и последнее создайте шаблон самой страницы, разрешено использование HTML. После создания страницы вы сможете ее просмотреть, изменить, либо удалить.

Адрес статической страницы с использование ЧПУ выглядит так: http://webseite.com/название страницы.html

Адрес статической страницы без ЧПУ выглядит так: http://webseite.com/index.php?do=static&page=название страницы


Группы пользователей

Navigation: Работа с админпанелью >

Группы пользователей

 Return to chapter overview

В данном разделе вы можете добавлять и редактировать новые и существующие группы пользователей. При добавлении новой группы пользователей вы выставляете ей доступные категории и права на сайте.

Доступные разделы: Разделы в которые имеет доступ выбранная группа

Доверительные разделы: В случае если разрешаете группе публиковать новости на сайте без предварительной модерации, либо разрешаете редактировать новости других пользователей, то в данном пункте вы указываете какие разделы вы доверяете группе. Редактирование новостей в неуказанных группах будет запрещено. Посетитель всегда может добавлять новости в доступные ему разделы, но если одна из категорий будет не в доверительном разделе то вся новость не будет опубликована без предварительной модерации. Категории в которые неразрешено добавлять новости без модерации выделяются красным цветом при добавлении.

Разрешить доступ в админпанель: данная опция разрешает пользователю доступ в админпанель, но не предоставляет доступа ко всем ее функциям. Разрешается доступ только для добавления или редактирования новостей из админпанели. Доступ ко всем функциям имеют только Администраторы.

Скрывать только полную новость из недоступных разделов: В случае если пользователю запрещен доступ в раздел вы можете выбрать, запретить ему полный доступ, либо запретить только просмотр полных новостей. В случае если вы запретите просмотр только полных новостей вы существенно сократите нагрузку на сервер и время выборки новостей.

Разрешить добавлять новости Вы можете запретить либо разрешить пользователям добавлять новости на сайт.

Публиковать новости без проверки: Разрешение на публикацию новостей в доверительные разделы без предварительной модерации

Разрешить фиксировать новости: Разрешение пользователям фиксировать новости на сайте

Редактирование собственных новостей: Разрешение пользователям редактировать собственные новости уже после опубликования на сайте

Редактирование всех новостей: Разрешение пользователям редактировать любые новости из доверительных разделов.

Разрешить добавление комментариев: Разрешение пользователям оставлять комментарии на сайте

Изменение своих комментариев: Разрешение пользователям редактировать собственные комментарии

Удаление своих комментариев: Разрешение пользователям удалять собственные комментарии

Изменение всех комментариев: Разрешение пользователям производить изменение любых комментариев

Удаление всех комментариев: Разрешение пользователям проводить удаление любых комментариев на сайте

Просмотр скрытого текста: Разрешение пользователям на просмотр содержимого тега [hide] [/hide]

Разрешить использование PM: Разрешение пользователям использование персональных сообщений на сайте.

Разрешить скачивание файлов: Разрешение пользователям скачивать загруженные на сервер файлы

Использование обратной связи: Разрешение пользователям использовать обратную связь на сайте

Использование поиска по сайту: Разрешение пользователям использовать поиск по сайту

Временное размещение в группе: Вы можете временно размещать пользователей в данной группе, при переносе пользователя в данную группу укажите до какого срока он будет размещен в данной группе, после окончания данного срока, пользователь будет автоматически перемещен в основную группу

Основная группа по окончании лимита: Укажите основную группу пользователя в которую он будет перемещен после окончания срока пребывания во временной группе.


Настройка категорий

Navigation: Работа с админпанелью >

Настройка категорий

 Return to chapter overview

В данном разделе вы можете создавать и редактировать категории. При создании новой категории вы указываете ее имя, альтернативное имя категории, путь для иконки категории, выбрать является ли новая категория подкатегорией и где. А также дополнительно вы можете указать какой шаблон будет использоваться при показе статей из данной категории, а также при просмотре этой категории. Иконка является необязательным параметром. Внимание: альтернативное имя задается только латинскими буквами и служит для вывода всех новостей данной категории. Например вы создаете категорию с именем «Софт», и альтернативным именем «soft», то для просмотра всех новостей из указанной новости при включенном ЧПУ в строке браузера необходимо набрать http://website.com/soft/, а при выключенном ЧПУ необходимо набрать http://website.com/?do=cat&category=soft


Дополнительные поля

Navigation: Работа с админпанелью >

Дополнительные поля

 Return to chapter overview

В данном разделе вы сможете создавать и редактировать дополнительные поля. Дополнительные поля, позволяют облегчать добавление информации на сайт, по умолчанию имеются только два поля, это краткое и полное описание новости. Однако вы можете создать и другие поля для ввода информации, например ссылку на источник или на программу, и настроив вывод поля всего один раз в шаблонах, отпадает необходимость постоянного форматирования часто повторяющегося ввода информации.

При добавлении нового поля вы вводите его название (латинскими буквами), описание поля (выводится рядом с полем ввода), категорию к которой принадлежит данное поле (вы можете выбрать, вводить ли данное поле для всех категорий или данное поле принадлежать только одной категории, вы можете назначать также выборочно, категории к которым будет принадлежать данное поле, для этого выберите нужные категории в списке удерживая кнопку Ctrl), тип поля (вы можете выбрать три типа поля, либо это одна строка, либо это какой то большой текст, либо это выпадающее меню со списком значений), также можете назначить значение поля по умолчанию. Если вы хотите чтобы поле являлось необязательным при вводе информации, поставьте соответствующую галочку, в противном случае новость не будет добавлена, если данное поле не введено.


Фильтр по IP, Логину или E-Mail

Navigation: Работа с админпанелью >

Фильтр по IP, Логину или E-Mail

 Return to chapter overview

Вы можете воспользоваться данным разделом, чтобы заблокировать определенные IP адреса, или заблокировать определенные электронные адреса, имена пользователей при регистрации. При вводе IP адреса, то доступ на сайт данному IP или подсети закрывается полностью, а не только для регистрации.

Примечание: вы можете воспользоваться в фильтре символом звездочки * для подстановки в имя пользователя, IP адрес или электронный адрес (например: 127.0.*.*, *@mail.ru, username*).


IP утилиты

Navigation: Работа с админпанелью >

IP утилиты

 Return to chapter overview

Данный модуль предназначен, для быстрого и удобного поиска и редактирования пользователей, использовавших для регистрации или авторизации указанный IP адрес. Допускается поиск как по полному IP адресу, так и по сокращенному. Также в данном модуле вы можете найти все IP адреса которые использовал определенный пользователь.


Управление рекламой

Navigation: Работа с админпанелью >

Управление рекламой

 Return to chapter overview

Данный модуль предназначен, для быстрого и удобного размещения и управления вашими рекламными материалами на сайте. Для того чтобы разместить на сайте ваш баннер, вам достаточно один раз добавить тег баннера в шаблон, после чего вы можете без проблем менять или редактировать код баннера в админпанели, не затрагивая при этом шаблоны.

После добавления своего баннера вы можете разместить его тег в шаблонах main.tpl или fullstory.tpl. Если вы добавляете баннер для показа между короткими новостями, то добавлять тег в шаблон ненужно, баннер будет добавлен между новостями автоматически.

Пример работы:

- Название: header
- Описание: Верхний баннер
- Включить показ баннера: Да
- Показывать только на главной: Нет
- Закрепить в расположении: Нет
- Расположение в коротких новостях: Нет

Если вы хотите чтобы данных баннер показывался только для определенных групп, то вы можете выбрать при добавлении баннера те группы пользователей, для которых необходимо показывать данный баннер. Также вы можете установить дополнительно время и дату начала показа баннера и время и дату окончания показа

После этого вы можете добавить в ваш шаблон в main.tpl или fullstory.tpl тег для вывода баннера: {banner_header}

Вы можете при добавлении кода баннера использовать HTML и JavaScript.


Анализ производительности

Navigation: Работа с админпанелью >

Анализ производительности

 Return to chapter overview

В данном разделе производится анализ всех настроек скрипта и настроек групп пользователей, и по результатам анализа выдаются рекомендации по изменению и отключению тех или иных возможностей скрипта. При этом результаты выводятся с подробными описаниями, почему нужно отключить ту или иную возможность, а также результаты выводятся в специальных графически выделенных блоках, определяющих степень нагрузки той или иной возможности. Рекомендации выделенным красным, необходимо выполнять в первую очередь, т.к. позволяют снизить существенно нагрузку на сервер. Рекомендации в желтом блоке указывают на среднюю степень нагрузки. Рекомендации, выделенные зеленым, способны лишь незначительно снизить нагрузку. Тем самым использование данного раздела рекомендуется в первую очередь, тем, кто испытывает проблемы с нагрузкой на сайт, на своем хостинге и хочет попытаться решить проблему "малой кровью", без смены тарифного плана на хостинге и перехода на более мощные ресурсы. Данный раздел будет полезен как новичкам, недавно пользующимся скриптом, так и более опытным пользователям.


Система Вопрос - Ответ

Navigation: Работа с админпанелью >

Система Вопрос - Ответ

 Return to chapter overview

В админпанели в специальном разделе администратором сайта задается список вопросов и варианты ответа на данные вопросы. При этом данная система может включаться отдельно для регистрации, добавления новостей, добавления комментариев. Для регистрации посетителей на сайте, система включается в настройках скрипта, а для добавления новостей и комментариев включается в настройках групп, и может включаться только для некоторых групп пользователей. Данная система вопроса-ответа является полностью автономной и независимой от каптчи на сайте и может использоваться как совместно с каптчей, так и отдельно. Для вывода системы вопроса и ответа используются шаблонные теги [question] и [/question], которые выводят текст заключенный в данные теги если система вопрос-ответ включена и тег {question} который выводит вопрос для посетителя.


Перекрестные ссылки

Navigation: Работа с админпанелью >

Перекрестные ссылки

 Return to chapter overview

Данный модуль предназначен, для быстрого и удобного создания перелинковки по сайту по ключевым словам.. В данном разделе вы задаете ключевое слово и URL, в случае нахождения данного ключевого слова на вашей странице, оно будет заменено на гипертекстовую ссылку. В отличии от модуля "фильтр слов", который также имеется в админпанели, в данном модуле ключевые слова ищется по всей странице, включая весь контент (новости, комментарии, шаблоны, сторонние модули и т.д.), а не только в новостях и комментариях. Также любое внесение или изменение ключевых слов в данном разделе, приводит к моментальному применению по всему сайту и всем страницам сайта, и не требуется никакого перестроения публикаций. Также в данном модуле поддерживается указание склонения слов, например вы можете задать ключевое слово "Иван(ов|ова|ову)" и ссылка будет применяться к словам: Иванов, Иванова, Иванову и т.д. Поиск ключевых слов осуществляется только по словам целиком, а не просто по всем вхождениям в тексте.


Система логов админпанели

Navigation: Работа с админпанелью >

Система логов админпанели

 Return to chapter overview

В данном разделе собираются все действия пользователей, осуществляемых в админпанели скрипта, за последние 30 дней, тем самым администратор сайта может всегда посмотреть, какие действия осуществлял тот или иной пользователь админпанели. Собираемые скриптом данные удалить в скрипте нельзя, они автоматически удаляются скриптом по истечении 30 дней, с момента их осуществления.


RSS информер

Navigation: Работа с админпанелью >

RSS информер

 Return to chapter overview

Данный модуль предназначен для публикации новостей ваших партнеров с других сайтов в определенном блоке на вашем сайте. Зайдя в админпанель для добавления нового информера вы задаете ему следующие параметры:

Название RSS информера - в данном поле вы указываете имя для информера имя может быть уникальным а может быть таким же как и у других информеров. В случае если имя одинаковое то информеры показываются в режиме ротации.

Описание RSS информера - краткое описание предназначенное для вас этого информера

Категория - вы можете указать категорию в которой показывать этот информер, либо сделать доступным показ во всех категориях

URL для RSS информера - здесь вы указываете путь к RSS источнику из которого будут братся новости

Шаблон для информера - укажите шаблон который будет подгружатся для показа отформатированной информации в этом блоке. Например informer.tpl

Количество новостей в блоке - укажите количество новостей которые должны показываться в данном блоке

Количество символов в заголовке - укажите максимальное количество символов в заголовке, при превышении данного лимита заголовок будет автоматически обрезаться. Вы можете установить значение 0, тогда заголовок будет импортироватся целиком

Количество символов в тексте новости- укажите максимальное количество символов в новости, при превышении данного лимита новость будет автоматически обрезаться. Вы можете установить значение 0, тогда новость будет импортироватся целиком


Используемые классы CSS

Navigation: Шаблоны >

Используемые классы CSS

 Return to chapter overview

DataLife Engine использует следующие классы CSS:

.calendar - Вывод таблицы календаря

.monthlink - Ссылка перехода по месяцам в календаре

.day-active-v - Класс для рабочих дней если новости есть

.day-active - Субботние и воскресные дни в которых есть новости
.day - Класс для рабочих дней если новостей нет
.weekday - Субботний и воскресный дни в которых нет новостей

.day-current - Текущая дата, или если посетитель просматривает новости за данный день

.archives - Вывод списка архивов

.xfields - Ввод дополнительный полей в добавлении новости

.rating - Вывод рейтинга

.quote - Используется для вывода цитаты или информации о скрытом тексте

.scriptcode - Используется для вывода информации, заключенной в тег [CODE]

.pm - Таблица при выводе списка полученных приватных сообщений

.pm_head - Заголовок таблицы

.pm_list - Список самих сообщений

.pm_progress_bar - Шкала заполненности ящика персональных сообщений

#dropmenudiv - Выпадающее меню при использовании быстрого или полного редактирования

#newpm, #newpmheader - Для настройки уведомления о получении нового персонального сообщения

.editor_button,

.editor_buttoncl,

.editbclose, .editor_button_brk - Стили для настройки кнопок BB редактора при быстром редактировании новостей на сайте.

.editor - общий стиль для BB редактора.

.clouds_xsmall, .clouds_small, .clouds_medium, .clouds_large, .clouds_xlarge - Для настройки размеров различных ключевых слов в облаке тегов, в зависимости от их популярности

.highslide-active-anchor, .highslide-image-blur, .highslide-html-content, .highslide-loading, a.highslide-full-expand, .highslide-display-block, .highslide-display-none - Для настройки показа всплывающего окна с оригинальным изображением из уменьшенной копии

.highslide-dimming - Используется для задания затемняющего фона при включении режима "Галереи" для показа загруженных изображений.

#loading-layer - оформление информационного окна о выполнении AJAX действия.

#searchsuggestions - оформление быстрого поиска на сайте.

.mass_comments_action - оформление меню выбора действия над комментариями на сайте.

Не забудьте использовать данные стили в вашем главном шаблоне.


Общая информация

Navigation: Шаблоны >

Общая информация

 Return to chapter overview

DataLife Engine позволяет использовать шаблонную систему для вывода новостей, а также для вывода различных модулей. Мы попытались максимально упростить использование шаблонов в движке, для того чтобы их использовать вам не надо обладать никакими знаниями языков программирования, только язык верстки HTML. Однако для более полного и легкого использования шаблонов мы рекомендуем вам внимательно прочитать руководство по работе с шаблонами, чтобы выяснить какие теги используются в шаблонах и для чего они предназначены.

Шаблоном в DLE является папка которая находится в свою очередь в папке /temlates/. Файлы находящиеся в папке шаблона, являются файлами одного шаблона.

Также вы можете подключать один файл шаблона в другой, используя тег {include file="my_block.tpl"} данный тег подключает указанный файл my_block.tpl в шаблон. Тег призван облегчить структуру шаблона, если используется сложная верстка со множеством тегов. Данный тег действует во всех шаблонных файлах .tpl Подключаемый файл должен находится в папке вашего шаблона или его вложенных папках, если вы хотите подключить файл шаблона, находящийся в другом шаблоне, необходимо использовать полный путь от корня где установлен скрипт, например, {include file="/templates/mytemplate/my_block.tpl"}.

Теги в подключаемом шаблоне должны быть такие же, какие допустимы в шаблоне где подключается файл, например если файл my_block.tpl подключается в шаблоне main.tpl, то и теги в этом файлы будут работать только те которые возможны в main.tpl


Главная страница сайта

Navigation: Шаблоны >

Главная страница сайта

 Return to chapter overview

Вывод данного раздела настраивается в файле main.tpl В этом разделе настраиваются шаблоны вашей главной и основной страницы, куда подключаются другие компоненты движка. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно.

{headers} | Выводит сгенерированные метатеги о кодировке страницы, title, keywords, description. А также подключает все необходимые скрипты. Размещаеться в шаблоне между тегами <head>. Данный тег обязателен в шаблоне.
{jsfiles} | Выводит подключение всех JS скриптов, которые использует DLE в указанном месте шаблона. При помощи данного тега вы можете, например, перенести все JS скрипты в самый низ страницы, для ускорения загрузки и рендеринга ваших страниц. Данный тег является необязательным, и в случае его отсутствия в шаблоне, все скрипты будут подключены, как и ранее к тегу {headers}. Внимание, если вы переносите подключение скриптов, то должны иметь ввиду, что тег {AJAX} также должен находится ниже тега {jsfiles}, а также вы должны предусмотреть работу всех своих сторонних скриптов в шаблоне, если они используют, например, библиотеку Jquery, чтобы они не запускались раньше, чем выполнится подключение всех скриптов. Мы настоятельно не рекомендуем новичкам пользоваться данным тегом, он предназначен для опытных вебмастеров, которые имеют опыт в работе с JS скриптами.
{THEME} | Путь к выбранному шаблону
{login} | Вставка панели для входа и регистрации посетителей
{vote} | Вставка опроса на сайте
{changeskin} | Вставка формы для смены скинов на сайте
{calendar} | Вставка модуля календаря
{topnews} | Вывод самых рейтинговых статей, добавленных за последний месяц
{archives} | Вывод архивов
{info} | выводит служебную информацию движка, в случае если возникла необходимость. Присутствие тега обязательно в шаблоне.
{content} | Вывод непосредственно самого контекста на сайте, новостей, обратной связи регистрации и прочего, в общем основная колонка. Присутствие тега практически обязательно в шаблоне, за исключением крайне редких случаев, в зависимости от необходимых возможностей самого сайта.
{custom} | Смотрите раздел "Вывод новостей на страницах"
[aviable=раздел]текст[/aviable] | Смотрите раздел "Вывод новостей на страницах"
{AJAX} | Подключает все необходимы скрипты для работы DLE и AJAX, подключение обязательно, и рекомендуется размещение в начале страницы, сразу после тега <body>. Данный тег обязателен в шаблоне.
[group=X]текст[/group] | Вывод текста определенной группе пользователей. Где X это список ID через запятую группы пользователей.
[category=X]текст[/category] | Предназначен для вывода текста если пользователь находится в X категории. Где X это ID вашей категории. Допустимо перечислять категории через запятую
{banner_имя} | Этот тег предназначен для вывода рекламной информации на сайте. Само имя для баннера задается в специальном модуле в админпанели.
{inform_имя} | Этот тег предназначен для вывода RSS информеров и новостей с других сайтов. Имя и все настройки для данного тега устанавливаются в админпанели скрипта.
[not-category=X]текст[/not-category] | Предназначен для вывода текста если пользователь находится везде, кроме как в X категории. Где X это ID вашей категории. Допустимо перечислять категории через запятую
[not-group=X]текст[/not-group] | Вывод текста любой группе пользователей, кроме указанной. Где X это список ID через запятую группы пользователей для которых непоказывать информацию.
[page-count=1,2,3] текст [/page-count] | Выводит текст заключенный в них, если пользователь находится на определенной по номеру страницы в навигации по новостям, независимо от раздела сайта, где 1,2,3 это номера страниц в навигации.
[not-page-count=1,2,3] текст [/not-page-count] | Выводит текст опубликованный в тегах на любых номерах страниц кроме указанных в теге.
[news=1,2,3] текст [/news] | Выводят заключенный в них текст, если посетитель просматривает полную новость указанных в параметре тега новостей, где 1,2,3 это ID новостей.
[not-news=1,2,3] текст [/not-news] | Выводит текст на любых других страницах кроме просмотра указанных в теге новостей.
[tags=тег1,тег2,тег3] текст [/tags] | Выводят заключенный в них текст если посетитель просматривает страницы с перечисленными ключевыми словами из облака тегов, где тег1,тег2,тег3 это ключевые слова из облака тегов.
[not-tags=тег1,тег2,тег3] текст [/not-tags] | Выводит текст на любых других страницах кроме указанных в теге.
[related-news] {related-news} [/related-news] | Выводят блок похожих новостей при просмотре полной новости.
[vk] текст [/vk] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте
{vk_url} | Выводит ссылку URL на авторизацию в соц. сети Вконтакте
[odnoklassniki] текст [/odnoklassniki] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники
{odnoklassniki_url} | Выводит ссылку URL на авторизацию в соц. сети Одноклассники
[facebook] текст [/facebook] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook
{facebook_url} | Выводит ссылку URL на авторизацию в соц. сети Facebook
[google] текст [/google] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google
{google_url} | Выводит ссылку URL на авторизацию в соц. сети Google
[mailru] текст [/mailru] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru
{mailru_url} | Выводит ссылку URL на авторизацию в соц. сети Mail.ru
[yandex] текст [/yandex] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex
{yandex_url} | Выводит ссылку URL на авторизацию в соц. сети Yandex
[xfvalue_X] | Выводит значение дополнительного поля "x", где "x" название дополнительного поля
[xfgiven_X] текст [/xfgiven_X] | Выводится дополнительное поле "x", если поле не пустое, если поле не имеет значения, то текст просто вырезается
[xfnotgiven_X] текст [/xfnotgiven_X] | Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля
[ifxfvalue tagname="tagvalue"] Текст [/ifxfvalue] | Выводят текст заключенный в них, если значение дополнительного поля совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение.
[ifxfvalue tagname!="tagvalue"] Текст [/ifxfvalue] | Выводят текст заключенный в них, если значение поля не совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение.


Панель авторизации на сайте

Navigation: Шаблоны >

Панель авторизации на сайте

 Return to chapter overview

Вывод данного раздела настраивается в файле login.tpl В данном разделе настраивается вывод панели авторизации посетителя на сайте. Возможно использование следующих тегов:

{registration-link} | Ссылка на страницу регистрации посетителя
{lostpassword-link} | Ссылка на страницу восстановления пароля
{logout-link} | Ссылка на разлогинивание пользователя на сайте
{admin-link} | Ссылка на админпанель скрипта
{pm-link} | Ссылка на страницу персональных сообщений
{new-pm} | Количество новых персональных сообщений
{all-pm} | Общее количество персональных сообщений
{favorite-count} | Количество новостей, добавленных пользователем себе в закладки на сайте
{foto} | Ссылка на аватар пользователя.
[admin-link] и [/admin-link] | Выводит текст в тегах, если пользователь имеет доступ к админпанели скрипта
{profile-link} | Ссылка на профиль пользователя
{stats-link} | Ссылка на статистику на сайте
{addnews-link} | Ссылка на страницу добавления новости на сайте
{favorites-link} | Ссылка на просмотр закладок пользователя
{newposts-link} | Ссылка на просмотр непрочитанных новостей пользователем с последнего посещения им сайта
{group-icon} | Выводит иконку группы пользователя
{login-method} | В зависимости от установленного в настройках скрипта типа авторизации, вывод что необходимо вводить пользователю: логин или E-mail
[vk] текст [/vk] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте
{vk_url} | Выводит ссылку URL на авторизацию в соц. сети Вконтакте
[odnoklassniki] текст [/odnoklassniki] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники
{odnoklassniki_url} | Выводит ссылку URL на авторизацию в соц. сети Одноклассники
[facebook] текст [/facebook] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook
{facebook_url} | Выводит ссылку URL на авторизацию в соц. сети Facebook
[google] текст [/google] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google
{google_url} | Выводит ссылку URL на авторизацию в соц. сети Google
[mailru] текст [/mailru] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru
{mailru_url} | Выводит ссылку URL на авторизацию в соц. сети Mail.ru
[yandex] текст [/yandex] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex
{yandex_url} | Выводит ссылку URL на авторизацию в соц. сети Yandex
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | Выводится дополнительное поле "x", если поле не пустое
[xfnotgiven_x] текст [/xfnotgiven_x] | Выводится текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя
[xfvalue_x] | Выводится значение дополнительного поля "x", где "x" название дополнительного поля
{group} | Выводит название группы пользователя сайта в которой он находится в данный момент


Краткое содержание

Navigation: Шаблоны >

Краткое содержание

 Return to chapter overview

Вывод кратких новостей настраивается в файле shortstory.tpl и возможно использование следующих тегов:

{title} | Выводится заголовок статьи
{title limit="x"} | Выводится урезанный до X количества символов, заголовок новости.
{news-id} | ID номер новости, это номер под которым данная новость храниться в базе данных
{short-story} | Выводится краткая новость
{short-story limit="x"} | Выводит только текст краткой новости без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов.
{author} | Автор статьи
{date} | Дата публикации, формат вывода даты настраивается в настройках системы
{rating} | Отображение рейтинга новости
[rating] текст [/rating] | Выводят заключенный в них текст, только если рейтинг для новости включен и убирают содержимое, если он был отключен при добавлении новости.
[rating-type-1] текст [/rating-type-1] | Выводят текст, заключенный в них, если в настройках скрипта включено использование первого типа рейтинга 'Оценка'.
[rating-type-2] текст [/rating-type-2] | Выводят текст, заключенный в них, если в настройках скрипта включено использование второго типа рейтинга 'Только Нравится'.
[rating-type-3] текст [/rating-type-3] | Выводят текст, заключенный в них, если в настройках скрипта включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.
[rating-minus] текст [/rating-minus] | Выводят текст, заключенных в них, в виде ссылки для уменьшения рейтинга публикации, выводится данная ссылка только если используется третий тип рейтинга.
[rating-plus] текст [/rating-plus] | Выводят текст, заключенных в них, в виде ссылки для увеличения рейтинга публикации, выводится данная ссылка только если используется второй и третий тип рейтинга.
{vote-num} | Выводит количество пользователей, выставивших рейтинг для данной новости
{comments-num} | Отображает количество комментариев , написанных к статье
{category} | Категория, к которой относится статья
{category-icon} | ссылка на иконку категории, внимание выводится именно путь к картинке, сам вывод вы должны предусмотреть самостоятельно например <img src="{category-icon}" />
{views} | Количество просмотров новости
{favorites} | Ссылка на добавление или удаление из Избранного
[add-favorites] текст [/add-favorites] | Выводят текст в них в виде ссылки на добавление новость в закладки на сайте
[del-favorites] текст [/del-favorites] | Выводят текст в них в виде ссылки удаление новости из закладок на сайте
[edit] текст [/edit] | Ссылка редактирование новости
{link-category} | Ссылка на все категории в которой присутствует новость
[full-link] и [/full-link] | Ссылка на полную версию, например [full-link]Подробнее…[/full-link]
[com-link] и [/com-link] | Ссылка на комментарии к статье, выводится только если они разрешены
[xfvalue_x] | Значение дополнительного поля "x", где "x" название дополнительного поля
[xfvalue_X limit="X2"] | Выводит только текст дополнительного поля без HTML форматирования, при этом сам текст сокращается до указанного X2 количества символов. При этом сокращение текста происходит до последнего логического слова. Например [xfvalue_test limit="50"] выведет только первые 50 символов значения дополнительного поля c именем test
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | Выводится дополнительное поле "x", если поле не пустое, если поле не имеет значения, то текст просто вырезается
[xfnotgiven_X] [/xfnotgiven_X] | Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля
[ifxfvalue tagname="tagvalue"] Текст [/ifxfvalue] | Выводят текст заключенный в них, если значение дополнительного поля совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение.
[ifxfvalue tagname!="tagvalue"] Текст [/ifxfvalue] | Выводят текст заключенный в них, если значение поля не совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение.
[xfvalue_thumb_url_X] | Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только URL для уменьшенной копии загруженного изображения, где "х" это имя дополнительного поля
[xfvalue_image_url_X] | Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только URL для полноразмерной картинки загруженного изображения, где "х" это имя дополнительного поля
[group=X]текст[/group] | Вывод текста определенной группе пользователей. Где X это список ID через запятую группы пользователей.
[category=X]текст[/category] | Предназначен для вывода текста если пользователь находится в X категории. Где X это ID вашей категории. Допустимо перечислять категории через запятую
[tags] текст [/tags] | Выводит текст если новость содержит ключевые слова, назначенные для облака тегов
{tags} | Выводит кликабельные ключевые слова новости
{full-link} | Для вывода полного постоянного адреса новости
[edit-date] текст [/edit-date] | Выводит текст если новость была отредактирована
{edit-date} | Выводит дату редактирования новости
{editor} | Выводит логин пользователя, отредактировавшего новость
[edit-reason] текст [/edit-reason] | Выводит текст если при редактировании была указана причина редактирования
{edit-reason} | Выводит причину редактирования новости
{date=формат даты} | Выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время
{approve} | Выводится только при просмотре пользователем собственного профиля и показывает статус его новостей ожидающих модерации
[fixed] текст [/fixed] | Выводит текст в тегах если данная новость зафиксирована
[not-fixed] текст [/not-fixed] | Выводит текст в тегах если данная новость не была зафиксирована
[day-news] текст [/day-news] | Выводит ссылку на все новости, опубликованные в тот же день что и данная новость. Данный тег например можно использовать совместно с тегом {date}
[catlist=1,2....] текст [/catlist] | Выводит текст в теге, если новость принадлежит указанным категориям
[not-catlist=1,2....] текст [/not-catlist] | Выводит текст в теге, если новость не принадлежит указанным категориям.
{login} | Выводит логин пользователя добавившего новость в виде обычной текстовой информации без ссылок на профиль и карточку пользователя.
[poll] текст [/poll] | Выводят текст в данных тегах, если для данной публикации задан опрос.
{poll} | Выводит опрос, добавленный к новости
[not-poll] текст [/not-poll] | Выводят текст в данных тегах, если для данной публикации не был задан опрос.
[profile] текст [/profile] | Выводят прямую ссылку на профиль автора публикации, без использования всплывающего окна минипрофиля.
[complaint] текст [/complaint] | Выводят текст, указанных в тегах в виде ссылки на написание жалобы, на новость.
{category-url} | Выводит полный URL на категорию, которой принадлежит данная новость. Данный тег выводит только URL в чистом виде без форматирования или готовой ссылки.
[comments] текст [/comments] | Выводят текст, заключенный в них, если у данной публикации присутствуют комментарии на сайте.
[not-comments] текст [/not-comments] | Выводят текст, заключенный в них, если у данной публикации отсутствуют комментарии на сайте.
{image-x} | Выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости
[image-x] текст [/image-x] | Выводят текст указанный в них только в случае если картинка с номером X присутствует в новости
[tags=тег1,тег2,тег3] текст [/tags] | Выводят заключенный в них текст если посетитель просматривает страницы с перечисленными ключевыми словами из облака тегов, где тег1,тег2,тег3 это ключевые слова из облака тегов.
[not-tags=тег1,тег2,тег3] текст [/not-tags] | Выводит текст на любых других страницах кроме указанных в теге.
[declination=X] текст [/declination] | Выводит склонения слов относительно чисел. В качестве параметров тега вместо X передается число, а вместо "текст" передается корень слова с окончаниями. Окончания слова перечисляются при помощи символа "|". Данный тег полезно использовать с другими тегами, выводящими например количество просмотров новости или количество комментариев. Например [declination={comments-num}]комментари|й|я|ев[/declination] в зависимости от количества комментариев будет выводить: "комментарий", "комментария", "комментариев"
[newscount=x] текст [/newscount] | Выводит текст указанный в тегах если показывается X новость, где X это число показываемой на странице новости. Например [newscount=1] текст [/newscount] покажет текст при показе первой по счету на странице новости.
[not-newscount=X] текст [/not-newscount] | Выводят текст заключенный в данные теги при показе любых по счету новостей, кроме указанных X новостей. Данный тег будет полезен, если вы хотите выводить какие-либо элементы оформления во всех новостях при показе кратких новостей, кроме вышеуказанных. Например, что-либо не показывать в первой по списку новости.
{banner_x} | Выводит баннер добавленный в админпанели в разделе управления рекламными материалами. Где Х это имя баннера.


Статья целиком

Navigation: Шаблоны >

Статья целиком

 Return to chapter overview

Вывод статьи целиком настраивается в файле fullstory.tpl и возможно использование следующих тегов:

{title} | Заголовок статьи
{title limit="x"} | Выводится урезанный до X количества символов, заголовок новости.
{full-story} | Полная версия
{short-story} | Краткая версия новости
{full-story limit="x"} | Выводит только текст полной новости без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов
{author} | Автор статьи
{date} | Дата публикации
{pages} | Навигация по страницам новости
[pages] текст [/pages] | Выводят указанный текст в тегах, если новость разбита на несколько страниц при помощи тега {PАGEBREAK} и убирает текст в нем, если новость состоит из одной страницы.
{link-category} | Ссылка на все категрии в которой присутствует новость
{rating} | Выводится рейтинг публикации
[rating] текст [/rating] | Выводят заключенный в них текст, только если рейтинг для новости включен и убирают содержимое, если он был отключен при добавлении новости.
[rating-type-1] текст [/rating-type-1] | Выводят текст, заключенный в них, если в настройках скрипта включено использование первого типа рейтинга 'Оценка'.
[rating-type-2] текст [/rating-type-2] | Выводят текст, заключенный в них, если в настройках скрипта включено использование второго типа рейтинга 'Только Нравится'.
[rating-type-3] текст [/rating-type-3] | Выводят текст, заключенный в них, если в настройках скрипта включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.
[rating-minus] текст [/rating-minus] | Выводят текст, заключенных в них, в виде ссылки для уменьшения рейтинга публикации, выводится данная ссылка только если используется третий тип рейтинга.
[rating-plus] текст [/rating-plus] | Выводят текст, заключенных в них, в виде ссылки для увеличения рейтинга публикации, выводится данная ссылка только если используется второй и третий тип рейтинга.
{vote-num} | Выводит количество пользователей, выставивших рейтинг для данной новости
{comments-num} | Позволяет отображать количество комментариев к статье
{category} | Категория, к которой относится статья
{category-url} | Выводит полный URL на категорию, которой принадлежит данная новость. Данный тег выводит только URL в чистом виде без форматирования или готовой ссылки.
{category-icon} | Ссылка на иконку категории
{views} | Количество просмотров новости
{favorites} | Ссылка на добавление или удаление из Избранного
[add-favorites] текст [/add-favorites] | Выводят текст в них в виде ссылки на добавление новость в закладки на сайте
[del-favorites] текст [/del-favorites] | Выводят текст в них в виде ссылки удаление новости из закладок на сайте
[edit] текст [/edit] | Ссылка на редактирование новости
[print-link] и [/print-link] | Ссылка на версию для печати
[com-link] и [/com-link] | Ссылка на комментарии к статье только если они разрешены
[xfvalue_x] | Значение дополнительного поля "x", где "x" название дополнительного поля
[xfvalue_X limit="X2"] | Выводит только текст дополнительного поля без HTML форматирования, при этом сам текст сокращается до указанного X2 количества символов. При этом сокращение текста происходит до последнего логического слова. Например [xfvalue_test limit="50"] выведет только первые 50 символов значения дополнительного поля c именем test
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | Выводится дополнительное поле "x", если поле не пустое
[xfnotgiven_X] [/xfnotgiven_X] | Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля
[ifxfvalue tagname="tagvalue"] Текст [/ifxfvalue] | Выводят текст заключенный в них, если значение дополнительного поля совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение.
[ifxfvalue tagname!="tagvalue"] Текст [/ifxfvalue] | Выводят текст заключенный в них, если значение поля не совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение.
[xfvalue_thumb_url_X] | Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только URL для уменьшенной копии загруженного изображения, где "х" это имя дополнительного поля
[xfvalue_image_url_X] | Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только URL для полноразмерной картинки загруженного изображения, где "х" это имя дополнительного поля
[group=X]текст[/group] | Вывод текста определенной группе пользователей. Где X это список ID через запятую группы пользователей.
{related-news} | Выводить ссылки на 5 наиболее подходящих по контексту новостей.
[catlist=1,2....] текст [/catlist] | Выводит текст в теге, если новость принадлежит указанным категориям
[not-catlist=1,2....] текст [/not-catlist] | Выводит текст в теге, если новость не принадлежит указанным категориям.
[tags] текст [/tags] | Выводит текст если новость содержит ключевые слова, назначенные для облака тегов
{tags} | Выводит кликабельные ключевые слова новости
{full-link} | Для вывода полного постоянного адреса новости
[edit-date] текст [/edit-date] | Выводит текст если новость была отредактирована
{edit-date} | Выводит дату редактирования новости
{editor} | Выводит логин пользователя, отредактировавшего новость
[edit-reason] текст [/edit-reason] | Выводит текст если при редактировании была указана причина редактирования
{edit-reason} | Выводит причину редактирования новости
{poll} | Подключает шаблон с опросом для новости, если опрос был добавлен к новости.
{date=формат даты} | выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время
[fixed] текст [/fixed] | Выводит текст в тегах если данная новость зафиксирована
[not-fixed] текст [/not-fixed] | Выводит текст в тегах если данная новость не была зафиксирована
[day-news] текст [/day-news] | Выводит ссылку на все новости, опубликованные в тот же день что и данная новость. Данный тег например можно использовать совместно с тегом {date}
{comments} | Выводит комментарии, написанные к данной новости. Данный тег будет полезен тем, кому необходимо разместить комментарии, например общем дизайне полной новости. Данный тег не является обязательным, в случае его отсутствия комментарии будут автоматически расположены скриптом ниже полной новости
{addcomments} | Выводит форму добавления комментариев на сайт, совместно с новым тегом {comments} вы можете размещать форму добавления комментариев как выше, так и ниже самих комментариев. Данный тег также не является обязательным, в случае его отсутствия форма будет автоматически расположена скриптом ниже полной новости
{navigation} | Выводит навигацию по комментариям, если комментарии расположены на нескольких страницах, совместно с новым тегом {comments} вы можете располагать навигацию по комментариям как выше, так и ниже самих комментариев. Данный тег также не является обязательным, в случае его отсутствия навигация будет автоматически расположена скриптом ниже полной новости
{login} | Выводит логин пользователя добавившего новость в виде обычной текстовой информации без ссылок на профиль и карточку пользователя.
[related-news] текст [/related-news] | Выводят информацию, заключенную в тегах, только если для данной новости присутствуют похожие новости, в противном случае информация удаляется из шаблона.
[poll] текст [/poll] | Выводят текст в данных тегах, если для данной публикации задан опрос.
[not-poll] текст [/not-poll] | Выводят текст в данных тегах, если для данной публикации не был задан опрос.
[profile] текст [/profile] | Выводят прямую ссылку на профиль автора публикации, без использования всплывающего окна минипрофиля.
[complaint] текст [/complaint] | Выводят текст, указанных в тегах в виде ссылки на написание жалобы, на новость.
{custom} | Смотрите раздел "Вывод новостей на страницах"
[comments] текст [/comments] | Выводят текст, заключенный в них, если у данной публикации присутствуют комментарии на сайте.
[not-comments] текст [/not-comments] | Выводят текст, заключенный в них, если у данной публикации отсутствуют комментарии на сайте
{image-x} | Выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости
[image-x] текст [/image-x] | Выводят текст указанный в них только в случае если картинка с номером X присутствует в новости
{fullimage-x} | Выводит URL картинки, находящийся в тексте полной новости, где "x" это номер картинки в новости
[fullimage-x] текст [/fullimage-x] | Выводят указанный в них текст, только если картинка с номером "x" присутствует в полной новости.
[news=1,2,3] текст [/news] | Выводят заключенный в них текст, если посетитель просматривает полную новость указанных в параметре тега новостей, где 1,2,3 это ID новостей.
[not-news=1,2,3] текст [/not-news] | Выводит текст на любых других страницах кроме просмотра указанных в теге новостей.
[declination=X] текст [/declination] | Выводит склонения слов относительно чисел. В качестве параметров тега вместо X передается число, а вместо "текст" передается корень слова с окончаниями. Окончания слова перечисляются при помощи символа "|". Данный тег полезно использовать с другими тегами, выводящими например количество просмотров новости или количество комментариев. Например [declination={comments-num}]комментари|й|я|ев[/declination] в зависимости от количества комментариев будет выводить: "комментарий", "комментария", "комментариев"
{banner_x} | Выводит баннер добавленный в админпанели в разделе управления рекламными материалами. Где Х это имя баннера.
[vk] текст [/vk] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте
{vk_url} | Выводит ссылку URL на авторизацию в соц. сети Вконтакте
[odnoklassniki] текст [/odnoklassniki] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники
{odnoklassniki_url} | Выводит ссылку URL на авторизацию в соц. сети Одноклассники
[facebook] текст [/facebook] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook
{facebook_url} | Выводит ссылку URL на авторизацию в соц. сети Facebook
[google] текст [/google] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google
{google_url} | Выводит ссылку URL на авторизацию в соц. сети Google
[mailru] текст [/mailru] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru
{mailru_url} | Выводит ссылку URL на авторизацию в соц. сети Mail.ru
[yandex] текст [/yandex] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex
{yandex_url} | Выводит ссылку URL на авторизацию в соц. сети Yandex


Скачивание файлов

Navigation: Шаблоны >

Скачивание файлов

 Return to chapter overview

Настройка вывода файлов для скачивания, загруженных через скрипт. Файл шаблона attachment.tpl. Допускается использование следующих тегов:

[allow-download] текст [/allow-download] | Выводят текст заключенных в них, если для пользователя сайта разрешено скачивание загруженных файлов
[not-allow-download] текст [/not-allow-download] | Выводят текст заключенных в них, если для пользователя сайта запрещено скачивание загруженных файлов.
[count] текст [/count] | Выводят текст заключенных в них, если в настройках скрипта включена поддержка счетчика скачиваний файла с сервера
{id} | Выводит уникальный ID номер загруженного файла, информация о котором хранится в базе данных
{name} | Выводит имя загруженного файла, либо текст указанный для имени файла в теге [аttachment=...] в тексте новости
{extension} | Выводит расширение загруженного к новости файла
{link} | Выводит URL на скачивание загруженного файла
{size} | Выводит размер загруженного файла
{md5} | Выводит контрольную сумму MD5 загруженного файла
{date} | Выводит дату загрузки файла на сервер, в формате даты, указанной в настройках скрипта
{date=формат даты} | Выводит дату в заданном в теге формате. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца загрузки файла, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время
{count} | Выводит количество скачиваний файла с сервера
{online-view-link} | Выводит ссылку URL на просмотр документа онлайн в браузере
[allow-online] текст [/allow-online] | Выводят заключенный в них текст, если загруженный документ имеет поддерживаемый для просмотра формат


Комментарии

Navigation: Шаблоны >

Комментарии

 Return to chapter overview

Вывод данного раздела настраивается в файле comments.tpl В данном разделе настраивается вывод комментариев для статьи.

{author} | Имя человека, оставившего комментарий
{mail} | е-mail человека, оставившего комментарий
{date} | Дата публикации комментария, формат вывода даты настраивается в настройках системы
{comment} | Текст комментария
{comment limit="X"} | Выводит текст комментария без HTML форматирования, при этом сам текст комментария сокращается до указанного "x" количества символов.
{comment-id} | Идентификационный номер комментария
{ip} | IP адрес человека, оставившего комментарий, просмотр доступен только администраторам сайта
[com-edit] и [/com-edit] | Ссылка на редактирование комментария только если это разрешено
[com-del] и [/com-del] | Ссылка на удаление комментария только если это разрешено
{news_title} | Выводит ссылку на новость при просмотре последних комментариев, при выводе комментариев в новости тег вырезается
{news-title} | Выводит HTML безопасный заголовок новости, которой принадлежит данный комментарий, при просмотре последних комментариев. При выводе комментариев в новости тег вырезается. Данный тег будет полезен при использовании пользовательского вывода комментариев и при показе последних комментариев.
{news-link} | Выводит URL новости, которой принадлежит данный комментарий, при просмотре последних комментариев. При выводе комментариев в новости тег вырезается. Данный тег будет полезен при использовании пользовательского вывода комментариев и при показе последних комментариев.
{foto} | Выводит ссылку на фотографию
{fullname} | Выводит полное имя пользователя
{land} | Выводит место жительства
[signature] и [/signature] | Выводит текст заключенный в теги, если пользователь задал подпись в профиле
{signature} | Выводит подпись пользователя
{registration} | Выводит дату регистрации на сайте
{lastdate} | Выводит дату последнего посещения сайта пользователя.
[fast] [/fast] | Быстрое цитирование комментариев
{group-icon} | Выводит иконку группы участника
{group-name} | Выводит имя группы участника
{news-num} | Выводит количество новостей участника
{comm-num} | Выводит количество комментариев участника
{date=формат даты} | Выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время
{login} | Выводит логин автора комментария без каких либо ссылок и меню
[profile] текст [/profile] | Выводит текст заключенный в теге в виде ссылки на профиль пользователя оставившего комментарий
{mass-action} | Устанавливает возможность массовой отметки комментариев для выполнения массовых действий на сайте
[complaint] текст [/complaint] | Выводят текст, указанных в тегах в виде ссылки на написание жалобы, на комментарий.
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | Выводится дополнительное поле "x", если поле не пустое
[xfnotgiven_x] текст [/xfnotgiven_x] | Выводится текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя
[xfvalue_x] | Значение дополнительного поля "x", где "x" название дополнительного поля
[fullname] текст [/fullname] | Выводится текст заключенный в них только если полное имя пользователя задано
[not-fullname] текст [/not-fullname] | Выводится текст, заданный в них только если полное имя пользователя не задано
[land] текст [/land] | Выводится текст заключенный в них только если местожительство пользователя было им задано
[not-land] текст [/not-land] | Выводится текст, заданный в них только если местожительство пользователя не было им указано
[news-num] текст [/news-num] | Выводится текст, заключенный в них если у данного пользователя есть опубликованные новости на сайте
[not-news-num] текст [/not-news-num] | Выводится текст заключенных в них если у данного пользователя нет новостей на сайте
[comm-num] текст [/comm-num] | Выводится текст, заключенный в них если у данного пользователя есть опубликованные комментарии на сайте
[not-comm-num] текст [/not-comm-num] | Выводится текст заключенных в них если у данного пользователя нет комментариев на сайте
[online] текст [/online] | Выводят текст если пользователь онлайн (20 минут с момента последнего посещения пользователем сайта)
[offline] текст [/offline] | Выводят текст если пользователь оффлайн
[spam] Спамер [/spam] | Выводят текст, указанных в них, в виде ссылки, при нажатии на которую происходит отметка посетителя, оставившего комментарий, как "спамера"
[declination=X] текст [/declination] | Выводит склонения слов относительно чисел. В качестве параметров тега вместо X передается число, а вместо "текст" передается корень слова с окончаниями. Окончания слова перечисляются при помощи символа "|". Данный тег полезно использовать с другими тегами, выводящими например количество просмотров новости или количество комментариев. Например [declination={comments-num}]комментари|й|я|ев[/declination] в зависимости от количества комментариев будет выводить: "комментарий", "комментария", "комментариев"
[commentsgroup=1,2,3] текст [/commentsgroup] | Выводят заключенный в них текст указанных в них, если комментарий был написан пользователем принадлежащем перечисленным группам
[not-commentsgroup=1,2,3] текст [/not-commentsgroup] | Выводят заключенный в них текст если комментарий был написан пользователем не принадлежащем указанным группам
[commentscount=x] текст [/commentscount] | Выводят текст указанный в тегах если показывается X комментарий, где X это число показываемого на странице комментария. Например [commentscount=1] текст [/commentscount] покажет текст при показе первого по счету на странице комментария. Данный тег полезен для вебмастеров, которые хотят например регулировать где им показывать рекламу на сайте между комментариями. Например, добавленный в самый конец шаблона код [commentscount=1,10] рекламный код [/commentscount], будет показывать рекламу после первого и десятого комментария.
[not-commentscount=X] текст [/not-commentscount] | Выводят текст заключенный в данные теги при показе любых по счету комментариев, кроме указанных X комментариях. Данный тег будет полезен, если вы хотите выводить какие-либо элементы оформления во всех по счету комментариях, кроме вышеуказанных. Например, что-либо не показывать в первом по списку комментарии.
[rating-type-1] текст [/rating-type-1] | Выводят текст, заключенный в них, если в настройках скрипта включено использование первого типа рейтинга 'Оценка'.
[rating-type-2] текст [/rating-type-2] | Выводят текст, заключенный в них, если в настройках скрипта включено использование второго типа рейтинга 'Только Нравится'.
[rating-type-3] текст [/rating-type-3] | Выводят текст, заключенный в них, если в настройках скрипта включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.
[rating-minus] текст [/rating-minus] | Выводят текст, заключенных в них, в виде ссылки для уменьшения рейтинга комментария, выводится данная ссылка только если используется третий тип рейтинга.
[rating-plus] текст [/rating-plus] | Выводят текст, заключенных в них, в виде ссылки для увеличения рейтинга комментария, выводится данная ссылка только если используется второй и третий тип рейтинга.
{rating} | Выводит выставленный для комментария рейтинг.
{vote-num} | Выводит количество пользователей, которые выставили рейтинг для данного комментария.
[reply] текст [/reply] | Выводят текст в них, в виде ссылки на открытие всплывающего окна для ответа на комментарий, в случае если включена поддержка древовидных комментариев, а в случае если она отключена вставляет логин выбранного комментатора в форму добавления комментариев
[treecomments] текст [/treecomments] | Выводят текст, заключенных в них, в случае если включены древовидные комментарии в настройках скрипта.
[not-treecomments] текст [/not-treecomments] | Выводят текст, заключенный в них, в случае если древовидные комментарии отключены.
[rootcomments] текст [/rootcomments] | Выводят текст, заключенных в них, в случае если комментарий является основным родительским к новости, а не является ответом на какой-либо другой комментарий.
[childrencomments] текст [/childrencomments] | Выводят текст, заключенных в них, в случае если комментарий является ответом на другой комментарий.
{replycount} | Выводит количество имеющихся ответов на данный комментарий
[comments-author] текст [/comments-author] | Выводят текст, заключенный в них, если пользователь, просматривающий страницу сайта, является автором данного комментария
[not-comments-author] текст [/not-comments-author] | Выводят текст, заключенный в них, если пользователь, просматривающий страницу сайта, не является автором данного комментария
[news-author] текст [/news-author] | Выводят текст, заключенный в них, если комментарий принадлежит автору данной новости
[not-news-author] текст [/not-news-author] | Выводят текст, заключенный в них, если комментарий не принадлежит автору данной новости
[positive-comment] текст [/positive-comment] | Выводят текст, заключенный в них, если комментарий имеет позитивный рейтинг
[negative-comment] текст [/negative-comment] | Выводят текст, заключенный в них, если комментарий имеет негативный рейтинг
[neutral-comment] текст [/neutral-comment] | Выводят текст, заключенный в них, если комментарий имеет нейтральный рейтинг


Форма добавления либо изменения комментария

Navigation: Шаблоны >

Форма добавления либо изменения комментария

 Return to chapter overview

Вывод данного раздела настраивается в файле addcomments.tpl В этом разделе настраиваются шаблоны, которые используются при добавлении комментариев в базу данных со стороны посетителей сайта. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{title} | Выводит заголовок, для чего эта форма, для добавления или редактирования комментариев
[not-logged] и [/not-logged] | Выводится код заключенный в теги, если пользователь не зарегистрирован, например вы можете заключить в эти теги поля для ввода имени и e-mail адреса, если они не заполнены и пользователь авторизован на сайте, эти данные будут взяты автоматически из его профиля.
{editor} | Выводит в зависимости от настроек BBCODE или WYSIWYG редактор для добавления комментария
[sec_code] и [/sec_code] | Выводит текст если было установлено в настройках использование CAPTCHA при добавлении комментариев
{sec_code} | Выводит код отображения CAPTCHA
[recaptcha] тест [/recaptcha] | Выводят информацию, заключенную в тегах, в случае если в настройках скрипта включент тип каптчи reCAPTCHA
{recaptcha} | Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи.
[question] и [/question] | выводят текст заключенный в данные теги если система вопрос-ответ включена
{question} | выводит вопрос для посетителя из заданного ранее списка вопросов и ответов
[vk] текст [/vk] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте
{vk_url} | Выводит ссылку URL на авторизацию в соц. сети Вконтакте
[odnoklassniki] текст [/odnoklassniki] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники
{odnoklassniki_url} | Выводит ссылку URL на авторизацию в соц. сети Одноклассники
[facebook] текст [/facebook] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook
{facebook_url} | Выводит ссылку URL на авторизацию в соц. сети Facebook
[google] текст [/google] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google
{google_url} | Выводит ссылку URL на авторизацию в соц. сети Google
[mailru] текст [/mailru] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru
{mailru_url} | Выводит ссылку URL на авторизацию в соц. сети Mail.ru
[yandex] текст [/yandex] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex
{yandex_url} | Выводит ссылку URL на авторизацию в соц. сети Yandex


Опросы в новостях

Navigation: Шаблоны >

Опросы в новостях

 Return to chapter overview

Вывод данного раздела настраивается в файле poll.tpl В данном разделе настраивается вывод опроса для опубликованной новости

{title} | Заголовок опроса
{question} | Вопрос
{votes} | Общее количество голосов
{list} | Список вариантов ответа
[voted] текст [/voted] | Выводят текст в тегах если пользователь уже проголосовал в опросе, в противном случае его скрывают
[not-voted] текст [/not-voted] | Выводят текст в тегах если пользователь еще не проголосовал в опросе, в противном случае его скрывают


Добавление новости

Navigation: Шаблоны >

Добавление новости

 Return to chapter overview

Вывод данной формы настраивается в файле addnews.tpl В этом разделе настраиваются шаблоны, которые используются при добавлении новости в базу данных со стороны посетителей сайта. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{category} | Выводится поле для выбора категории к которой будет принадлежать категория
{xfields} | Вывод дополнительных полей при добавлении новости
[xfinput_X] | Выводит ваше выбранное дополнительное поле в форме добавления новости в нужном вам месте, где X это имя дополнительного поля для новостей
{bbcode} | Выводятся кнопки для вставки тегов в новости
{admintag} | Вывод дополнительных опций для администратора
[urltag] и [/urltag] | Выводится код заключенный в теги, для изменения ЧПУ URL статьи (доступно администратору)
[not-wysywyg] и [/not-wysywyg] | Выводится текст заключенный в теги если отключен WYSIWYG редактор, если включен, то содержимое тегов удаляется
{shortarea} | Выводит WYSIWYG редактор для добавления краткой новости
{title} | Выводит заголовок во время редактирования новости
{alt-name} | Значение ЧПУ при редактировании новости
{short-story} | Короткая новость при редактировании новости
{full-story} | Полная новость при редактировании новости
[sec_code] и [/sec_code] | Выводит текст если было установлено в настройках использование CAPTCHA при добавлении новостей
{sec_code} | Код отображения CAPTCHA
{fullarea} | Выводит WYSIWYG редактор для добавления полной новости
[recaptcha] тест [/recaptcha] | Выводят информацию, заключенную в тегах, в случае если в настройках скрипта включент тип каптчи reCAPTCHA
{recaptcha} | Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи.
[question] и [/question] | Выводят текст заключенный в данные теги если система вопрос-ответ включена
{question} | Выводит вопрос для посетителя из заданного ранее списка вопросов и ответов
{votetitle} | Выводит заголовок опроса при редактировании новости
{frage} | Выводит вопрос из опроса при редактировании новости
{votebody} | Выводит список вариантов ответа из опроса при редактировнии новости


Предосмотр новостей

Navigation: Шаблоны >

Предосмотр новостей

 Return to chapter overview

Вывод данного раздела настраивается в файле preview.tpl В этом разделе настраиваются шаблоны, предназначенные для предосмотра добавляемых новостей. В данном шаблоне вы можете использовать все теги для краткой и полной новости, а также статических страниц, при этом для разделения просматриваемых частей используются дополнительно теги:

[short-preview] и [/short-preview] выводит в тегах текст шаблона предназначенного для просмотра краткой новости

[full-preview] и [/full-preview] выводит в тегах текст шаблона предназначенного для просмотра полной новости

[static-preview] и [/static-preview] выводит в тегах текст шаблона предназначенного для просмотра статической страницы


Предыдущая и следующая страницы для новостей

Navigation: Шаблоны >

Предыдущая и следующая страницы для новостей

 Return to chapter overview

Вывод данного раздела настраивается в файле navigation.tpl В данном разделе настраивается вывод навигации для новостей

[prev-link] and [/prev-link] | Создает ссылку на предыдущую страницу (если такая есть)
[next-link] and [/next-link] | Создает ссылку на следующую страницу (если такая есть)
{pages} | Создает ссылки на страницы; например: 1 2 3 4


Регистрация на сайте

Navigation: Шаблоны >

Регистрация на сайте

 Return to chapter overview

Вывод данного раздела настраивается в файле registration.tpl В этом разделе настраиваются шаблоны, которые используются при регистрации посетителей на сайте. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

[registration] и [/registration] | Выводит текст заключенный в тегах при регистрации
[validation] и [/validation] | Выводит текст заключенный в тегах при активации
[sec_code] и [/sec_code] | Выводит текст заключенный в тегах если разрешен показ кода безопасности
{reg_code} | Выводит код безопасности для посетителя
{xfields} | Выводит поля для ввода дополнительных полей профиля
[xfinput_X] | Выводит ваше выбранное дополнительное поле в виде заполения поля в нужном вам месте, где X это имя дополнительного поля
[recaptcha] тест [/recaptcha] | Выводят информацию, заключенную в тегах, в случае если в настройках скрипта включент тип каптчи reCAPTCHA
{recaptcha} | Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи.
[question] и [/question] | Выводят текст заключенный в данные теги если система вопрос-ответ включена
{question} | Выводит вопрос для посетителя из заданного ранее списка вопросов и ответов
[vk] текст [/vk] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте
{vk_url} | Выводит ссылку URL на авторизацию в соц. сети Вконтакте
[odnoklassniki] текст [/odnoklassniki] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники
{odnoklassniki_url} | Выводит ссылку URL на авторизацию в соц. сети Одноклассники
[facebook] текст [/facebook] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook
{facebook_url} | Выводит ссылку URL на авторизацию в соц. сети Facebook
[google] текст [/google] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google
{google_url} | Выводит ссылку URL на авторизацию в соц. сети Google
[mailru] текст [/mailru] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru
{mailru_url} | Выводит ссылку URL на авторизацию в соц. сети Mail.ru
[yandex] текст [/yandex] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex
{yandex_url} | Выводит ссылку URL на авторизацию в соц. сети Yandex


Профиль пользователя

Navigation: Шаблоны >

Профиль пользователя

 Return to chapter overview

Вывод данного раздела настраивается в файле userinfo.tpl В этом разделе настраиваются шаблоны, которые используются при выводе профиля пользователя. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{usertitle} | Вывод имени пользователя
{info} | Краткая информация о пользователе
{editmail} | Выводит Е-mail адрес пользователя
{comm-num} | Выводит количество комментариев
{news-num} | Выводит количество новостей пользователя
{status} | Статус пользователя (его группа на сайте)
{rate} | Текущий рейтинг новостей посетителя (складывается автоматически на основе рейтинга его статей)
[rating-type-1] текст [/rating-type-1] | Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование первого типа рейтинга 'Оценка'.
[rating-type-2] текст [/rating-type-2] | Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование второго типа рейтинга 'Только Нравится'.
[rating-type-3] текст [/rating-type-3] | Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.
[comments-rating-type-1] текст [/comments-rating-type-1] | Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев первого типа рейтинга 'Оценка'.
[comments-rating-type-2] текст [/comments-rating-type-2] | Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев второго типа рейтинга 'Только Нравится'.
[comments-rating-type-3] текст [/comments-rating-type-3] | Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев третьего типа рейтинга 'Нравится' или 'Не нравится'.
{commentsrate} | Выводит суммарный рейтинг всех комментариев данного пользователя.
{registration} | Выводит его дату регистрации на сайте
{editinfo} | Вывод существующей краткой информации в поле при редактировании профиля
{hidemail} | Выводить чекбокс на скрытие e-mail адреса.
{foto} | Выводит ссылку на загруженную фотографию
{fullname} | Выводит полное имя пользователя
{land} | Выводит место жительства пользователя
[not-logged] и [/not-logged] | Выводится код заключенный в теги, если пользователь который просматривает профиль и есть этот самый пользователь, используется для того чтобы посетители могли редактировать свой собственный профиль.
[signature] и [/signature] | Выводит текст заключенный в теги, если пользователь задал подпись в профиле
{signature} | Выводит подпись пользователя
{editsignature} | Выводит отформатированную для редактирования подпись пользователя
{lastdate} | Выводит дату последнего посещения сайта пользователем
{comments} | Выводит ссылку на все комментарии этого пользователя
{allowed-ip} | Значение IP с которого разрешена авторизация
{xfields} | Выводится Список дополнительных полей профиля при их редактировании
[xfinput_X] | Выводит ваше выбранное дополнительное поле в виде заполения поля в нужном вам месте, где X это имя дополнительного поля
[xfvalue_x] | Выводится значение дополнительного поля "x", где "x" название дополнительного поля
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | Выводится дополнительное поле "x", если поле не пустое
[xfnotgiven_x] текст [/xfnotgiven_x] | Выводится текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя
{group-icon} | Выводит иконку группы участника
[time_limit] [/time_limit] | Выводит текст между тегами если пользователь находится во временной группе
{time_limit} | Выводит дату, до которой пользователь находится во временной группе
{news} | Выводит ссылку на просмотр всех новостей данного пользователя
[rss] тект [/rss] | Выводит ссылку в профиле на RSS поток всех новостей пользователя.
{ignore-list} | Список пользователей, добавленных в игнорируемые.
[fullname] текст [/fullname] | Выводится текст заключенный в них только если полное имя пользователя задано
[not-fullname] текст [/not-fullname] | Выводится текст, заданный в них только если полное имя пользователя не задано
[land] текст [/land] | Выводится текст заключенный в них только если местожительство пользователя было им задано
[not-land] текст [/not-land] | Выводится текст, заданный в них только если местожительство пользователя не было им указано
[news-num] текст [/news-num] | Выводится текст, заключенный в них если у данного пользователя есть опубликованные новости на сайте
[not-news-num] текст [/not-news-num] | Выводится текст заключенных в них если у данного пользователя нет новостей на сайте
[comm-num] текст [/comm-num] | Выводится текст, заключенный в них если у данного пользователя есть опубликованные комментарии на сайте
[not-comm-num] текст [/not-comm-num] | Выводится текст заключенных в них если у данного пользователя нет комментариев на сайте
[online] текст [/online] | Выводят текст если пользователь онлайн (20 минут с момента последнего посещения пользователем сайта)
[offline] текст [/offline] | Выводят текст если пользователь оффлайн
[profile-user-group=X] Текст [/profile-user-group] | Выводят текст заключенных в них, если группа пользователя, профиль которого просматривается, принадлежит указанной группе X. Где X это номер группы. Допускается также перечисление нужных групп через запятую.
[not-profile-user-group=X] Текст [/not-profile-user-group] | Выводят текст заключенных в них, если группа пользователя, профиль которого просматривается, не принадлежит указанной группе X. Где X это номер группы.
{timezones} | Выводит список доступных часовых поясов в системе, и позволяет пользователю выбрать свой часовой пояс для своего профиля на сайте.
{unsubscribe} | Выводит чекбокс на отписку от комментариев, и количество подписанных публикаций.
{news-subscribe} | Выводит чекбокс на подписку получения уведомлений о новых комментариях, которые добавляются к новостям, автором которых является пользователь.
{comments-reply-subscribe} | Выводит чекбокс на подписку получения уведомлений о новых комментариях, которые являются ответами на собственные комментарии пользователя.


Карточка профиля пользователя

Navigation: Шаблоны >

Карточка профиля пользователя

 Return to chapter overview

Вывод данного раздела настраивается в файле profile_popup.tpl В этом разделе настраиваются шаблоны, которые используются при выводе карточки профиля пользователя.

{fullname} | Выводит полное имя пользователя
{foto} | Выводит ссылку на загруженную фотографию
{status} | Статус пользователя
{registration} | Дата регистрации на сайте
{lastdate} | Выводит дату последнего посещения сайта пользователем
{comm-num} | Количество комментариев
{news-num} | Количество новостей
{land} | Выводит место жительства
{info} | Краткая информация о пользователе
{rate} | Текущий рейтинг новостей посетителя (складывается автоматически на основе рейтинга его статей)
[rating-type-1] текст [/rating-type-1] | Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование первого типа рейтинга 'Оценка'.
[rating-type-2] текст [/rating-type-2] | Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование второго типа рейтинга 'Только Нравится'.
[rating-type-3] текст [/rating-type-3] | Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.
[comments-rating-type-1] текст [/comments-rating-type-1] | Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев второго типа рейтинга 'Только Нравится'.
[comments-rating-type-2] текст [/comments-rating-type-2] | Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев второго типа рейтинга 'Только Нравится'.
[comments-rating-type-3] текст [/comments-rating-type-3] | Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев третьего типа рейтинга 'Нравится' или 'Не нравится'.
{commentsrate} | Выводит суммарный рейтинг всех комментариев данного пользователя.
[signature] и [/signature] | Выводит текст заключенный в теги, если пользователь задал подпись в профиле
{signature} | Выводит подпись пользователя
{group-icon} | Выводит иконку группы пользователя
{news} | Выводит ссылку на просмотр всех новостей данного пользователя
{comments} | Выводит ссылку на все комментарии этого пользователя
[rss] тект [/rss] | Выводит ссылку в профиле на RSS поток всех новостей пользователя
[fullname] текст [/fullname] | Выводится текст заключенный в них только если полное имя пользователя задано
[not-fullname] текст [/not-fullname] | Выводится текст, заданный в них только если полное имя пользователя не задано
[icq] текст [/icq] | Выводится текст заключенный в них только если ICQ пользователя задано
[not-icq] текст [/not-icq] | Выводится текст, заданный в них только если ICQ пользователя не задано
[land] текст [/land] | Выводится текст заключенный в них только если местожительство пользователя было им задано
[not-land] текст [/not-land] | Выводится текст, заданный в них только если местожительство пользователя не было им указано
[news-num] текст [/news-num] | Выводится текст, заключенный в них если у данного пользователя есть опубликованные новости на сайте
[not-news-num] текст [/not-news-num] | Выводится текст заключенных в них если у данного пользователя нет новостей на сайте
[comm-num] текст [/comm-num] | Выводится текст, заключенный в них если у данного пользователя есть опубликованные комментарии на сайте
[not-comm-num] текст [/not-comm-num] | Выводится текст заключенных в них если у данного пользователя нет комментариев на сайте
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | Выводится дополнительное поле "x", если поле не пустое
[xfnotgiven_x] текст [/xfnotgiven_x] | Выводится текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя
[xfvalue_x] | Значение дополнительного поля "x", где "x" название дополнительного поля
[online] текст [/online] | Выводят текст если пользователь онлайн (20 минут с момента последнего посещения пользователем сайта)
[offline] текст [/offline] | Выводят текст если пользователь оффлайн
[profile-user-group=X] Текст [/profile-user-group] | Выводят текст заключенных в них, если группа пользователя, профиль которого просматривается, принадлежит указанной группе X. Где X это номер группы. Допускается также перечисление нужных групп через запятую.
[not-profile-user-group=X] Текст [/not-profile-user-group] | Выводят текст заключенных в них, если группа пользователя, профиль которого просматривается, не принадлежит указанной группе X. Где X это номер группы.


Форма поиска

Navigation: Шаблоны >

Форма поиска

 Return to chapter overview

Вывод данного раздела настраивается в файле search.tpl В данном разделе настраиваются шаблоны, отвечающие за вывод формы поиска по сайту:

{searchtable} | Форма поиска в виде таблицы
{searchmsg} | Вывод сообщения о результатах поиска
[searchmsg] и [/searchmsg] | Вывод текста в случае если был произведен поиск


Результаты поиска

Navigation: Шаблоны >

Результаты поиска

 Return to chapter overview

Вывод данного раздела настраивается в файле searchresult.tpl В данном разделе настраиваются шаблоны, отвечающие за вывод новостей найденных в результате поиска:

[searchposts] и [/searchposts] | Вывод найденных результатов для новостей
[searchcomments] и [/searchcomments] | Вывод найденных результатов для комментариев
[fullresult] и [/fullresult] | Вывод результатов в виде статей
[shortresult] и [/shortresult] | Вывод результатов в виде заголовков

Внимание, в данном шаблоне для непосредственного вывода статей и комментариев исклюльзуются полностью аналогичные теги как и в шаблонах вывода кратких новостей и комментариев.


Статистика сайта

Navigation: Шаблоны >

Статистика сайта

 Return to chapter overview

Вывод данного раздела настраивается в файле stats.tpl В данном разделе настраивается вывод общей статистики сайта

{datenbank} | Общий размер базы данных
{news_num} | Общее количество новостей
{news_allow} | Опубликовано новостей
{news_main} | Опубликовано на главной
{news_moder} | Ожидает модерации
{comm_num} | Количество комментариев
{user_num} | Зарегистрировано пользователей
{user_banned} | Забаненных пользователей
{topusers} | Список лучших авторов на сайте
{news_day} | Опубликовано новостей за сутки
{news_week} | Опубликовано новостей за неделю
{news_month} | Опубликовано новостей за месяц
{comm_day} | Опубликовано комментариев за сутки
{comm_week} | Опубликовано комментариев за неделю
{comm_month} | Опубликовано комментариев за месяц
{user_day} | Зарегистрировано пользователей за сутки
{user_week} | Зарегистрировано пользователей за неделю
{user_month} | Зарегистрировано пользователей за месяц


Вывод информации и ошибок

Navigation: Шаблоны >

Вывод информации и ошибок

 Return to chapter overview

Вывод данного раздела настраивается в файле info.tpl В данном разделе настраивается вывод формы в случае возникновения ошибок, либо наоборот в случае успешного выполнения действий.

{title} – заголовок сообщения

{error} – текст ошибки


Форма для отправки E-Mail

Navigation: Шаблоны >

Форма для отправки E-Mail

Return to chapter overview

Вывод данного раздела настраивается в файле feedback.tpl В этом разделе настраиваются шаблоны, которые используются при выводе формы для отправки E-Mail. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{recipient} - Выводит список получателей

[not-logged] и [/not-logged] - Выводит текст между тегами если посетитель не зарегистрирован

{code} - Выводит код отображения CAPTCHA

[sec_code] и [/sec_code] Выводит текст если в настройках скрипта включена стандартная CAPTCHA

[recaptcha] и [/recaptcha] Выводит текст если в настройках скрипта включена reCAPTCHA

{recaptcha} Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи


Восстановление пароля

Navigation: Шаблоны >

Восстановление пароля

 Return to chapter overview

Вывод данного раздела настраивается в файле lostpassword.tpl В этом разделе настраиваются шаблоны, которые используются при выводе формы для восстановления пароля на E-Mail. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{code} - Выводит код отображения CAPTCHA

[sec_code] и [/sec_code] Выводит текст если в настройках скрипта включена стандартная CAPTCHA

[recaptcha] и [/recaptcha] Выводит текст если в настройках скрипта включена reCAPTCHA

{recaptcha} Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи


Статические страницы

Navigation: Шаблоны >

Статические страницы

 Return to chapter overview

Вывод статических страниц настраивается в файле static.tpl или в файле который вы назначите при создании статической страницы в админпанели скрипта. В данном шаблоне вы можете использовать следующие теги:

{description} выводит описание статической страницы

{static} выводит текст статической страницы

{pages} Выводит навигацию по нескольким страницам одной статической страницы.

{views} Выводит количество просмотров статической страницы.

{custom} Смотрите раздел "Вывод новостей на страницах"

{text limit="x"} выводит только текст добавленных для статической страницы без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов. При этом сокращение текста происходит до последнего логического слова.

{image-x} выводит URL картинки, находящейся в тексте статической страницы, где "x" это номер картинки в тексте страницы, например, {image-1} выведет URL первой картинки в тексте страницы.

[image-x] текст [/image-x] выводят указанный в них текст, только если картинка с номером "x" присутствует в тексте страницы.

[print-link] текст [/print-link] выводить ссылку на версию для печати

{date} выводит дату создания страницы в формате установленном в настройках скрипта

{date=формат даты} выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y, H:i} выведет полную дату и время. Также дополнительно как в тексте статических страниц, так и в их шаблонах вы можете указывать теги из модуля управления рекламой и теги информеров.

[static=имя страницы] текст [/static] выводит текст заключенный в теги , если посетитель просматривает статическую страницу с указанным именем.

[not-static=имя страницы] текст [/not-static] выводит текст заключенный в теги, если посетитель не просматривает статическую страницу с указанным именем.

Также в шаблоне имеется поддержка тегов рекламы и RSS информеров


Персональные сообщения

Navigation: Шаблоны >

Персональные сообщения

 Return to chapter overview

Вывод данного раздела настраивается в файле pm.tpl В этом разделе настраиваются шаблоны, которые используются для работы с персональными сообщениями. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

[inbox] и [/inbox] | Ссылка на входящие сообщения
[outbox] и [/outbox] | Ссылка на отправленные сообщения
[new_pm] и [/new_pm] | Ссылка на написание сообщения
[pmlist] и [/pmlist] | Выводится текст в тегах, если просматривается список сообщений
{pmlist} | Список сообщений
[newpm] и [/newpm] | Выводится текст в тегах, если написание сообщения
{pm-limit} | Выводит максимальное количество сообщений, который может хранить пользователь
{proc-pm-limit} | Выводит количество заполненного пространства ящика пользователя в процентах
{pm-progress-bar} | Выводит шкалу наполненности ящика персональных сообщений
{author} | Получатель сообщения
{subj} | Тема сообщения
{editor} | Выводит в зависимости от настроек BBCODE или WYSIWYG редактор для написания сообщения
{text} | Текст сообщения
[readpm] и [/readpm] | Выводится текст в тегах, если просматривается само сообщение
[reply] и [/reply] | Ссылка для ответа на сообщение
[del] и [/del] | Ссылка на удаление сообщения
{sec_code} | Код отображения CAPTCHA
[sec_code] и [/sec_code] | Выводит текст если было установлено в настройках использование CAPTCHA при написании персональных сообщений
{foto} | Выводит ссылку на фотографию
{group-icon} | Выводит иконку группы участника
{group-name} | Выводит имя группы участника
{news-num} | Выводит количество новостей участника
{comm-num} | Выводит количество комментариев участника
[signature]{signature}[/signature] | Выводит текст заключенный в теги и подпись пользователя, если пользователь задал подпись в профиле
{date} | Дата публикации комментария, формат вывода даты настраивается в настройках системы
{registration} | Выводит дату регистрации на сайте
[recaptcha] тест [/recaptcha] | Выводят информацию, заключенную в тегах, в случае если в настройках скрипта включент тип каптчи reCAPTCHA
{recaptcha} | Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи.
[complaint] текст [/complaint] | Выводять текст, указанных в тегах в виде ссылки на написание жалобы, на персональное сообщение.
[ignore]текст[/ignore] | Выводит ссылки на добавление пользователя в список игнорируемых.
[online] текст [/online] | Выводят текст если пользователь онлайн (20 минут с момента последнего посещения пользователем сайта)
[offline] текст [/offline] | Выводят текст если пользователь оффлайн
[declination=X] текст [/declination] | Выводит склонения слов относительно чисел. В качестве параметров тега вместо X передается число, а вместо "текст" передается корень слова с окончаниями. Окончания слова перечисляются при помощи символа "|". Данный тег полезно использовать с другими тегами, выводящими например количество просмотров новости или количество комментариев. Например [declination={comments-num}]комментари|й|я|ев[/declination] в зависимости от количества комментариев будет выводить: "1 комментарий", "2 комментария", "10 комментариев"


Облако тегов

Navigation: Шаблоны >

Облако тегов

 Return to chapter overview

Вывод данного раздела настраивается в файле tagscloud.tpl В этом разделе настраиваются шаблоны, которые используются для работы с облаком тегов. В данном блоке показываются все ключевые теги добавленные к новостям.

Возможно использование следующих тегов:

{tags} - Используется для вывода всех ключевых тегов, находящихся в базе данных

{tags limit="100"} - Используется для вывода 100 самых популярных ключевых тегов, находящихся в базе данных


Голосование на сайте

Navigation: Шаблоны >

Голосование на сайте

 Return to chapter overview

Вывод данного раздела настраивается в файле vote.tpl В этом разделе настраиваются шаблоны, которые используются для работы с голосованием на сайте.

Возможно использование следующих тегов:

{title} - Заголовок опроса

{list} - Список вопросов

{vote_id} - ID опроса

{votes} - Количество голосов

[votelist] и [/votelist] - Выводит текст который нужно показывать для еще не голосовавших людей

[voteresult] и [/voteresult] - Выводит текст который нужно показывать для уже голосовавших людей


Топ новостей

Navigation: Шаблоны >

Топ новостей

 Return to chapter overview

Вывод данного раздела настраивается в файле topnews.tpl В этом разделе настраиваются шаблоны, которые используются для вывода блока популярных новостей.

Возможно использование следующих тегов:

{title} - выводит заголовок новости

{title limit="x"} - Выводится урезанный до X количества символов, заголовок новости.

{link} - выводит ссылку на новость

{date} - Выводится дата публикации, формат вывода даты настраивается в настройках системы

{date=формат даты} - Выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время

{image-x} - выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости

[image-x] текст [/image-x] - выводят текст указанный в них только в случае если картинка с номером X присутствует в новости

{text} - выводит полностью краткое содержание новости

{text limit="x"} - выводит только текст краткой новости без HTML форматирования, при этом сам текст публикации обрезает до указанных X количества символов. При этом обрезание текста происходит до последнего логического слова, а не обрывает текст на середине слова. Тем самым вы получаете возможность более расширенного оформления публикации популярных новостей на сайте.

{category} - выводит категорию, к которой относится статья

{link-category} - выводит ссылку на все категрии в которой присутствует новость

[xfvalue_x] - выводит значение дополнительного поля "x", где "x" название дополнительного поля

[xfgiven_x] [xfvalue_x] [/xfgiven_x] - Выводится дополнительное поле "x", если поле не пустое, если поле не имеет значения, то текст просто вырезается

[xfnotgiven_X] текст [/xfnotgiven_X] - Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля


Похожие новости

Navigation: Шаблоны >

Похожие новости

 Return to chapter overview

Вывод данного раздела настраивается в файле relatednews.tpl В этом разделе настраиваются шаблоны, которые используются для вывода списка похожих новостей при просмотре полной новости на сайте.

Возможно использование следующих тегов:

{title} - выводит заголовок новости

{title limit="x"} - выводит заголовок новости, сокращенный до указанного количества в теге X символов. При этом сокращение заголовка производится до завершения логического слова, а не обрывается посередине.

{link} - выводит ссылку на новость

{date} - Выводится дата публикации, формат вывода даты настраивается в настройках системы

{date=формат даты} - Выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время

{image-x} - выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости

[image-x] текст [/image-x] - выводят текст указанный в них только в случае если картинка с номером X присутствует в новости.

{text} - выводит полностью краткое содержание новости

{text limit="x"} - выводит только текст краткой новости без HTML форматирования, при этом сам текст публикации обрезает до указанных X количества символов. При этом обрезание текста происходит до последнего логического слова, а не обрывает текст на середине слова. Тем самым вы получаете возможность более расширенного оформления публикации популярных новостей на сайте.

{category} - выводит категорию, к которой относится статья

{link-category} - выводит ссылку на все категрии в которой присутствует новость

[xfvalue_x] - выводит значение дополнительного поля "x", где "x" название дополнительного поля

[xfgiven_x] [xfvalue_x] [/xfgiven_x] - Выводится дополнительное поле "x", если поле не пустое, если поле не имеет значения, то текст просто вырезается

[xfnotgiven_X] текст [/xfnotgiven_X] - Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля


Временное отключение сайта

Navigation: Шаблоны >

Временное отключение сайта

 Return to chapter overview

В данном разделе вы можете настроить страницу, которая будет выводится при отключении сайта например на технические работы. Помните что администраторы всегда будут допущены к просмотру сайта как при включенном режиме. Все остальные будут видеть страницу из данного раздела.

Шаблон настраивается в файле offline.tpl и возможно использование следующих тегов:

{reason} - Используется для вывода причины отключения сайта, которое вы задаете в настройках скрипта


Модуль speedbar

Navigation: Шаблоны >

Модуль speedbar

 Return to chapter overview

В данном разделе вы можете настроить вывод текущего местоположения пользователя на вашем сайте. Данный шаблон использует только один тег {speedbar} который и выводит непосредственно местоположение.


RSS трансляция новостей

Navigation: Шаблоны >

RSS трансляция новостей

 Return to chapter overview

Данный шаблон находится в файле templates/rss.tpl и предназначен для настройки вывода RSS потока вашего сайта.

В данном шаблоне вы можете использовать следующие теги:

[shortrss] текст [/shortrss] - Выводят текст заключенный в них, если в настройках скрипта включен краткий формат вывода RSS новостей.

[fullrss] текст [/fullrss] - Выводят текст заключенный в них, если в настройках скрипта включен полный формат вывода RSS новостей.

[yandexrss] текст [/yandexrss] - Выводят текст заключенный в них, если в настройках скрипта включен формат вывода RSS новостей "Яндекс новости".

{title} - Выводит заголовок новости

{rsslink} - Выводит полный URL новости

{rssauthor} - Выводят автора новости

{rssdate} - Выводят дату новости

{category} - Выводят категорию новости

{short-story} - Выводят текст краткой новости

{images} - Выводит набор картинок для Яндекс новостей

{full-story} - Выводит текст полной новости, только для Яндекс новостей

Также вы можете использовать дополнительно любые теги которые поддерживаются шаблоном вывода краткиких новостей shortstory.tpl, однако вам необходимо быть внимательными чтобы не был нарушен стандарт вывода RSS 2.0 который используется для RSS трансляции публикаций.


RSS информер

Navigation: Шаблоны >

RSS информер

 Return to chapter overview

В данном шаблоне вы можете настроить вывод вашего RSS информера. Имя данного шаблона вы назначаете самостоятельно в админпанели при добавлении нового RSS информера. В данном шаблоне вы можете использовать следующие теги:

[link] текст [/link] - формирует ссылку на новость партнера

{link} - предназначен для вывода только URL ссылки на страницу источника публикации

{title} - заголовок новости

{news} - непосредственно сама новость

{category} - выводит категорию в которой опубликована новости в RSS потоке

{author} - выводит автора новости

{date} - выводит дату новости, при этом формат даты можно задать в настройках информера, для каждого информера.

{date=формат даты} - выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком, но и ее отдельные части. Формат даты задается задается согласно формату, принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время.

{image-x} - выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости

[image-x] текст [/image-x] - выводят текст указанный в них только в случае если картинка с номером X присутствует в новости


OpenSearch

Navigation: Шаблоны >

OpenSearch

 Return to chapter overview

Данный шаблон находится в файле templates/opensearch.tpl и предназначен для поддержки технологии OpenSearch в современных браузерах, данная технология позволяет интегрировать поиск по вашему сайту в строку поиска самого браузера. Будьте предельно внимательны при редактировании данного шаблона. Он должен соответствовать необходимым спецификациям.


Разработка и подключение модулей

Navigation: Разработчикам >

Разработка и подключение модулей

 Return to chapter overview

DataLife Engine предоставляет удобные механизмы для подключения разработанных вами модификаций скрипта. Данные механизмы позволяют обеспечить работоспособность и после обновления скрипта на новую версию, т.к. данные механизмы позволяют осуществлять подключение без правки файлов скрипта. Для подключения разработанных вами модулей вам необходимо в любом необходимом вам шаблоне добавить тег:

{include file="engine/modules/mymod.php"}

Где engine/modules/ это путь к файлу вашего модуля, а mymod.php имя подключаемого файла. Стандартные файлы модулей DataLife Engine находятся в этой папке и мы вам рекомендуем использовать данную папку, однако это не является обязательным требованием и файл может находится в любой другой папке на сервере. Единственное ограничение безопасности по подобному подключению модулей, это то что на папку в которой находится файл не должно быть прав на запись (CHMOD 777). Также мы рекомендуем вам использовать именно относительные пути при подключении модулей, DataLfe Engine автоматически распознает относительные пути и подключает ваши модули уже согласно настройкам скрипта и путям где установлен скрипт. Тем самым вы можете создавать универсальные инструкции по установке ваших модификаций.

Также вы можете подключать PHP файлы вашего модуля передав им различные параметры, например:

{include file="engine/modules/mymod.php?param=value1&variable2=value2"}

Благодаря подобному подключению, вы можете делать ваши модификации многофункциональными, которые будут выполнять различные роли и функции при различных подключениях. Переданные переменные будут доступны в вашем модуле как $param и $variable2 соответственно.

Начиная с версии DataLife Engine 8.3 в качестве параметров к подключаемым модулям вы можете задавать шаблонные теги скрипта, например при добавлении в шаблон полной новости конструкции {include file="engine/modules/mymod.php?param={news-id}"}, вы можете передавать вашему стороннему модулю в качестве параметра ID новости и т.д. Вниманию разработчиков: Передаваемые в скрипт параметры, это аналоги GET параметров URL браузера, соответственно при выборе передаваемых тегов вы должны учитывать ограчения GET строки, другими словами вы не можете передать в качестве параметра содержимое полной новости к примеру.

Также вы можете использовать подключение своих модулей и для замены основного блока, где выводятся новости и другая основная информация, для этого необходимо использовать данный тег совместно с тегами [aviable=раздел]текст[/aviable] и [not-aviable=раздел]текст[/not-aviable] Описание тегов смотрите в документации в разделе "Вывод новостей на страницах". Вы можете использовать как стандартный список разделов, так и использовать создание собственного раздела сайта, передав его в URL браузера. Рассмотрим простейший пример. Вы хотите добавить к стандартным разделам сайта, добавить свой раздел и выводить информацию в нем из вашего модуля. Допустим вы хотите создать раздел FAQ. Для этого в шаблоне main.tpl прописывается конструкция:

[aviable=faq]{include file="engine/modules/mymod.php"}[/aviable]

[not-aviable=faq]{content}[/not-aviable]

После подобного подключения помимо работы стандартных разделов сайта при обращении по адресу: http://site.ru/index.php?do=faq вместо новостей будет выводится ваш новый раздел из вашего модуля.

Для работы ваших модулей и вывода информации именно в том месте шаблона, где вставлен вышеуказанный тег, обязательно только одно важное условие. Вывод информации должен осуществляется только через функцию PHP echo. Рассмотрим пример простейшего модуля и вывода информации. Создадим файл mymod.php со следующим содержимым:

<?php

echo "Тестовый модуль";

?>

При подключении этого файла в шаблоне, в данном месте шаблона появится текст: Тестовый модуль

Список переменных и классов DLE которые вы можете использовать в вашем подключаемом модуле, без дополнительного объявления:

$is_logged - содержит информацию, является ли посетитель авторизованным пользователем или гостем, и содержит значения true или false.

$member_id - содержит массив с информацией о авторизованном пользователе, включая всю его информацию из профиля.

$db - класс DLE для работы с базой данных.

$tpl - класс DLE для работы с шаблонами.

$cat_info - массив содержащий информацию обо всех категориях на сайте.

$config - массив содержащий информацию обо всех настройках скрипта.

$user_group - массив содержащий информацию о всех группах пользователей и их настройках.

$category_id - содержит ID категории которую просматривает посетитель.

$_TIME - содержит текущее время в UNIX формате с учетом настроек смещения в настройках скрипта.

$lang - массив содержащий текст из языкового пакета.

$smartphone_detected - содержит информацию о том, просматривает ли пользователь сайт со смартфона или с обычного браузера, и содержит значения true или false.

$dle_module - содержит информацию о разделе сайта, который просматривает пользователь, либо информацию переменной do из URL браузера.

Внимание: Ваш модуль должен только читать данные из данных переменных, внесение изменений в значения переменных повлечет сбои в работе стандартных возможностей скрипта и дальнейшей его некорректной работе.


Подключение модулей в адмипанели

Navigation: Разработчикам >

Подключение модулей в адмипанели

 Return to chapter overview

DataLife Engine предоставляет удобные механизмы для подключения разработанных вами модификаций скрипта в админпанели. Данные механизмы позволяют подключать модули админпанели без внесения изменений в файлы скрипта и позволяют сохранять работоспособность после обновления скрипта на новую версию скрипта.

Для того чтобы подключить ваш сторонний модуль в админпанель, вы должны разместить файл вашего модуля в папке engine/inc/ это обязательное условие. Только файлы находящиеся в этой папке могут быть подключены. Например имя файла вашего модуля mymod.php вы разместили его в папке engine/inc/ После этого вы можете вызвать и обратится к вашему модулю из админпанели по адресу: http://site.ru/admin.php?mod=mymod где mymod это имя вашего модуля без расширения .php Подключение происходит автоматически, никаких изменений в файлах скрипта не требуется.

Для того чтобы пользователи не вводили адрес вашего модуля в браузере вручную и он отображался в списке всех разделов в административной панели, для этого предусмотрена специальная таблица в базе данных MySQL. Имя таблицы: ПРЕФИКС_admin_sections. ПРЕФИКС ваш скрипт установки может прочитать из файла engine/inc/dbconfig.php. Данная таблица содержит следующие имена полей:

name - содержит имя вашего модуля, а именно файла .php находящегося в папке engine/inc/, но без расширения файла. Например имя вашего файла mymod.php, то в данное поле должно быть записано значение mymod.

title - содержит заголовок вашего модуля.

descr - содержит описание вашего модуля.

icon - содержит имя иконки для вашего модуля, без указания пути. Иконка обязательно при этом должна находится в папке engine/skins/images/ (это обязательное условие). Рекомендуемые размеры иконок 70 на 70 пикселей.

allow_groups - содержит информацию о группах которым разрешен показ данного модуля. Данное поле может принимать следующие значения: all или ID групп через запятую. Например: 1,2,3. если указано значение all то модуль будет показываться всем пользователям имеющим доступ в админпанел.

Пример запроса для записи информации о модуле mymod:

INSERT INTO `префикс_admin_sections` (`name`, `title`, `descr`, `icon`, `allow_groups`) VALUES

('mymod', 'Тестовый модуль', 'Здесь находится описание тестового модуля', 'mymod.png', '1');

после выполнения данного запроса модуль в админпанели будет прописан в админпанели только для администраторов.

ВНИМАНИЕ: указание о группах в базе данных не запрещает и не предотвращяет запуск модуля пользователями из других групп. Для разграничения доступа ваши подключаемые модули обязаны сами производить проверку групп и разрешать выполнение только разрешенным группам.


API для разработки модулей

Navigation: Разработчикам >

API для разработки модулей

 Return to chapter overview

API предназначен для написания модификаций совместимых со старыми и будущими версиями скрипта. В случае использования API для получения данных из базы, вы можете быть уверенными что данный код будет работать и в будущих версиям, тем самым вы облегчается проверка и адаптация кода при выходе новой версии. Также при использовании API вам нет необходимости писать собственные функции для выборки данных, нет необходимости подключать и объявлять необходимые для работы с БД классы. Достаточно просто подключить файл API, и начать использовать его функции, все остальное он берет на себя.

Для использования API в своем модуле вы должны его подключить строчкой:

include ('engine/api/api.class.php');

При этом вам нет необходимости задумываться есть ли подключение к БД или нет, подключены или нет необходимые классы. Данный код вы можете использовать как внутри файлов самого скрипта DLE, так и просто в других скриптах, не имеющих отношения к DLE. Тем самым вы можете организовывать стандартизированные интеграции скрипта DLE, с другими скриптами. Например форумами.

Список функций API:

$dle_api->take_user_by_id( int $id [, string $select_list] );

получение массива с информацией о пользователе по его ID. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить или * для всех. Возвращает массив с информацией о пользователе либо false, если пользователь не найден.

$dle_api->take_user_by_name( string $name [, string $select_list]);

получение массива с информацией о пользователе по его логину. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить или * для всех. Возвращает массив с информацией либо false, если пользователь не найден.

$dle_api->take_user_by_email( string $email [, string $select_list]);

получение массива с информацией о пользователе по его E-Mail. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить или * для всех. Возвращает массив с информацией либо false, если пользователь не найден.

$dle_api->take_users_by_group( int $group_id [, string $select_list [, int $limit]]);

получение массива с информацией о пользователях по номеру группы. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить. Необязательный параметр $limit указывает на лимит количества возращаемых пользователей. Возвращает массив с информацией либо false, если пользователи не найдены.

$dle_api->take_users_by_ip( string $ip, [, bool $like [, string $select_list [, int $limit]]]);

Получение списка пользователей по IP, второй параметр $like указывает использовать точное совпадение при поиске, либо неточное. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить. Необязательный параметр $limit указывает на лимит количества возращаемых пользователей. Возвращает массив с информацией либо false, если пользователи не найдены.

$dle_api->change_user_name( int $user_id, string $new_name);

Изменение логина пользователя. user_id ID пользователя, логин которого необходимо заменить. new_name новый логин пользователя. Возвращаемые значения: true если успешно выполнено, false если новое имя уже занято другим пользователем.

$dle_api->change_user_pass( int $user_id, string $new_pass);

Изменение пароля пользователя. user_id ID пользователя, пароль которого необходимо заменить. new_pass новый пароль пользователя.

$dle_api->change_user_email( int $user_id, string $new_email);

Изменение E-Mail пользователя. user_id ID пользователя, E-Mail которого необходимо заменить. new_email новый E-Mail пользователя. Возвращаемые значения: 1 - успешно выполнено, -1 - новый E-Mail уже существует, -2 - некорректный E-mail.

$dle_api->change_user_group( int $user_id, int $new_group);

Изменение группы пользователя. user_id ID пользователя, группу которого необходимо заменить. new_group ID новой группы пользователя. Возвращаемые значения: true если успешно выполнено, false если указан ID несуществующей группы.

$dle_api->external_auth( string $login, string $password);

Авторизация по логину и паролю. Возвращаемые значения: true - авторизация успешна, false - логин или пароль не верны.

$dle_api->external_register( string $login, string $password, string $email, int $group);

Регистрация пользователя в базе данных. В функцию передаются: Логин, Пароль, E-mail и номер группы в которой зарегистрировать пользователя. Возвращаемые значения: 1 - успешно выполнено, -1 - новый логин уже существует, -2 - новый E-Mail уже существует, -3 - некорректный E-Mail, -4 - задана несуществующая группа.

$dle_api->send_pm_to_user ( int $user_id, string $subject, string $text, string $from);

Отправка персонального сообщения пользователю. $user_id ID получателя. $subject тема сообщения. $text текст сообщения. $from логин отправителя. Возвращаемые значения: 1 - успешно выполнено, -1 - получатель не найден, 0 - ошибка БД.

$dle_api->load_table ( string $table [, string $fields [, string $where [, bool $multirow [, int $start [, int $limit [, string $sort [, string $sort_order]]]]]]]);

Получение информации из таблицы БД.

$table - название таблицы

$fields - необходимые поля через запятую или * для всех

$where - условие выборки

$multirow - забирать ли один ряд или несколько

$start - начальное значение выборки

$limit - количество записей для выборки, 0 - выбрать все

$sort - поле, по которому осуществляется сортировка

$sort_order - направление сортировки

Возвращается массив с данными, либо false если в БД по указанным параметрам ничего не найдено.

$dle_api->save_to_cache ( string $fname, mixed $vars);

Запись данных в файл кеша. Параметр $fname указывает имя файла кеша без указания его расширения. $vars - данные для записи в кеш.

$dle_api->load_from_cache ( string $fname, [, int $timeout [, string $type]]);

Чтение данных из файла кеша. Параметр $fname указывает имя файла кеша без указания его расширения. Необязательный параметр $timeout указывает количество секунд, в течении которых информацию из кеша считать актуальной. Если файл кеша будет устаревшим, то функция возвращает false. Необязательный параметр $type указывает на тип данных который хранится в кеше, если не 'text' - считаем, что хранился массив и возвращается массив данных.

$dle_api->clean_cache ( [string $name] );

Удаление кеша. Необязательный параметр $name указывает на конкретное имя файла без расширения который нужно удалить

$dle_api->get_cached_files();

Получение массива содержащего названия файлов кеша.

$dle_api->edit_config ( mixed $key, [, string $new_value]);

Изменение и сохранение настроек скрипта.

Параметр $key string или array

string: Название параметра

array: ассоциативный массив параметров

Параметр $new_value - значение параметра. Не используется, если $key массив

$dle_api->take_news ( string $cat, [, string $fields [, int $start [, int $limit [, string $sort [, string $sort_order]]]]]);

Получение новостей

$cat - категории новостей, через запятую

$fields - перечень получаемых полей новостей или * для всех

$start - начальное значение выборки

$limit - количество новостей для выборки, 0 - выбрать все новости

$sort - поле, по которому осуществляется сортировка

$sort_order - направление сортировки

Возвращает ассоциативный 2-х мерный массив с новостями

$dle_api->checkGroup ( int $group );

Проверяет существует ли указанная группа или нет. Возвращаемые значения: true если группа существует, false если группа не существует.

$dle_api->install_admin_module ( string $name, string $title, string $descr, string $icon [, string $perm] );

Установка стороннего модуля в админпанель скрипта.

$name - название модуля, а именно файла .php находящегося в папке engine/inc/, но без расширения файла

$title - заголовок модуля

$descr - описание модуля

$icon - имя иконки для модуля, без указания пути. Иконка обязательно при этом должна находится в папке engine/skins/images/

$perm - информация о группах которым разрешен показ данного модуля. Данное поле может принимать следующие значения: all или ID групп через запятую. Например: 1,2,3. если указано значение all то модуль будет показываться всем пользователям имеющим доступ в админпанель

$dle_api->uninstall_admin_module ( string $name );

Удаление стороннего модуля из админпанели скрипта.

$name - название удаляемого модуля

$dle_api->change_admin_module_perms ( string $name, string $perm );

Изменение группы пользователей которым разрешен показ стороннего модуля в админпанели скрипта.

$name - название модуля

$perm - информация о группах которым разрешен показ данного модуля. Данное поле может принимать следующие значения: all или ID групп через запятую. Например: 1,2,3. если указано значение all то модуль будет показываться всем пользователям имеющим доступ в админпанель

Разработка полноценного API, только начата и на данный момент API имеет пока ограниченный набор функций. Поэтому мы просим всех заинтересованных в данном API разработчиков посетить специально созданную для этого тему на форуме и оставить свои пожелания о том какие новые функции вы хотите видеть в новых версиях. Потому что только опираясь на ваши потребности можно создать полноценный API, охватывающий все аспекты взаимодействия с скриптом.


Запуск функций по крону

Navigation: »No topics above this level«

Запуск функций по крону

 Return to chapter overview

В DataLife Engine присутствует возможность запускать некоторые функции по расписанию. Вы можете создавать автоматически бекап БД, оптимизировать БД, а также создавать карту сайта для поисковиков. Для этого необходима поддержка вашим хостингом функции запуска приложений по расписанию (CRON). Для запуска функций по крону предназначен файл cron.php расположенный в корне вашего сайта. По умолчанию в целях безопасности возможность запуска этого файла отключена, поэтому рассмотрим как можно включить данную функцию.

Во первых мы рекомендуем обязательно в целях безопасности изменить название файла cron.php на любое другое с расширением .php

Далее откройте этот файл в текстовом редакторе и в самом начале найдите строчку

$allow_cron = 0;

Измените ее на

$allow_cron = 1;

Тем самым вы разрешаете этому файлу выполнять функции в автоматическом режиме.

Далее вы можете изменить количество файлов резервных копий БД которые будут хранится на сервере. Для этого найдите чуть ниже строчку

$max_count_files = 5;

где 5 это количество копий БД. Вы можете поставить свое собственное количество файлов. При превышении данного лимита более старые резервные копии базы данных будут автоматически удалятся.

После того как вы произвели необходимые изменения, сохраните данный файл на сервере. Теперь вам нужно добавить данный файл на запуск по расписанию (CRON) время создания и периодичность вы устанавливаете самостоятельно. Подробную инструкцию по добавлению данного файла в функцию CRON вы можете получить у вашего хостинг провайдера.

Файл крона может выполнять следующие операции:

1. Создание резервной копии базы данный. Для запуска данного режима

просто запустите файл cron.php без указания ему параметров

2. Создание карты сайты сайта. Для запуска данного режима

запустите файл с параметром cron.php?cronmode=sitemap

если используется консольный запуск скрипта, то используйте php -f cron.php sitemap

При создании карты сайта по крону, также будет выполняться автоматическое уведомление поисковых систем о наличии карты сайта.

3. Оптимизация базы данных. Для запуска данного режима

запустите файл с параметром cron.php?cronmode=optimize

если используется консольный запуск скрипта, то используйте php -f cron.php optimize

4. Запуск антивируса. Для запуска данного режима

запустите файл с параметром cron.php?cronmode=antivirus

если используется консольный запуск скрипта, то используйте php -f cron.php antivirus

При этом конечно не следует забывать про указание правильных путей как к PHP интерпретатору, так и к самому скрипту от корня вашего сервера.


RSS Экспорт

Navigation: »No topics above this level«

RSS Экспорт

 Return to chapter overview

Движок DataLife Engine поддерживает также экспорт новостей в формате RSS для того чтобы посетители получили экспорт новостей с главной страницы вы должны использовать следующий путь.

http://website.com/rss.xml - с использованием ЧПУ

http://website.com/engine/rss.php - без использования ЧПУ

Для экспорта новостей из определенной категории используйте следующие ссылки

http://website.com/альтернативное имя/rss.xml - с использованием ЧПУ

http://website.com/engine/rss.php?do=cat&category=альтернативное имя - без использования ЧПУ

Для экспорта всех новостей определенного пользователя используйте следующие ссылки

http://website.com/user/имя пользователя/rss.xml - с использованием ЧПУ

http://website.com/engine/rss.php?subaction=allnews&user=имя пользователя - без использования ЧПУ

Для экспорта новостей из определенного каталога используйте следующие ссылки

http://website.com/catalog/идентификатор/rss.xml - с использованием ЧПУ

http://website.com/engine/rss.php?catalog=идентификатор - без использования ЧПУ